]> git.pld-linux.org Git - packages/OpenGL-doc.git/blob - OpenGL-doc.spec
- OpenGL (GL/GLU/GLX/GLW) and glut man pages gathered
[packages/OpenGL-doc.git] / OpenGL-doc.spec
1 # NOTE: more up-to-date docs in PDF format can be found at
2 #       http://opengl.org/documentation/specs/
3 #       but they are non-distributable
4 Summary:        OpenGL Programmers Documentation - manuals
5 Summary(pl.UTF-8):      Dokumentacja dla programistów OpenGL - podręczniki man
6 Name:           OpenGL-doc
7 Version:        1.2.1
8 Release:        1
9 Epoch:          1
10 License:        freely distributable (SGI)
11 Group:          Documentation
12 Source0:        ftp://oss.sgi.com/projects/ogl-sample/download/ogl-sample.20000807.tgz
13 # Source0-md5:  2427a75a3c4345ac248119405f85e447
14 Source1:        http://www.opengl.org/resources/libraries/glut/glut-3.7.tar.gz
15 # Source1-md5:  dc932666e2a1c8a0b148a4c32d111ef3
16 Patch0:         %{name}-macros.patch
17 URL:            http://opengl.org/
18 # headers for man generation
19 BuildRequires:  OpenGL-devel >= 1.2.1
20 BuildRequires:  OpenGL-GLU-devel >= 1.3
21 BuildRequires:  OpenGL-GLX-devel >= 1.3
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 OpenGL API documentation.
27
28 %description -l pl.UTF-8
29 Dokumentacja API OpenGL.
30
31 %package man
32 Summary:        OpenGL API documentation in man format
33 Summary(pl.UTF-8):      Dokumentacja API OpenGL w formacie man
34 Group:          Documentation
35 Obsoletes:      XFree86-OpenGL-doc
36 Conflicts:      glut-devel < 3.7-19
37
38 %description man
39 OpenGL API documentation from Siligon Graphics. This package contains
40 man pages for OpenGL 1.2.1 API, GLU 1.3 API (GL Utility Library) and
41 GLX 1.3 API (OpenGL extensions to the X Server).
42
43 %description man -l pl.UTF-8
44 Pakiet zawiera opracowaną przez firmę Silicon Graphics dokumentację
45 biblioteki graficznej OpenGL. Strony podręcznika man opisują
46 podstawowe funkcje OpenGL 1.2.1, GLU 1.3 (GL Utility Library) oraz GLX
47 1.3 (rozszerzenia 3D dla serwera X).
48
49 %package html
50 Summary:        OpenGL Programmers Documentation - HTML version
51 Summary(pl.UTF-8):      Dokumentacja dla programistów OpenGL - wersja HTML
52 Group:          X11/XFree86
53 Obsoletes:      XFree86-OpenGL-doc-html
54
55 %description html
56 OpenGL API documentation from Siligon Graphics. This set contains HTML
57 documentation for OpenGL 1.2.1 API, GLU 1.3 API (GL Utility Library)
58 and GLX 1.3 API (OpenGL extensions to the X Server).
59
60 %description html -l pl.UTF-8
61 Pakiet zawiera opracowaną przez firmę Silicon Graphics dokumentację
62 biblioteki graficznej OpenGL. Dokumentacja HTML opisuje podstawowe
63 funkcje OpenGL 1.2.1, GLU 1.3 (GL Utility Library) oraz GLX 1.3
64 (rozszerzenia 3D dla serwera X).
65
66 %prep
67 %setup -q -c -a1
68 %patch0 -p0
69
70 # hack
71 install -d usr/include
72 ln -s ../../main/tools/include usr/include/make
73 ln -s /usr/include/GL usr/include/GL
74
75 %build
76 %{__make} -C main/doc/man \
77         ROOT=`pwd`
78
79 install -d html/{gl,glu,glx}
80 cp main/doc/man/mangl/html/*.html html/gl
81 cp main/doc/man/manglu/html/*.html html/glu
82 cp main/doc/man/manglx/html/*.html html/glx
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_mandir}/man3
87
88 installman() {
89         awk '/^\.SH NAME/ { getline; sub(/^(\.B \"|\\fB)/, ""); sub(/\\\(em.*/, ""); gsub(/,/, ""); print; }' $1 | ( read bname names
90                 install $1 $RPM_BUILD_ROOT%{_mandir}/man3/${bname}.3gl
91                 for f in $names ; do
92                         echo ".so ${bname}.3gl" > $RPM_BUILD_ROOT%{_mandir}/man3/${f}.3gl
93                 done
94         )
95 }
96 for f in main/doc/man/{mangl,manglu,manglx}/standard/*.3gl main/doc/man/manglw/*.3gl ; do
97         installman $f
98 done
99
100 %{__make} -C glut-3.7/man/glut install.man \
101         DESTDIR=$RPM_BUILD_ROOT \
102         MANDIR=%{_mandir}/man3
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files man
108 %defattr(644,root,root,755)
109 %{_mandir}/man3/gl[A-Z]*.3gl*
110 %{_mandir}/man3/glu[A-Z]*.3gl*
111 %{_mandir}/man3/GLw*.3gl*
112 %{_mandir}/man3/glut*.3xglut*
113 %{_mandir}/man3/intro.3xglut*
114
115 %files html
116 %defattr(644,root,root,755)
117 %doc html/*
This page took 0.069324 seconds and 3 git commands to generate.