]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- changed versioning to show that it's 0.0.7 snapshot
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA support
4 %bcond_with     arts    # with aRts support
5 %bcond_without  doc     # don't build HTML documentation (from SGML source)
6 %bcond_without  esd     # without esd support
7 %bcond_with     mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
8 #
9 # TODO:
10 # - remove zip BR?
11 #
12 %ifarch athlon
13 %define         with_mmx        1
14 %endif
15
16 Summary:        Open Audio Library
17 Summary(pl):    Otwarta Biblioteka D¼wiêku
18 Name:           OpenAL
19 Version:        0.0.7
20 %define snap    20040416
21 Release:        0.%{snap}.1
22 License:        LGPL
23 Group:          Libraries
24 # from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
25 # (without all Win and Mac stuff and demos)
26 Source0:        %{name}-linuxonly-%{snap}.tar.bz2
27 # Source0-md5:  4f42f20484858452bfc30caa8976415d
28 Patch0:         %{name}-prefix.patch
29 Patch1:         %{name}-info.patch
30 URL:            http://www.openal.org/
31 BuildRequires:  SDL-devel
32 %{?with_alsa:BuildRequires:     alsa-lib-devel}
33 %{?with_arts:BuildRequires:     artsc-devel}
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 %{?with_doc:BuildRequires:      docbook-utils}
37 %{?with_esd:BuildRequires:      esound-devel}
38 %{?with_doc:BuildRequires:      gnome-doc-tools}
39 BuildRequires:  libvorbis-devel
40 %{?with_mmx:BuildRequires:      nasm}
41 BuildRequires:  smpeg-devel
42 BuildRequires:  texinfo
43 BuildRequires:  zip
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 OpenAL, the Open Audio Library, is a joint effort to create an open,
48 vendor-neutral, cross-platform API for interactive, primarily
49 spatialized audio. OpenAL's primary audience are application
50 developers and desktop users that rely on portable standards like
51 OpenGL, for games and other multimedia applications. OpenAL is already
52 supported by a number of hardware vendors and developers.
53
54 %description -l pl
55 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
56 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
57 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
58 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
59 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
60 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
61 dostarczycieli sprzêtu i programistów.
62
63 %package devel
64 Summary:        Headers for OpenAL
65 Summary(pl):    Pliki nag³ówkowe do OpenAL
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description devel
70 Header files for OpenAL-based programs.
71
72 %description devel -l pl
73 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
74 OpenAL.
75
76 %package static
77 Summary:        OpenAL static library
78 Summary(pl):    Statyczna biblioteka OpenAL
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 OpenAL static library.
84
85 %description static -l pl
86 Biblioteka OpenAL do konsolidacji statycznej.
87
88 %prep
89 %setup -q -n openal
90 %patch0 -p1
91 %patch1 -p1
92
93 echo 'AC_DEFUN([AC_HAS_MMX],[$%{?with_mmx:1}%{!?with_mmx:2}])' >> linux/acinclude.m4
94
95 %build
96 cd linux
97 cp -f /usr/share/automake/config.sub .
98 %{__aclocal}
99 %{__autoconf}
100 %{__autoheader}
101 %configure \
102         %{!?debug:--enable-optimization} \
103         %{?with_mmx:--enable-arch-asm} \
104         %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
105         %{?with_arts:--enable-arts} \
106         %{?with_esd:--enable-esd} \
107         --enable-sdl \
108         --enable-vorbis \
109         --enable-smpeg \
110         --enable-capture \
111         --with-gcc=%{__cc}
112
113 %{__make}
114
115 cd ../docs
116 %{?with_doc:%{__make} full-html}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT%{_infodir}
121
122 %{__make} -C linux install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %post devel
134 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
135
136 %postun devel
137 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
138
139 %files
140 %defattr(644,root,root,755)
141 %doc linux/{CREDITS,ChangeLog,NOTES,TODO}
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc linux/doc/LOKI* %{?with_doc:docs/oalspecs-full}
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_includedir}/AL
149 %{_infodir}/openal.info*
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/*.a
This page took 0.103333 seconds and 4 git commands to generate.