]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
e4271d801c60c744a9d59301f9ffbd0583780102
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # ALSA backend
4 %bcond_without  jack            # JACK backend
5 %bcond_without  portaudio       # PortAudio backend
6 %bcond_without  pulseaudio      # PulseAudio backend
7 %bcond_with     sdl             # SDL2 backend
8 %bcond_with     sse2            # force use of SSE2 instructions (x86)
9 %bcond_without  gui             # alsoft-config GUI
10 %bcond_with     qt4             # Qt 4 instead of Qt 5 for GUI
11 %ifarch pentium4 x32 %{x8664}
12 %define with_sse2       1
13 %endif
14 Summary:        Open Audio Library
15 Summary(pl.UTF-8):      Otwarta Biblioteka Dźwięku
16 Name:           OpenAL
17 Version:        1.20.1
18 Release:        1
19 License:        LGPL v2+
20 Group:          Libraries
21 Source0:        http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
22 # Source0-md5:  556695068ce8375b89986083d810fd35
23 Patch0:         %{name}-pc.patch
24 Patch1:         %{name}-nosse.patch
25 URL:            http://www.openal.org/
26 %{?with_sdl:BuildRequires:      SDL2-devel >= 2}
27 %{?with_alsa:BuildRequires:     alsa-lib-devel}
28 BuildRequires:  cmake >= 3.0.2
29 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
30 BuildRequires:  libmysofa-devel
31 BuildRequires:  libstdc++-devel >= 6:4.8.1
32 BuildRequires:  pkgconfig
33 %{?with_portaudio:BuildRequires:        portaudio-devel}
34 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
35 BuildRequires:  rpmbuild(macros) >= 1.605
36 %if %{with gui}
37 %if %{with qt4}
38 BuildRequires:  QtCore-devel >= 4.8.0
39 BuildRequires:  QtGui-devel >= 4.8.0
40 BuildRequires:  qt4-build >= 4.8.0
41 %else
42 BuildRequires:  Qt5Core-devel >= 5
43 BuildRequires:  Qt5Gui-devel >= 5
44 BuildRequires:  Qt5Widgets-devel >= 5
45 BuildRequires:  qt5-build >= 5
46 %endif
47 %endif
48 %{?with_sse2:Requires:  cpuinfo(sse2)}
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 OpenAL, the Open Audio Library, is a joint effort to create an open,
53 vendor-neutral, cross-platform API for interactive, primarily
54 spatialized audio. OpenAL's primary audience are application
55 developers and desktop users that rely on portable standards like
56 OpenGL, for games and other multimedia applications. OpenAL is already
57 supported by a number of hardware vendors and developers.
58
59 %description -l pl.UTF-8
60 OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
61 stworzenia otwartego, niezależnego od producentów, międzyplatformowego
62 interfejsu projektowania aplikacji w części obsługi dźwięku.
63 Biblioteka adresowana jest do twórców aplikacji i użytkowników,
64 którzy wybierają przenośne standardy, jak OpenGL, w grach i
65 aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
66 dostarczycieli sprzętu i programistów.
67
68 %package devel
69 Summary:        Headers for OpenAL
70 Summary(pl.UTF-8):      Pliki nagłówkowe do OpenAL
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 Header files for OpenAL-based programs.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
79 OpenAL.
80
81 %package gui
82 Summary:        OpenAL configuration GUI
83 Summary(pl.UTF-8):      Graficzny interfejs do konfiguracji biblioteki OpenAL
84 Group:          X11/Applications/Sound
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       QtCore >= 4.8.0
87 Requires:       QtGui >= 4.8.0
88
89 %description gui
90 OpenAL configuration GUI.
91
92 %description gui -l pl.UTF-8
93 Graficzny interfejs do konfiguracji biblioteki OpenAL.
94
95 %prep
96 %setup -q -n openal-soft-%{version}
97 %patch0 -p1
98 %patch1 -p1
99
100 %build
101 cd build
102 %cmake .. \
103         %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
104         %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
105         %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
106         %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
107         %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
108         %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
109         -DALSOFT_EXAMPLES=OFF \
110         %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
111         %{?with_qt4:-DALSOFT_NO_QT5=ON} \
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
118
119 %{__make} -C build install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
123
124 # these look not really useful
125 %{__rm} $RPM_BUILD_ROOT%{_bindir}/altonegen
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
136 %attr(755,root,root) %{_bindir}/makemhr
137 %attr(755,root,root) %{_bindir}/openal-info
138 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
140 %{_datadir}/openal
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libopenal.so
145 %{_includedir}/AL
146 %{_pkgconfigdir}/openal.pc
147 %{_libdir}/cmake/OpenAL
148
149 %if %{with gui}
150 %files gui
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/alsoft-config
153 %endif
This page took 0.102238 seconds and 3 git commands to generate.