]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- removed non-existed configure options
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 #
4 %bcond_without  alsa    # without ALSA support
5 %bcond_with     arts    # with aRts support
6 %bcond_without  esd     # without esd support
7 %bcond_without  mmx     # don't use MMX
8 #
9 %ifnarch %{ix86} %{x8664}
10 %undefine       with_mmx
11 %endif
12 %ifarch i386 i486
13 %undefine       with_mmx
14 %endif
15 Summary:        Open Audio Library
16 Summary(pl.UTF-8):      Otwarta Biblioteka Dźwięku
17 Name:           OpenAL
18 Version:        0.0.8
19 Release:        4
20 License:        LGPL
21 Group:          Libraries
22 Source0:        http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
23 # Source0-md5:  641cf53761f35ee979f3e888614797a0
24 URL:            http://www.openal.org/
25 Patch0:         %{name}-alc.h.patch
26 Patch1:         %{name}-pkgconfig.patch
27 BuildRequires:  SDL-devel
28 %{?with_alsa:BuildRequires:     alsa-lib-devel}
29 %{?with_arts:BuildRequires:     artsc-devel}
30 BuildRequires:  autoconf >= 2.56
31 BuildRequires:  automake
32 %{?with_esd:BuildRequires:      esound-devel}
33 %if %{with mmx}
34 # MMX code triggers ICE in gcc 3.3.x
35 BuildRequires:  gcc >= 5:3.4.0
36 %endif
37 BuildRequires:  libtool
38 BuildRequires:  libvorbis-devel
39 %ifarch %{ix86}
40 %{?with_mmx:BuildRequires:      nasm}
41 %endif
42 BuildRequires:  pkgconfig
43 BuildRequires:  smpeg-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %if %{with mmx}
47 %define         specflags_ia32  -mmmx
48 %else
49 %define         specflags_ia32  -U__MMX__
50 %endif
51
52 %description
53 OpenAL, the Open Audio Library, is a joint effort to create an open,
54 vendor-neutral, cross-platform API for interactive, primarily
55 spatialized audio. OpenAL's primary audience are application
56 developers and desktop users that rely on portable standards like
57 OpenGL, for games and other multimedia applications. OpenAL is already
58 supported by a number of hardware vendors and developers.
59
60 %description -l pl.UTF-8
61 OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
62 stworzenia otwartego, niezależnego od producentów, międzyplatformowego
63 interfejsu projektowania aplikacji w części obsługi dźwięku.
64 Biblioteka adresowana jest do twórców aplikacji i użytkowników,
65 którzy wybierają przenośne standardy, jak OpenGL, w grach i
66 aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
67 dostarczycieli sprzętu i programistów.
68
69 %package devel
70 Summary:        Headers for OpenAL
71 Summary(pl.UTF-8):      Pliki nagłówkowe do OpenAL
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description devel
76 Header files for OpenAL-based programs.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
80 OpenAL.
81
82 %package static
83 Summary:        OpenAL static library
84 Summary(pl.UTF-8):      Statyczna biblioteka OpenAL
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 OpenAL static library.
90
91 %description static -l pl.UTF-8
92 Biblioteka OpenAL do konsolidacji statycznej.
93
94 %prep
95 %setup -q -n openal-%{version}
96 %patch0 -p1
97 %patch1 -p1
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I admin/autotools/m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
107         --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
108         --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
109         --enable-sdl --enable-sdl-dlopen \
110         --enable-linux \
111         --enable-null \
112 %ifarch amd64 x86_64 athlon i686 i586
113         --enable-optim-generic \
114 %endif
115         --enable-waveout \
116         --enable-vorbis --enable-vorbis-dlopen \
117         --enable-mp3 --enable-mp3-dlopen
118
119 %{__make} -j1
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc ChangeLog NOTES TODO
136 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.?
138
139 %files devel
140 %defattr(644,root,root,755)
141 %doc common/specification/OpenAL1-1Spec.pdf
142 %attr(755,root,root) %{_bindir}/openal-config
143 %attr(755,root,root) %{_libdir}/libopenal.so
144 %{_libdir}/libopenal.la
145 %{_includedir}/AL
146 %{_pkgconfigdir}/openal.pc
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libopenal.a
This page took 0.047621 seconds and 3 git commands to generate.