]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- cleanups, rel 1
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # TODO:
3 # - Build stops at:
4 # arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
5 # arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
6 # arch/i386/x86_floatmul.c: In function `_alFloatMul':
7 #arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
8 # Please submit a full bug report,
9 #
10 # - autoconf provides undefined macro....
11
12 # Conditional build:
13 #
14 %bcond_without  alsa    # without ALSA support
15 %bcond_with     arts    # with aRts support
16 %bcond_without  esd     # without esd support
17 %bcond_with     mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
18
19 Summary:        Open Audio Library
20 Summary(pl):    Otwarta Biblioteka D¼wiêku
21 Name:           OpenAL
22 Version:        0.0.8
23 Release:        1
24 License:        LGPL
25 Group:          Libraries
26 Source0:        http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
27 # Source0-md5:  641cf53761f35ee979f3e888614797a0
28 URL:            http://www.openal.org/
29 BuildRequires:  SDL-devel
30 %{?with_alsa:BuildRequires:     alsa-lib-devel}
31 %{?with_arts:BuildRequires:     artsc-devel}
32 %{?with_esd:BuildRequires:      esound-devel}
33 BuildRequires:  libvorbis-devel
34 %{?with_mmx:BuildRequires:      nasm}
35 BuildRequires:  smpeg-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 OpenAL, the Open Audio Library, is a joint effort to create an open,
40 vendor-neutral, cross-platform API for interactive, primarily
41 spatialized audio. OpenAL's primary audience are application
42 developers and desktop users that rely on portable standards like
43 OpenGL, for games and other multimedia applications. OpenAL is already
44 supported by a number of hardware vendors and developers.
45
46 %description -l pl
47 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
48 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
49 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
50 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
51 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
52 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
53 dostarczycieli sprzêtu i programistów.
54
55 %package devel
56 Summary:        Headers for OpenAL
57 Summary(pl):    Pliki nag³ówkowe do OpenAL
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description devel
62 Header files for OpenAL-based programs.
63
64 %description devel -l pl
65 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
66 OpenAL.
67
68 %package static
69 Summary:        OpenAL static library
70 Summary(pl):    Statyczna biblioteka OpenAL
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 OpenAL static library.
76
77 %description static -l pl
78 Biblioteka OpenAL do konsolidacji statycznej.
79
80 %prep
81 %setup -q -n openal-%{version}
82
83 %build
84 %configure \
85         %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
86         %{?with_arts:--enable-arts --enable-arts-dlopen} \
87         %{?with_esd:--enable-esd --enable-esd-dlopen} \
88         --enable-sdl --enable-sdl-dlopen \
89         --enable-capture \
90         --enable-linux \
91         --enable-null \
92         --enable-waveout \
93         --enable-vorbis --enable-vorbis-dlopen \
94         --enable-mp3 --enable-mp3-dlopen \
95         --with-gcc=%{__cc}
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc ChangeLog NOTES TODO
114 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/*-config
119 %attr(755,root,root) %{_libdir}/lib*.so
120 %{_libdir}/*.la
121 %{_pkgconfigdir}/*
122 %{_includedir}/AL
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/*.a
This page took 0.02986 seconds and 3 git commands to generate.