]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- kill needless BR zip
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA support
4 %bcond_with     arts    # with aRts support
5 %bcond_without  doc     # don't build HTML documentation (from SGML source)
6 %bcond_without  esd     # without esd support
7 %bcond_with     mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
8
9 %define _branch Linux_Spec1-0
10
11 Summary:        Open Audio Library
12 Summary(pl):    Otwarta Biblioteka D¼wiêku
13 Name:           OpenAL
14 Version:        0.0.8
15 %define snap    20051015
16 Release:        0.%{snap}.1
17 License:        LGPL
18 Group:          Libraries
19 # from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
20 # (without all Win and Mac stuff and demos)
21 Source0:        %{name}-%{_branch}-%{snap}.tar.bz2
22 # Source0-md5:  013a571cf588bec1d3a5628b5ed527ea
23 Patch0:         %{name}-prefix.patch
24 Patch1:         %{name}-info.patch
25 URL:            http://www.openal.org/
26 BuildRequires:  SDL-devel
27 %{?with_alsa:BuildRequires:     alsa-lib-devel}
28 %{?with_arts:BuildRequires:     artsc-devel}
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %{?with_doc:BuildRequires:      docbook-utils}
32 %{?with_esd:BuildRequires:      esound-devel}
33 %{?with_doc:BuildRequires:      gnome-doc-tools}
34 BuildRequires:  libvorbis-devel
35 %{?with_mmx:BuildRequires:      nasm}
36 BuildRequires:  smpeg-devel
37 BuildRequires:  texinfo
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 OpenAL, the Open Audio Library, is a joint effort to create an open,
42 vendor-neutral, cross-platform API for interactive, primarily
43 spatialized audio. OpenAL's primary audience are application
44 developers and desktop users that rely on portable standards like
45 OpenGL, for games and other multimedia applications. OpenAL is already
46 supported by a number of hardware vendors and developers.
47
48 %description -l pl
49 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
50 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
51 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
52 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
53 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
54 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
55 dostarczycieli sprzêtu i programistów.
56
57 %package devel
58 Summary:        Headers for OpenAL
59 Summary(pl):    Pliki nag³ówkowe do OpenAL
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 Header files for OpenAL-based programs.
65
66 %description devel -l pl
67 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
68 OpenAL.
69
70 %package static
71 Summary:        OpenAL static library
72 Summary(pl):    Statyczna biblioteka OpenAL
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 OpenAL static library.
78
79 %description static -l pl
80 Biblioteka OpenAL do konsolidacji statycznej.
81
82 %prep
83 %setup -q -n %{name}-%{_branch}-%{snap}
84 %patch0 -p1
85 %patch1 -p1
86
87 cp CREDITS docs
88
89 %build
90 cd linux
91 cp -f /usr/share/automake/config.sub .
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %configure \
96         %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
97         %{?with_arts:--enable-arts --enable-arts-dlopen} \
98         %{?with_esd:--enable-esd --enable-esd-dlopen} \
99         --enable-sdl \
100         --enable-vorbis \
101         --enable-smpeg \
102         --enable-capture \
103         --with-gcc=%{__cc}
104
105 %{__make}
106
107 cd ../docs/spec1-0
108 %{?with_doc:%{__make} full-html}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_infodir}
113
114 %{__make} -C linux install \
115         DESTLIB='$(DESTDIR)%{_libdir}' \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %post devel
127 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
128
129 %postun devel
130 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
131
132 %files
133 %defattr(644,root,root,755)
134 %doc linux/{CREDITS,ChangeLog,NOTES,TODO}
135 %attr(755,root,root) %{_libdir}/lib*.so.*.*
136
137 %files devel
138 %defattr(644,root,root,755)
139 %doc linux/doc/LOKI* %{?with_doc:docs/spec1-0/oalspecs-full docs/spec1-1/OpenAL1-1Spec.pdf}
140 %attr(755,root,root) %{_libdir}/lib*.so
141 %attr(755,root,root) %{_bindir}/*-config
142 %{_pkgconfigdir}/*
143 %{_includedir}/AL
144 %{_infodir}/openal.info*
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/*.a
This page took 0.612391 seconds and 3 git commands to generate.