]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
3c023e8495167a2ba54b9330a56bb5c099875508
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 # TODO:
4 # - Build stops at:
5 # arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
6 # arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
7 # arch/i386/x86_floatmul.c: In function `_alFloatMul':
8 #arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
9 # Please submit a full bug report,
10 #
11 # - autoconf provides undefined macro....
12
13 %bcond_without  alsa    # without ALSA support
14 %bcond_with     arts    # with aRts support
15 %bcond_without  doc     # don't build HTML documentation (from SGML source)
16 %bcond_without  esd     # without esd support
17 %bcond_with     mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
18
19 Summary:        Open Audio Library
20 Summary(pl):    Otwarta Biblioteka D¼wiêku
21 Name:           OpenAL
22 Version:        0.0.8
23 Release:        0.1
24 License:        LGPL
25 Group:          Libraries
26 Source0:        http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
27 # Source0-md5:  641cf53761f35ee979f3e888614797a0
28 #Patch0:                %{name}-prefix.patch
29 #Patch1:                %{name}-info.patch
30 URL:            http://www.openal.org/
31 BuildRequires:  SDL-devel
32 %{?with_alsa:BuildRequires:     alsa-lib-devel}
33 %{?with_arts:BuildRequires:     artsc-devel}
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 %{?with_doc:BuildRequires:      docbook-utils}
37 %{?with_esd:BuildRequires:      esound-devel}
38 %{?with_doc:BuildRequires:      gnome-doc-tools}
39 BuildRequires:  libvorbis-devel
40 %{?with_mmx:BuildRequires:      nasm}
41 BuildRequires:  smpeg-devel
42 BuildRequires:  texinfo
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 OpenAL, the Open Audio Library, is a joint effort to create an open,
47 vendor-neutral, cross-platform API for interactive, primarily
48 spatialized audio. OpenAL's primary audience are application
49 developers and desktop users that rely on portable standards like
50 OpenGL, for games and other multimedia applications. OpenAL is already
51 supported by a number of hardware vendors and developers.
52
53 %description -l pl
54 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
55 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
56 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
57 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
58 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
59 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
60 dostarczycieli sprzêtu i programistów.
61
62 %package devel
63 Summary:        Headers for OpenAL
64 Summary(pl):    Pliki nag³ówkowe do OpenAL
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description devel
69 Header files for OpenAL-based programs.
70
71 %description devel -l pl
72 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
73 OpenAL.
74
75 %package static
76 Summary:        OpenAL static library
77 Summary(pl):    Statyczna biblioteka OpenAL
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 OpenAL static library.
83
84 %description static -l pl
85 Biblioteka OpenAL do konsolidacji statycznej.
86
87 %prep
88 %setup -q -n openal-%{version}
89 #%patch0 -p1
90 #%patch1 -p1
91
92 %build
93 cp -f /usr/share/automake/config.sub .
94 #%{__aclocal}
95 #%{__autoconf}
96 #%{__autoheader}
97 %configure \
98         %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
99         %{?with_arts:--enable-arts --enable-arts-dlopen} \
100         %{?with_esd:--enable-esd --enable-esd-dlopen} \
101         --enable-sdl \
102         --enable-vorbis \
103         --enable-smpeg \
104         --enable-capture \
105         --with-gcc=%{__cc}
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{_infodir}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %post devel
123 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
124
125 %postun devel
126 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
127
128 %files
129 %defattr(644,root,root,755)
130 %doc ChangeLog NOTES TODO
131 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/*-config
136 %attr(755,root,root) %{_libdir}/lib*.so
137 %{_libdir}/*.la
138 %{_pkgconfigdir}/*
139 %{_includedir}/AL
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/*.a
This page took 0.168894 seconds and 2 git commands to generate.