]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- autoize
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 #
4 %bcond_without  alsa    # without ALSA support
5 %bcond_with     arts    # with aRts support
6 %bcond_without  esd     # without esd support
7 %bcond_without  mmx     # don't use MMX
8 #
9 %ifnarch %{ix86} %{x8664}
10 %undefine       with_mmx
11 %endif
12 %ifarch i386 i486
13 %undefine       with_mmx
14 %endif
15 Summary:        Open Audio Library
16 Summary(pl):    Otwarta Biblioteka D¼wiêku
17 Name:           OpenAL
18 Version:        0.0.8
19 Release:        1
20 License:        LGPL
21 Group:          Libraries
22 Source0:        http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
23 # Source0-md5:  641cf53761f35ee979f3e888614797a0
24 URL:            http://www.openal.org/
25 BuildRequires:  SDL-devel
26 %{?with_alsa:BuildRequires:     alsa-lib-devel}
27 %{?with_arts:BuildRequires:     artsc-devel}
28 %{?with_esd:BuildRequires:      esound-devel}
29 %if %{with mmx}
30 # MMX code triggers ICE in gcc 3.3.x
31 BuildRequires:  gcc >= 5:3.4.0
32 %endif
33 BuildRequires:  libvorbis-devel
34 %ifarch %{ix86}
35 %{?with_mmx:BuildRequires:      nasm}
36 %endif
37 BuildRequires:  pkgconfig
38 BuildRequires:  smpeg-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %if %{with mmx}
42 %define         specflags_ia32  -mmmx
43 %else
44 %define         specflags_ia32  -U__MMX__
45 %endif
46
47 %description
48 OpenAL, the Open Audio Library, is a joint effort to create an open,
49 vendor-neutral, cross-platform API for interactive, primarily
50 spatialized audio. OpenAL's primary audience are application
51 developers and desktop users that rely on portable standards like
52 OpenGL, for games and other multimedia applications. OpenAL is already
53 supported by a number of hardware vendors and developers.
54
55 %description -l pl
56 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
57 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
58 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
59 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
60 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
61 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
62 dostarczycieli sprzêtu i programistów.
63
64 %package devel
65 Summary:        Headers for OpenAL
66 Summary(pl):    Pliki nag³ówkowe do OpenAL
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description devel
71 Header files for OpenAL-based programs.
72
73 %description devel -l pl
74 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
75 OpenAL.
76
77 %package static
78 Summary:        OpenAL static library
79 Summary(pl):    Statyczna biblioteka OpenAL
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 OpenAL static library.
85
86 %description static -l pl
87 Biblioteka OpenAL do konsolidacji statycznej.
88
89 %prep
90 %setup -q -n openal-%{version}
91
92 %build
93 cp -f /usr/share/automake/config.sub .
94 %{__libtoolize}
95 %{__aclocal} -I admin/autotools/m4
96 %{__autoconf}
97 %{__autoheader}
98 %configure \
99         --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
100         --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
101         --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
102         --enable-sdl --enable-sdl-dlopen \
103         --enable-capture \
104         --enable-linux \
105         --enable-null \
106 %ifarch amd64 x86_64 athlon i686 i586
107         --enable-optim-generic \
108 %endif
109         --enable-waveout \
110         --enable-vorbis --enable-vorbis-dlopen \
111         --enable-mp3 --enable-mp3-dlopen \
112         --with-gcc="%{__cc}"
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc ChangeLog NOTES TODO
131 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %doc common/specification/OpenAL1-1Spec.pdf
136 %attr(755,root,root) %{_bindir}/openal-config
137 %attr(755,root,root) %{_libdir}/libopenal.so
138 %{_libdir}/libopenal.la
139 %{_includedir}/AL
140 %{_pkgconfigdir}/openal.pc
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libopenal.a
This page took 0.126835 seconds and 3 git commands to generate.