]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- fix packaging config file
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # without ALSA support
4 %bcond_without  portaudio       # without PortAudio support
5 %bcond_without  pulseaudio      # without PulseAudio support
6 #
7 Summary:        Open Audio Library
8 Summary(pl.UTF-8):      Otwarta Biblioteka Dźwięku
9 Name:           OpenAL
10 Version:        1.14
11 Release:        3
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
15 # Source0-md5:  3d8b86c21a2f87a2a5e60f78f3b3f03d
16 Patch0:         %{name}-link.patch
17 #URL:           http://kcat.strangesoft.net/openal.html
18 URL:            http://www.openal.org/
19 %{?with_alsa:BuildRequires:     alsa-lib-devel}
20 BuildRequires:  cmake
21 %{?with_portaudio:BuildRequires:        portaudio-devel}
22 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 OpenAL, the Open Audio Library, is a joint effort to create an open,
27 vendor-neutral, cross-platform API for interactive, primarily
28 spatialized audio. OpenAL's primary audience are application
29 developers and desktop users that rely on portable standards like
30 OpenGL, for games and other multimedia applications. OpenAL is already
31 supported by a number of hardware vendors and developers.
32
33 %description -l pl.UTF-8
34 OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
35 stworzenia otwartego, niezależnego od producentów, międzyplatformowego
36 interfejsu projektowania aplikacji w części obsługi dźwięku.
37 Biblioteka adresowana jest do twórców aplikacji i użytkowników,
38 którzy wybierają przenośne standardy, jak OpenGL, w grach i
39 aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
40 dostarczycieli sprzętu i programistów.
41
42 %package devel
43 Summary:        Headers for OpenAL
44 Summary(pl.UTF-8):      Pliki nagłówkowe do OpenAL
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for OpenAL-based programs.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
53 OpenAL.
54
55 %prep
56 %setup -q -n openal-soft-%{version}
57 %patch0 -p1
58
59 %build
60 %cmake . \
61         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
62         -DCMAKE_VERBOSE_MAKEFILE=1 \
63         -DEXAMPLES=OFF \
64         -DLIB_INSTALL_DIR=%{_lib} \
65         %{!?with_alsa:-DALSA=OFF} \
66         %{!?with_portaudio:-DPORTAUDIO=OFF} \
67         %{!?with_pulseaudio:-DPULSEAUDIO=OFF}
68
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
89 %attr(755,root,root) %{_bindir}/makehrtf
90 %attr(755,root,root) %{_bindir}/openal-info
91 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
92 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
93
94 %files devel
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/libopenal.so
97 %{_includedir}/AL
98 %{_pkgconfigdir}/openal.pc
This page took 0.094126 seconds and 3 git commands to generate.