]> git.pld-linux.org Git - packages/ORBit2.git/commitdiff
- added idl-gtk-doc patch (adjust orbit-idl-2 to generate code parsable by current...
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 12 Mar 2021 20:13:15 +0000 (21:13 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 12 Mar 2021 20:13:15 +0000 (21:13 +0100)
- modernize spec, release 10

ORBit2-idl-gtk-doc.patch [new file with mode: 0644]
ORBit2.spec

diff --git a/ORBit2-idl-gtk-doc.patch b/ORBit2-idl-gtk-doc.patch
new file mode 100644 (file)
index 0000000..ed859a1
--- /dev/null
@@ -0,0 +1,23 @@
+--- ORBit2-2.14.19/src/idl-compiler/orbit-idl-c-headers.c.orig 2010-02-09 13:05:35.000000000 +0100
++++ ORBit2-2.14.19/src/idl-compiler/orbit-idl-c-headers.c      2021-03-12 20:48:55.042479965 +0100
+@@ -634,7 +634,7 @@
+   ctmp = orbit_cbe_get_typespec_str(tree);
+   fprintf(ci->fh,
+-        "typedef struct { CORBA_unsigned_short _digits; CORBA_short _scale; CORBA_char _value[%d]; } %s;\n",
++        "typedef struct {\n  CORBA_unsigned_short _digits;\n  CORBA_short _scale;\n  CORBA_char _value[%d];\n} %s;\n",
+         (int) (IDL_INTEGER(IDL_TYPE_FIXED(tree).positive_int_const).value + 2)/2,
+         ctmp);
+   g_free(ctmp);
+@@ -714,9 +714,9 @@
+       fprintf(ci->fh, "#if !defined(_%s_defined)\n#define _%s_defined 1\n",
+             fullname, fullname);
+-      fprintf(ci->fh, "typedef struct { CORBA_unsigned_long _maximum, _length; ");
++      fprintf(ci->fh, "typedef struct {\n  CORBA_unsigned_long _maximum, _length;\n  ");
+       orbit_cbe_write_typespec(ci->fh, IDL_TYPE_SEQUENCE(tree).simple_type_spec);
+-      fprintf(ci->fh, "* _buffer; CORBA_boolean _release; } ");
++      fprintf(ci->fh, "* _buffer;\n  CORBA_boolean _release;\n} ");
+       orbit_cbe_write_typespec(ci->fh, tree);
+       fprintf(ci->fh, ";\n#endif\n");
+       ch_type_alloc_and_tc(tree, rinfo, ci, TRUE);
index 1273407e21351a5ef64d043e81d4bc38c9b1b1b2..0375ef259c256d51b81814dc3981e1a7661c8958 100644 (file)
@@ -1,22 +1,23 @@
 #
 # Conditional build:
-%bcond_without apidocs         # disable gtk-doc
-%bcond_without static_libs     # don't build static library
+%bcond_without apidocs         # gtk-doc based API documentation
+%bcond_without static_libs     # static libraries
 
 Summary:       High-performance CORBA Object Request Broker
 Summary(fr.UTF-8):     Requète d'Objects CORBA
 Summary(pl.UTF-8):     Wysoko wydajny CORBA Object Request Broker
 Name:          ORBit2
 Version:       2.14.19
-Release:       9
+Release:       10
 Epoch:         1
 License:       GPL v2+/LGPL v2+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
+Source0:       https://download.gnome.org/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
 # Source0-md5: 7082d317a9573ab338302243082d10d1
 Patch0:                %{name}-pthread.patch
 Patch1:                %{name}-build-fix.patch
-URL:           https://projects-old.gnome.org/ORBit2/
+Patch2:                %{name}-idl-gtk-doc.patch
+URL:           https://developer.gnome.org/ORBit2/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake >= 1:1.9
 BuildRequires: docbook-dtd412-xml
@@ -27,11 +28,12 @@ BuildRequires:      indent
 BuildRequires: libIDL-devel >= 0.8.10
 BuildRequires: libtool
 BuildRequires: pkgconfig >= 1:0.18
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.197
 Requires:      glib2 >= 1:2.14.1
 Requires:      libIDL >= 0.8.10
 Provides:      linc = 1.1.1
-Obsoletes:     ORBit2-automake
+Obsoletes:     ORBit2-automake < 1:2.12.5
 Obsoletes:     libORBit2_0
 Obsoletes:     linc
 Conflicts:     libbonobo < 2.3.2
@@ -130,8 +132,9 @@ skonsolidowanych statycznie używających technologii CORBA.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
-%if !%{with apidocs}
+%if %{without apidocs}
 echo 'EXTRA_DIST=' > gtk-doc.make
 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
 %endif
This page took 0.091264 seconds and 4 git commands to generate.