]> git.pld-linux.org Git - packages/ORBit2.git/commitdiff
- fixes for automake 1.5.
authorkloczek <kloczek@pld-linux.org>
Wed, 6 Feb 2002 05:27:30 +0000 (05:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ORBit2-Makefile.shared -> 1.1
    ORBit2-am15.patch -> 1.1

ORBit2-Makefile.shared [new file with mode: 0644]
ORBit2-am15.patch [new file with mode: 0644]

diff --git a/ORBit2-Makefile.shared b/ORBit2-Makefile.shared
new file mode 100644 (file)
index 0000000..d4fc7e1
--- /dev/null
@@ -0,0 +1,19 @@
+IDL_COMPILER = $(top_builddir)/src/idl-compiler/orbit-idl-2
+
+%.h %-stubs.c %-skels.c %-common.c %-imodule.c %-skelimpl.c: $(IDL_DIR)%.idl $(IDL_COMPILER)
+       -(rm -f $(*).h $(*)-stubs.c $(*)-skels.c $(*)-common.c $(*)-imodule.c $(*)-skelimpl.c || true) > /dev/null
+       $(IDL_COMPILER) $(IDL_FLAGS) --deps $(*D)/.deps/$(*F).idl.P $< 
+       for I in $(*).h $(*)-stubs.c $(*)-skels.c $(*)-common.c $(*)-imodule.c $(*)-skelimpl.c; do \
+               if test -f $$I; then \
+                       sed -e 's,OObject,Object,g' -e 's,TTypeCode,TypeCode,g' $$I > $$I.out; \
+                       mv $$I.out $$I ; \
+               fi; \
+       done
+
+if MAINTAINER_MODE
+IDL_DEPS_MAGIC := $(shell mkdir .deps > /dev/null 2>&1 || :)
+IDL_DEP_FILES = $(IDL_FILES:%.idl=.deps/%.idl.P)
+-include $(IDL_DEP_FILES)
+distclean-local:
+       -rm -rf .deps
+endif
diff --git a/ORBit2-am15.patch b/ORBit2-am15.patch
new file mode 100644 (file)
index 0000000..5f6647b
--- /dev/null
@@ -0,0 +1,33 @@
+--- ORBit2-2.3.104/src/orb/dynamic/Makefile.am~        Wed Feb  6 06:14:58 2002
++++ ORBit2-2.3.104/src/orb/dynamic/Makefile.am Wed Feb  6 06:14:58 2002
+@@ -15,8 +15,6 @@
+       $(ORBIT_DEBUG_CFLAGS)                           \
+       $(ORBIT_CFLAGS)
+-DYNAMIC_IDLOUT=dynamic-defs-common.c
+-
+ IDL_FLAGS= -I$(top_srcdir)/src/idl/CORBA_PIDL                 \
+       --define=Object=OObject --define=TypeCode=TTypeCode     \
+       -I$(top_srcdir)/src/idl/CORBA                           \
+--- ORBit2-2.3.104/src/orb/orb-core/Makefile.am~       Wed Feb  6 06:24:16 2002
++++ ORBit2-2.3.104/src/orb/orb-core/Makefile.am        Wed Feb  6 06:24:16 2002
+@@ -49,7 +49,6 @@
+ IFACE_IDLOUT=orbit-interface-common.c
+ $(liborb_core_la_OBJECTS) : $(BUILT_SOURCES)
+-IDL_COMPILER = $(top_builddir)/src/idl-compiler/orbit-idl-2
+ IDL_FLAGS = -I$(top_srcdir)/src/idl/CORBA_PIDL                        \
+       -I$(top_srcdir)/src/idl/CORBA                           \
+--- ORBit2-2.3.104/Makefile.am~        Wed Feb  6 06:25:12 2002
++++ ORBit2-2.3.104/Makefile.am Wed Feb  6 06:25:12 2002
+@@ -8,7 +8,8 @@
+       ORBit2.m4              \
+       ORBit.spec             \
+       HACKING                \
+-      MAINTAINERS
++      MAINTAINERS            \
++      Makefile.shared
+ rpms: distcheck
+       rpm -ta $(top_builddir)/@PACKAGE@-@VERSION@.tar.gz
This page took 0.072194 seconds and 4 git commands to generate.