]> git.pld-linux.org Git - packages/ORBit2.git/blob - ORBit2.spec
df387afdeeadd2d1a403797a763feacb74cf8ef7
[packages/ORBit2.git] / ORBit2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5
6 Summary:        High-performance CORBA Object Request Broker
7 Summary(fr.UTF-8):      Requète d'Objects CORBA
8 Summary(pl.UTF-8):      Wysoko wydajny CORBA Object Request Broker
9 Name:           ORBit2
10 Version:        2.14.19
11 Release:        9
12 Epoch:          1
13 License:        GPL v2+/LGPL v2+
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
16 # Source0-md5:  7082d317a9573ab338302243082d10d1
17 Patch0:         %{name}-pthread.patch
18 Patch1:         %{name}-build-fix.patch
19 URL:            https://projects-old.gnome.org/ORBit2/
20 BuildRequires:  autoconf >= 2.54
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  docbook-dtd412-xml
23 BuildRequires:  flex
24 BuildRequires:  glib2-devel >= 1:2.14.1
25 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
26 BuildRequires:  indent
27 BuildRequires:  libIDL-devel >= 0.8.10
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig >= 1:0.18
30 BuildRequires:  rpmbuild(macros) >= 1.197
31 Requires:       glib2 >= 1:2.14.1
32 Requires:       libIDL >= 0.8.10
33 Provides:       linc = 1.1.1
34 Obsoletes:      ORBit2-automake
35 Obsoletes:      libORBit2_0
36 Obsoletes:      linc
37 Conflicts:      libbonobo < 2.3.2
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 ORBit is a high-performance CORBA (Common Object Request Broker
42 Architecture) ORB (object request broker). It allows programs to send
43 requests and receive replies from other programs, regardless of the
44 locations of the two programs. CORBA is an architecture that enables
45 communication between program objects, regardless of the programming
46 language they're written in or the operating system they run on.
47
48 %description -l fr.UTF-8
49 ORBit est un ORB CORBA avec support pour le language C. Il permet a
50 des programmes d'envoyer des requètes et recevoir de réponses d'autres
51 programmes, indépendement de l'endroit ou sont les deux programmes.
52
53 %description -l pl.UTF-8
54 ORBit to wysokiej wydajności CORBA (Common Object Request Broker
55 Architecture) ORB (object request broker). Pozwala na wysyłanie próśb
56 i otrzymywanie odpowiedzi od innych programów bez znajomości położenia
57 tych dwóch programów.
58
59 %package apidocs
60 Summary:        ORBit API documentation
61 Summary(pl.UTF-8):      Dokumentacja API ORBit
62 Group:          Documentation
63 Requires:       gtk-doc-common
64 %if "%{_rpmversion}" >= "5"
65 BuildArch:      noarch
66 %endif
67
68 %description apidocs
69 ORBit API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API ORBit.
73
74 %package devel
75 Summary:        Header files, and utilities for ORBit
76 Summary(fr.UTF-8):      Librairies statiques et fichiers entête pour ORBit
77 Summary(pl.UTF-8):      Pliki nagłówkowe i użytki dla ORBit
78 Group:          Development/Libraries
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80 Requires:       glib2-devel >= 1:2.14.1
81 Requires:       indent
82 Requires:       libIDL-devel >= 0.8.10
83 Provides:       linc-devel = 1.1.1
84 Obsoletes:      libORBit2_0-devel
85 Obsoletes:      linc-devel
86
87 %description devel
88 devel ORBit is a high-performance CORBA ORB with support for the C
89 language. It allows programs to send requests and receive replies from
90 other programs, regardless of the locations of the two programs.
91
92 This package includes the header files and utilities neecessary to
93 write programs that use CORBA technology.
94
95 %description devel -l fr.UTF-8
96 Librairies statiques et fichiers entête requis pour le development ou
97 la compilation de programmes utilisant ORBit.
98
99 %description devel -l pl.UTF-8
100 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
101 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
102 programów bez znajomości położenia tych dwóch programów.
103
104 Ten pakiet zawiera pliki nagłówkowe oraz użytki potrzebne do pisania
105 programów używających technologi CORBA.
106
107 %package static
108 Summary:        Static libraries for ORBit
109 Summary(pl.UTF-8):      Biblioteki statyczne dla ORBit
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
112 Provides:       linc-static = 1.1.1
113 Obsoletes:      linc-static
114
115 %description static
116 ORBit is a high-performance CORBA ORB with support for the C language.
117 It allows programs to send requests and receive replies from other
118 programs, regardless of the locations of the two programs.
119
120 This package includes static libraries neecessary to write programs
121 statically linked that use CORBA technology.
122
123 %description static -l pl.UTF-8
124 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
125 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
126 programów bez znajomości położenia tych dwóch programów.
127
128 Ten pakiet zawiera biblioteki statyczne potrzebne do pisania programów
129 skonsolidowanych statycznie używających technologii CORBA.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135
136 %if !%{with apidocs}
137 echo 'EXTRA_DIST=' > gtk-doc.make
138 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
139 %endif
140
141 %build
142 %{?with_apidocs:%{__gtkdocize}}
143 %{__libtoolize}
144 %{__aclocal}
145 %{__autoconf}
146 %{__autoheader}
147 %{__automake}
148 %configure \
149         --with-html-dir=%{_gtkdocdir} \
150         %{!?with_static_libs:--disable-static} \
151         %{?with_apidocs:--enable-gtk-doc}
152 %{__make} -j1
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156
157 %{__make} -j1 install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 # obsoleted by pkg-config
161 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
162 # no static module - shut up check-files
163 %{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.{la,a}
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %files
172 %defattr(644,root,root,755)
173 %doc AUTHORS NEWS README
174 %attr(755,root,root) %{_bindir}/ior-decode-2
175 %attr(755,root,root) %{_bindir}/linc-cleanup-sockets
176 %attr(755,root,root) %{_bindir}/orbit-idl-2
177 %attr(755,root,root) %{_bindir}/typelib-dump
178 %attr(755,root,root) %{_libdir}/libORBit-2.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libORBit-2.so.0
180 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libORBit-imodule-2.so.0
182 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libORBitCosNaming-2.so.0
184 %dir %{_libdir}/orbit-2.0
185 %attr(755,root,root) %{_libdir}/orbit-2.0/Everything_module.so
186 %{_datadir}/idl/orbit-2.0
187
188 %if %{with apidocs}
189 %files apidocs
190 %defattr(644,root,root,755)
191 %{_gtkdocdir}/%{name}
192 %endif
193
194 %files devel
195 %defattr(644,root,root,755)
196 %doc ChangeLog
197 %attr(755,root,root) %{_bindir}/orbit2-config
198 %attr(755,root,root) %{_libdir}/libORBit-2.so
199 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so
200 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so
201 # static-only library
202 %{_libdir}/libname-server-2.a
203 %{_includedir}/orbit-2.0
204 %{_pkgconfigdir}/ORBit-2.0.pc
205 %{_pkgconfigdir}/ORBit-CosNaming-2.0.pc
206 %{_pkgconfigdir}/ORBit-idl-2.0.pc
207 %{_pkgconfigdir}/ORBit-imodule-2.0.pc
208 %{_aclocaldir}/ORBit2.m4
209
210 %if %{with static_libs}
211 %files static
212 %defattr(644,root,root,755)
213 %{_libdir}/libORBit-2.a
214 %{_libdir}/libORBit-imodule-2.a
215 %{_libdir}/libORBitCosNaming-2.a
216 %endif
This page took 0.084275 seconds and 2 git commands to generate.