]> git.pld-linux.org Git - packages/ORBit2.git/blob - ORBit2.spec
- without apidocs and static_libs bconds
[packages/ORBit2.git] / ORBit2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        High-performance CORBA Object Request Broker
7 Summary(fr.UTF-8):      Requète d'Objects CORBA
8 Summary(pl.UTF-8):      Wysoko wydajny CORBA Object Request Broker
9 Name:           ORBit2
10 Version:        2.14.14
11 Release:        1
12 Epoch:          1
13 License:        GPL v2+/LGPL v2+
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
16 # Source0-md5:  f288e9a4354fce14cf6bb35140ac5d9b
17 Patch0:         %{name}-pthread.patch
18 URL:            http://www.gnome.org/projects/ORBit2/
19 BuildRequires:  autoconf >= 2.54
20 BuildRequires:  automake >= 1:1.9
21 BuildRequires:  flex
22 BuildRequires:  glib2-devel >= 1:2.14.1
23 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
24 BuildRequires:  indent
25 BuildRequires:  libIDL-devel >= 0.8.10
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig >= 1:0.14.0
28 BuildRequires:  rpmbuild(macros) >= 1.197
29 Requires:       glib2 >= 1:2.14.1
30 Requires:       libIDL >= 0.8.10
31 Provides:       linc = 1.1.1
32 Obsoletes:      ORBit2-automake
33 Obsoletes:      libORBit2_0
34 Obsoletes:      linc
35 Conflicts:      libbonobo < 2.3.2
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 ORBit is a high-performance CORBA (Common Object Request Broker
40 Architecture) ORB (object request broker). It allows programs to send
41 requests and receive replies from other programs, regardless of the
42 locations of the two programs. CORBA is an architecture that enables
43 communication between program objects, regardless of the programming
44 language they're written in or the operating system they run on.
45
46 %description -l fr.UTF-8
47 ORBit est un ORB CORBA avec support pour le language C. Il permet a
48 des programmes d'envoyer des requètes et recevoir de réponses d'autres
49 programmes, indépendement de l'endroit ou sont les deux programmes.
50
51 %description -l pl.UTF-8
52 ORBit to wysokiej wydajności CORBA (Common Object Request Broker
53 Architecture) ORB (object request broker). Pozwala na wysyłanie próśb
54 i otrzymywanie odpowiedzi od innych programów bez znajomości położenia
55 tych dwóch programów.
56
57 %package apidocs
58 Summary:        ORBit API documentation
59 Summary(pl.UTF-8):      Dokumentacja API ORBit
60 Group:          Documentation
61 Requires:       gtk-doc-common
62
63 %description apidocs
64 ORBit API documentation.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API ORBit.
68
69 %package devel
70 Summary:        Header files, and utilities for ORBit
71 Summary(fr.UTF-8):      Librairies statiques et fichiers entête pour ORBit
72 Summary(pl.UTF-8):      Pliki nagłówkowe i użytki dla ORBit
73 Group:          Development/Libraries
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75 Requires:       glib2-devel >= 1:2.14.1
76 Requires:       indent
77 Requires:       libIDL-devel >= 0.8.10
78 Provides:       linc-devel = 1.1.1
79 Obsoletes:      libORBit2_0-devel
80 Obsoletes:      linc-devel
81
82 %description devel
83 devel ORBit is a high-performance CORBA ORB with support for the C
84 language. It allows programs to send requests and receive replies from
85 other programs, regardless of the locations of the two programs.
86
87 This package includes the header files and utilities neecessary to
88 write programs that use CORBA technology.
89
90 %description devel -l fr.UTF-8
91 Librairies statiques et fichiers entête requis pour le development ou
92 la compilation de programmes utilisant ORBit.
93
94 %description devel -l pl.UTF-8
95 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
96 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
97 programów bez znajomości położenia tych dwóch programów.
98
99 Ten pakiet zawiera pliki nagłówkowe oraz użytki potrzebne do pisania
100 programów używających technologi CORBA.
101
102 %package static
103 Summary:        Static libraries for ORBit
104 Summary(pl.UTF-8):      Biblioteki statyczne dla ORBit
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
107 Provides:       linc-static = 1.1.1
108 Obsoletes:      linc-static
109
110 %description static
111 ORBit is a high-performance CORBA ORB with support for the C language.
112 It allows programs to send requests and receive replies from other
113 programs, regardless of the locations of the two programs.
114
115 This package includes static libraries neecessary to write programs
116 statically linked that use CORBA technology.
117
118 %description static -l pl.UTF-8
119 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
120 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
121 programów bez znajomości położenia tych dwóch programów.
122
123 Ten pakiet zawiera biblioteki statyczne potrzebne do pisania programów
124 skonsolidowanych statycznie używających technologii CORBA.
125
126 %prep
127 %setup -q
128 %patch0 -p1
129
130 %if !%{with apidocs}
131 echo 'EXTRA_DIST=' > gtk-doc.make
132 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
133 %endif
134
135 %build
136 %{?with_apidocs:%{__gtkdocize}}
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %configure \
143         --with-html-dir=%{_gtkdocdir} \
144         %{!?with_static_libs:--disable-static} \
145         %{?with_apidocs:--enable-gtk-doc}
146 %{__make} -j1
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} -j1 install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 # no static module - shut up check-files
155 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.{la,a}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS NEWS README
166 %attr(755,root,root) %{_bindir}/ior-decode-2
167 %attr(755,root,root) %{_bindir}/linc-cleanup-sockets
168 %attr(755,root,root) %{_bindir}/orbit-idl-2
169 %attr(755,root,root) %{_bindir}/typelib-dump
170 %attr(755,root,root) %{_libdir}/libORBit-2.so.*.*.*
171 %attr(755,root,root) %ghost %{_libdir}/libORBit-2.so.0
172 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libORBit-imodule-2.so.0
174 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libORBitCosNaming-2.so.0
176 %dir %{_libdir}/orbit-2.0
177 %attr(755,root,root) %{_libdir}/orbit-2.0/Everything_module.so
178 %{_datadir}/idl/orbit-2.0
179
180 %if %{with apidocs}
181 %files apidocs
182 %defattr(644,root,root,755)
183 %{_gtkdocdir}/%{name}
184 %endif
185
186 %files devel
187 %defattr(644,root,root,755)
188 %doc ChangeLog
189 %attr(755,root,root) %{_bindir}/orbit2-config
190 %attr(755,root,root) %{_libdir}/libORBit-2.so
191 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so
192 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so
193 %{_libdir}/libORBit-2.la
194 %{_libdir}/libORBit-imodule-2.la
195 %{_libdir}/libORBitCosNaming-2.la
196 %{_libdir}/libname-server-2.a
197 %{_includedir}/orbit-2.0
198 %{_pkgconfigdir}/ORBit-2.0.pc
199 %{_pkgconfigdir}/ORBit-CosNaming-2.0.pc
200 %{_pkgconfigdir}/ORBit-idl-2.0.pc
201 %{_pkgconfigdir}/ORBit-imodule-2.0.pc
202 %{_aclocaldir}/ORBit2.m4
203
204 %if %{with static_libs}
205 %files static
206 %defattr(644,root,root,755)
207 %{_libdir}/libORBit-2.a
208 %{_libdir}/libORBit-imodule-2.a
209 %{_libdir}/libORBitCosNaming-2.a
210 %endif
This page took 0.045081 seconds and 3 git commands to generate.