]> git.pld-linux.org Git - packages/ORBit2.git/blob - ORBit2.spec
- release 2
[packages/ORBit2.git] / ORBit2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        High-performance CORBA Object Request Broker
7 Summary(fr.UTF-8):      Requète d'Objects CORBA
8 Summary(pl.UTF-8):      Wysoko wydajny CORBA Object Request Broker
9 Name:           ORBit2
10 Version:        2.14.19
11 Release:        2
12 Epoch:          1
13 License:        GPL v2+/LGPL v2+
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
16 # Source0-md5:  7082d317a9573ab338302243082d10d1
17 Patch0:         %{name}-pthread.patch
18 URL:            http://projects.gnome.org/ORBit2/
19 BuildRequires:  autoconf >= 2.54
20 BuildRequires:  automake >= 1:1.9
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  flex
23 BuildRequires:  glib2-devel >= 1:2.14.1
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
25 BuildRequires:  indent
26 BuildRequires:  libIDL-devel >= 0.8.10
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig >= 1:0.18
29 BuildRequires:  rpmbuild(macros) >= 1.197
30 Requires:       glib2 >= 1:2.14.1
31 Requires:       libIDL >= 0.8.10
32 Provides:       linc = 1.1.1
33 Obsoletes:      ORBit2-automake
34 Obsoletes:      libORBit2_0
35 Obsoletes:      linc
36 Conflicts:      libbonobo < 2.3.2
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 ORBit is a high-performance CORBA (Common Object Request Broker
41 Architecture) ORB (object request broker). It allows programs to send
42 requests and receive replies from other programs, regardless of the
43 locations of the two programs. CORBA is an architecture that enables
44 communication between program objects, regardless of the programming
45 language they're written in or the operating system they run on.
46
47 %description -l fr.UTF-8
48 ORBit est un ORB CORBA avec support pour le language C. Il permet a
49 des programmes d'envoyer des requètes et recevoir de réponses d'autres
50 programmes, indépendement de l'endroit ou sont les deux programmes.
51
52 %description -l pl.UTF-8
53 ORBit to wysokiej wydajności CORBA (Common Object Request Broker
54 Architecture) ORB (object request broker). Pozwala na wysyłanie próśb
55 i otrzymywanie odpowiedzi od innych programów bez znajomości położenia
56 tych dwóch programów.
57
58 %package apidocs
59 Summary:        ORBit API documentation
60 Summary(pl.UTF-8):      Dokumentacja API ORBit
61 Group:          Documentation
62 Requires:       gtk-doc-common
63
64 %description apidocs
65 ORBit API documentation.
66
67 %description apidocs -l pl.UTF-8
68 Dokumentacja API ORBit.
69
70 %package devel
71 Summary:        Header files, and utilities for ORBit
72 Summary(fr.UTF-8):      Librairies statiques et fichiers entête pour ORBit
73 Summary(pl.UTF-8):      Pliki nagłówkowe i użytki dla ORBit
74 Group:          Development/Libraries
75 Requires:       %{name} = %{epoch}:%{version}-%{release}
76 Requires:       glib2-devel >= 1:2.14.1
77 Requires:       indent
78 Requires:       libIDL-devel >= 0.8.10
79 Provides:       linc-devel = 1.1.1
80 Obsoletes:      libORBit2_0-devel
81 Obsoletes:      linc-devel
82
83 %description devel
84 devel ORBit is a high-performance CORBA ORB with support for the C
85 language. It allows programs to send requests and receive replies from
86 other programs, regardless of the locations of the two programs.
87
88 This package includes the header files and utilities neecessary to
89 write programs that use CORBA technology.
90
91 %description devel -l fr.UTF-8
92 Librairies statiques et fichiers entête requis pour le development ou
93 la compilation de programmes utilisant ORBit.
94
95 %description devel -l pl.UTF-8
96 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
97 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
98 programów bez znajomości położenia tych dwóch programów.
99
100 Ten pakiet zawiera pliki nagłówkowe oraz użytki potrzebne do pisania
101 programów używających technologi CORBA.
102
103 %package static
104 Summary:        Static libraries for ORBit
105 Summary(pl.UTF-8):      Biblioteki statyczne dla ORBit
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
108 Provides:       linc-static = 1.1.1
109 Obsoletes:      linc-static
110
111 %description static
112 ORBit is a high-performance CORBA ORB with support for the C language.
113 It allows programs to send requests and receive replies from other
114 programs, regardless of the locations of the two programs.
115
116 This package includes static libraries neecessary to write programs
117 statically linked that use CORBA technology.
118
119 %description static -l pl.UTF-8
120 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
121 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
122 programów bez znajomości położenia tych dwóch programów.
123
124 Ten pakiet zawiera biblioteki statyczne potrzebne do pisania programów
125 skonsolidowanych statycznie używających technologii CORBA.
126
127 %prep
128 %setup -q
129 %patch0 -p1
130
131 %if !%{with apidocs}
132 echo 'EXTRA_DIST=' > gtk-doc.make
133 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
134 %endif
135
136 %build
137 %{?with_apidocs:%{__gtkdocize}}
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure \
144         --with-html-dir=%{_gtkdocdir} \
145         %{!?with_static_libs:--disable-static} \
146         %{?with_apidocs:--enable-gtk-doc}
147 %{__make} -j1
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} -j1 install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 # no static module - shut up check-files
156 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.{la,a}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %files
165 %defattr(644,root,root,755)
166 %doc AUTHORS NEWS README
167 %attr(755,root,root) %{_bindir}/ior-decode-2
168 %attr(755,root,root) %{_bindir}/linc-cleanup-sockets
169 %attr(755,root,root) %{_bindir}/orbit-idl-2
170 %attr(755,root,root) %{_bindir}/typelib-dump
171 %attr(755,root,root) %{_libdir}/libORBit-2.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libORBit-2.so.0
173 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libORBit-imodule-2.so.0
175 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libORBitCosNaming-2.so.0
177 %dir %{_libdir}/orbit-2.0
178 %attr(755,root,root) %{_libdir}/orbit-2.0/Everything_module.so
179 %{_datadir}/idl/orbit-2.0
180
181 %if %{with apidocs}
182 %files apidocs
183 %defattr(644,root,root,755)
184 %{_gtkdocdir}/%{name}
185 %endif
186
187 %files devel
188 %defattr(644,root,root,755)
189 %doc ChangeLog
190 %attr(755,root,root) %{_bindir}/orbit2-config
191 %attr(755,root,root) %{_libdir}/libORBit-2.so
192 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so
193 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so
194 %{_libdir}/libORBit-2.la
195 %{_libdir}/libORBit-imodule-2.la
196 %{_libdir}/libORBitCosNaming-2.la
197 %{_libdir}/libname-server-2.a
198 %{_includedir}/orbit-2.0
199 %{_pkgconfigdir}/ORBit-2.0.pc
200 %{_pkgconfigdir}/ORBit-CosNaming-2.0.pc
201 %{_pkgconfigdir}/ORBit-idl-2.0.pc
202 %{_pkgconfigdir}/ORBit-imodule-2.0.pc
203 %{_aclocaldir}/ORBit2.m4
204
205 %if %{with static_libs}
206 %files static
207 %defattr(644,root,root,755)
208 %{_libdir}/libORBit-2.a
209 %{_libdir}/libORBit-imodule-2.a
210 %{_libdir}/libORBitCosNaming-2.a
211 %endif
This page took 0.054021 seconds and 3 git commands to generate.