]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
up to 22.2.0 auto/th/Mesa-22.2.0-1
authorJan Palus <atler@pld-linux.org>
Sun, 25 Sep 2022 10:07:52 +0000 (12:07 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 25 Sep 2022 10:07:52 +0000 (12:07 +0200)
- use source url from release announcement

Mesa.spec
powervr_uint64.patch [deleted file]
zink_x32.patch [deleted file]

index fe24912104c08c9040ea5fd5c1af9f225329ed9f..8cddeabd00cfe196e65948a518fa0ba32aeb6198 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
-Version:       22.1.7
+Version:       22.2.0
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 #Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 ## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
-Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
-# Source0-md5: 3ae6822caa25e912f099ce1927f9fbc6
-Patch0:                zink_x32.patch
-Patch1:                powervr_uint64.patch
+Source0:       https://archive.mesa3d.org/mesa-%{version}.tar.xz
+# Source0-md5: 731cdd53d5f9dd695aae1b3a37081d5f
 URL:           https://www.mesa3d.org/
 %{?with_opencl_spirv:BuildRequires:    SPIRV-LLVM-Translator-devel >= 8.0.1.3}
 %{?with_gallium_zink:BuildRequires:    Vulkan-Loader-devel}
@@ -120,6 +118,7 @@ BuildRequires:      python3-Mako >= 0.8.0
 BuildRequires: rpmbuild(macros) >= 2.007
 BuildRequires: sed >= 4.0
 %{?with_opencl_spirv:BuildRequires:    spirv-tools-devel >= 2018.0}
+BuildRequires: tar >= 1:1.22
 BuildRequires: udev-devel
 # wayland-{client,server}
 %{?with_wayland:BuildRequires: wayland-devel >= %{wayland_ver}}
@@ -137,6 +136,7 @@ BuildRequires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
 %if %{with gallium}
 %{?with_lm_sensors:BuildRequires:      lm_sensors-devel}
+BuildRequires: xz
 %endif
 BuildRequires: zlib-devel >= %{zlib_ver}
 BuildRequires: zstd-devel
@@ -1423,11 +1423,7 @@ radv - experimental Mesa Vulkan driver for AMD Radeon GPUs.
 radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD.
 
 %prep
-%setup -q -n mesa-mesa-%{version}
-%patch0 -p1
-%ifarch %{arm} aarch64
-%patch1 -p1
-%endif
+%setup -q -n mesa-%{version}
 
 %build
 %if %{with opencl}
@@ -1504,6 +1500,7 @@ vulkan_drivers=$(echo $vulkan_drivers | xargs | tr ' ' ',')
        -Dselinux=true \
        -Dsse2=%{__true_false sse2} \
        -Dva-libs-path=%{_libdir}/libva/dri \
+       -Dvideo-codecs=h264dec,h264enc,h265dec,h265enc,vc1dec \
        -Dvulkan-drivers=${vulkan_drivers} \
        -Dvulkan-icd-dir=/usr/share/vulkan/icd.d \
 %ifarch %{arm} aarch64
@@ -1828,6 +1825,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ili9341_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-dcss_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-drm_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-lcdif_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ingenic-drm_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/kirin_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/komeda_dri.so
diff --git a/powervr_uint64.patch b/powervr_uint64.patch
deleted file mode 100644 (file)
index 4a1a35f..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From 2d46abb200f6631d8689ecf8f18d55e9c2bb2cc6 Mon Sep 17 00:00:00 2001
-From: Jan Palus <jpalus@fastmail.com>
-Date: Fri, 20 May 2022 11:20:33 +0200
-Subject: [PATCH] pvr: use UINT64_C for 64-bit constant
-
-Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/6528
-
-Signed-off-by: Jan Palus <jpalus@fastmail.com>
----
- src/imagination/vulkan/pvr_cmd_buffer.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/imagination/vulkan/pvr_cmd_buffer.c b/src/imagination/vulkan/pvr_cmd_buffer.c
-index f043054bcb0b..0afd463e2fb0 100644
---- a/src/imagination/vulkan/pvr_cmd_buffer.c
-+++ b/src/imagination/vulkan/pvr_cmd_buffer.c
-@@ -2760,7 +2760,7 @@ static VkResult pvr_setup_descriptor_mappings(
-                PVR_ROGUE_PDSINST_DOUT_FIELDS_DOUTD_SRC1_BSIZE_CLRMSK;
-             PVR_WRITE(qword_buffer,
--                      0UL,
-+                      UINT64_C(0),
-                       desc_set_entry->const_offset,
-                       pds_info->data_size_in_dwords);
--- 
-GitLab
-
diff --git a/zink_x32.patch b/zink_x32.patch
deleted file mode 100644 (file)
index 449e4dd..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- mesa-mesa-21.3.0/src/gallium/drivers/zink/zink_framebuffer.c.orig  2021-11-17 21:16:20.000000000 +0100
-+++ mesa-mesa-21.3.0/src/gallium/drivers/zink/zink_framebuffer.c       2021-11-17 22:27:05.031355842 +0100
-@@ -207,7 +207,7 @@
-    struct hash_entry *he = _mesa_hash_table_search_pre_hashed(&fb->objects, hash, rp);
-    if (he) {
--#if defined(_WIN64) || defined(__x86_64__)
-+#if defined(_WIN64) || (defined(__x86_64__) && !defined(__ILP32__))
-       ret = (VkFramebuffer)he->data;
- #else
-       VkFramebuffer *ptr = he->data;
-@@ -229,7 +229,7 @@
-    if (VKSCR(CreateFramebuffer)(screen->dev, &fci, NULL, &ret) != VK_SUCCESS)
-       return;
--#if defined(_WIN64) || defined(__x86_64__)
-+#if defined(_WIN64) || (defined(__x86_64__) && !defined(__ILP32__))
-    _mesa_hash_table_insert_pre_hashed(&fb->objects, hash, rp, ret);
- #else
-    VkFramebuffer *ptr = ralloc(fb, VkFramebuffer);
This page took 0.26742 seconds and 4 git commands to generate.