]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
- merged last pre-9.0 snap from DEVEL branch, resolved conflicts
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 9 Oct 2012 17:40:51 +0000 (19:40 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 9 Oct 2012 17:40:51 +0000 (19:40 +0200)
1  2 
Mesa.spec

diff --cc Mesa.spec
index bc80ea30557a497d4e456d8085ee2b847b3a509e,270282e803b054ed76097ef0ffe358f1b7abc955..458451025c9df808b9cb187801dd340f29390e99
+++ b/Mesa.spec
@@@ -6,12 -5,10 +5,11 @@@
  # - resurrect static if it's useful (using plain xorg target? DRI doesn't support static)
  #
  # Conditional build:
 -%bcond_without        egl             # EGL libraries
  %bcond_without        gallium         # gallium drivers
 -%bcond_with   gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
 -%bcond_without        gallium_nouveau # gallium nouveau driver
 +%bcond_with   gallium_intel   # gallium i915 driver (instead of plain dri; doesn't work with AIGLX)
 +%bcond_without        gallium_nouveau # gallium nouveau driver (instead of plain dri)
 +%bcond_with   dri_nouveau     # nouveau DRI driver (any kind; doesn't build with current libdrm)
 +%bcond_without        egl             # EGL libraries
- %bcond_without        osmesa          # OSMesa libraries
  %bcond_without        gbm             # Graphics Buffer Manager
  %bcond_without        wayland         # Wayland EGL
  %bcond_without        xa              # XA state tracker (for vmwgfx xorg driver)
  Summary:      Free OpenGL implementation
  Summary(pl.UTF-8):    Wolnodostępna implementacja standardu OpenGL
  Name:         Mesa
- Version:      8.0.4
- Release:      1
- License:      MIT (core), SGI (GLU) and others - see license.html file
+ Version:      9.0.0
+ Release:      0.%{snap}.1
+ License:      MIT (core) and others - see license.html file
  Group:                X11/Libraries
Source0:      ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
- # Source0-md5:        d546f988adfdf986cff45b1efa2d8a46
- Patch100:     %{name}-git.patch
#Source0:     ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
+ Source0:      %{name}Lib-%{snap}.tar.bz2
+ # Source0-md5:        6a81ca41f8f131d98e95371ea0b6717e
 -#Patch100: %{name}-git.patch
  Patch0:               %{name}-realclean.patch
  Patch1:               %{name}-link.patch
  Patch2:               %{name}-wayland.patch
@@@ -591,6 -541,21 +553,21 @@@ Sterownik r600 dla szkieletu Mesa Graph
  bufora graficznego). Obsługuje karty graficzne ATI Radeon oparte na
  układach R600/R700.
  
 -radeonsi driver for Mesa Graphics Buffer Manager. It supports ATI Radeon
 -adapters based on Southern Islands chips.
+ %package gbm-driver-radeonsi
+ Summary:      radeonsi driver for Mesa GBM framework
+ Summary(pl.UTF-8):    Sterownik radeonsi dla szkieletu Mesa GBM
+ Group:                Libraries
+ Requires:     %{name}-libgbm = %{version}-%{release}
+ %description gbm-driver-radeonsi
 -Sterownik radeonsi dla szkieletu Mesa Graphics Buffer Manager (zarządcy
 -bufora graficznego). Obsługuje karty graficzne ATI Radeon oparte na
 -układach Southern Islands.
++radeonsi driver for Mesa Graphics Buffer Manager. It supports ATI
++Radeon adapters based on Southern Islands chips.
+ %description gbm-driver-radeonsi -l pl.UTF-8
++Sterownik radeonsi dla szkieletu Mesa Graphics Buffer Manager
++(zarządcy bufora graficznego). Obsługuje karty graficzne ATI Radeon
++oparte na układach Southern Islands.
  %package gbm-driver-vmwgfx
  Summary:      vmwgfx driver for Mesa GBM framework
  Summary(pl.UTF-8):    Sterownik vmwgfx dla szkieletu Mesa GBM
@@@ -879,6 -874,23 +886,23 @@@ based on R600/R700 chips
  Sterownik Mesa r600 dla API vdpau. Obsługuje karty ATI Radeon oparte
  na układach R600/R700.
  
 -Mesa radeonsi driver for the vdpau API. It supports ATI Radeon adapters
 -based on Southern Islands chips.
+ %package -n libvdpau-driver-mesa-radeonsi
+ Summary:      Mesa radeonsi driver for the vdpau API
+ Summary(pl.UTF-8):    Sterownik Mesa radeonsi dla API vdpau
+ License:      MIT
+ Group:                X11/Libraries
+ Requires:     libdrm >= %{libdrm_ver}
+ Requires:     libvdpau >= 0.4.1
+ Conflicts:    libvdpau-driver-mesa
+ %description -n libvdpau-driver-mesa-radeonsi
 -Sterownik Mesa radeonsi dla API vdpau. Obsługuje karty ATI Radeon oparte
 -na układach Southern Islands.
++Mesa radeonsi driver for the vdpau API. It supports ATI Radeon
++adapters based on Southern Islands chips.
+ %description -n libvdpau-driver-mesa-radeonsi -l pl.UTF-8
++Sterownik Mesa radeonsi dla API vdpau. Obsługuje karty ATI Radeon
++oparte na układach Southern Islands.
  %package -n libvdpau-driver-mesa-softpipe
  Summary:      Mesa softpipe driver for the vdpau API
  Summary(pl.UTF-8):    Sterownik Mesa softpipe dla API vdpau
@@@ -895,16 -907,19 +919,19 @@@ Mesa softpipe driver for the vdpau API
  Sterownik Mesa softpipe dla API vdpau.
  
  %prep
- %setup -q
+ %setup -q -n %{name}
  #%patch100 -p1
- %patch0 -p0
 -#%patch0 -p0
++#patch0 -p0
  %patch1 -p1
- %patch2 -p1
- %patch3 -p1
 -#%patch2 -p1
++#patch2 -p1
  
  %build
 -      %{__aclocal}
 -      %{__autoconf}
+ if [ -x autogen.sh ]; then
+       ./autogen.sh
+ else
 +%{__aclocal}
 +%{__autoconf}
+ fi
  
  dri_drivers="r200 radeon \
  %if %{without gallium_intel}
@@@ -927,8 -939,9 +954,9 @@@ i915 
  %endif
  r300 \
  r600 \
- %if %{with dri_nouveau} && %{with gallium_nouveau}
- nouveau \
+ radeonsi \
+ %if %{with gallium_nouveau}
 -nouveau \
++nouveau
  %endif
  "
  
@@@ -1296,8 -1280,11 +1295,12 @@@ rm -rf $RPM_BUILD_ROO
  %files dri-driver-ati-radeon-R600
  %defattr(644,root,root,755)
  %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
 +%endif
  
+ %files dri-driver-ati-radeon-SI
+ %defattr(644,root,root,755)
+ %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeonsi_dri.so
  %files dri-driver-intel-i915
  %defattr(644,root,root,755)
  %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
This page took 0.044404 seconds and 4 git commands to generate.