]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 20111205
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_without  gallium_nouveau # gallium nouveau driver
11 %bcond_without  motif   # build static libGLw without Motif interface
12 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
13 %bcond_without  osmesa  # don't build osmesa
14 %bcond_without  gbm     # with Graphics Buffer Manager
15 %bcond_with     static_libs     # static libraries
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.27
25 %define         dri2proto_ver   2.6
26 %define         glproto_ver     1.4.11
27 #
28 %define         snap            20111205
29 #
30 Summary:        Free OpenGL implementation
31 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
32 Name:           Mesa
33 Version:        7.12
34 Release:        0.%{snap}.1%{?with_multigl:.mgl}
35 License:        MIT (core), SGI (GLU) and others - see license.html file
36 Group:          X11/Libraries
37 Source0:        %{name}Lib-%{snap}.tar.bz2
38 # Source0-md5:  d2330fbba42ab1391195d6f3c51ebda7
39 Patch0:         %{name}-realclean.patch
40 URL:            http://www.mesa3d.org/
41 BuildRequires:  autoconf >= 2.59
42 BuildRequires:  automake
43 BuildRequires:  expat-devel
44 BuildRequires:  libdrm-devel >= %{libdrm_ver}
45 # drop when 2.4.24 is released
46 %{?with_nouveau:BuildRequires:  libdrm-devel >= 2.4.24}
47 BuildRequires:  libselinux-devel
48 BuildRequires:  libstdc++-devel >= 5:3.3.0
49 BuildRequires:  libtalloc-devel >= 2:2.0.1
50 BuildRequires:  libtool >= 2:1.4d
51 BuildRequires:  libvdpau-devel
52 BuildRequires:  llvm-devel >= 2.9
53 %{?with_motif:BuildRequires:    motif-devel}
54 BuildRequires:  pixman-devel
55 BuildRequires:  pkgconfig
56 BuildRequires:  pkgconfig(talloc) >= 2.0.1
57 BuildRequires:  python
58 BuildRequires:  python-libxml2
59 BuildRequires:  python-modules
60 BuildRequires:  rpmbuild(macros) >= 1.470
61 BuildRequires:  sed >= 4.0
62 BuildRequires:  xorg-lib-libXdamage-devel
63 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
64 BuildRequires:  xorg-lib-libXt-devel
65 BuildRequires:  xorg-lib-libXvMC-devel
66 BuildRequires:  xorg-lib-libXxf86vm-devel
67 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
68 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
69 BuildRequires:  xorg-util-makedepend
70 BuildRequires:  xorg-xserver-server-devel
71 %if %{with egl}
72 BuildRequires:  libxcb-devel
73 BuildRequires:  udev-devel >= 150
74 %endif
75 %if %{with gallium}
76 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
77 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
78 %endif
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %if %{without gallium}
82 %undefine       with_gallium_intel
83 %endif
84
85 %if %{without egl}
86 %undefine       with_gbm
87 %endif
88
89 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
90 %define         skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libXvMCnouveau.so.1.* libXvMCr300.so.1.*  libXvMCr600.so.1.* libXvMCsoftpipe.so.1.* libvdpau_nouveau.so.1.*
91
92 %description
93 Mesa is a 3-D graphics library with an API which is very similar to
94 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
95 syntax or state machine, it is being used with authorization from
96 Silicon Graphics, Inc. However, the author does not possess an OpenGL
97 license from SGI, and makes no claim that Mesa is in any way a
98 compatible replacement for OpenGL or associated with SGI.
99
100 %description -l pl.UTF-8
101 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
102 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
103 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
104 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
105 OpenGL ani powiązana z SGI.
106
107 %package libEGL
108 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
109 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
110 License:        MIT
111 Group:          Libraries
112 Requires:       OpenGL >= 1.2
113 Requires:       udev-libs >= 150
114 Provides:       EGL = 1.4
115
116 %description libEGL
117 This package contains shared libEGL - Mesa implementation of EGL
118 Native Platform Graphics Interface as specified by Khronos Group:
119 <http://www.khronos.org/egl/>.
120
121 %description libEGL -l pl.UTF-8
122 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
123 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
124 graficznego platformy natywnej) wg specyfikacji Khronos Group:
125 <http://www.khronos.org/egl/>.
126
127 %package libEGL-devel
128 Summary:        Header files for Mesa implementation of EGL library
129 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
130 License:        MIT
131 Group:          Development/Libraries
132 Requires:       %{name}-libEGL = %{version}-%{release}
133 Requires:       OpenGL-devel >= 1.2
134 Requires:       libstdc++-devel
135 Provides:       EGL-devel = 1.4
136
137 %description libEGL-devel
138 Header files for Mesa implementation of EGL library.
139
140 %description libEGL-devel -l pl.UTF-8
141 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
142
143 %package libEGL-static
144 Summary:        Static SGI libEGL library
145 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
146 License:        MIT
147 Group:          Development/Libraries
148 Requires:       %{name}-libEGL-devel = %{version}-%{release}
149 Provides:       EGL-static = 1.4
150
151 %description libEGL-static
152 Static Mesa libEGL library.
153
154 %description libEGL-static -l pl.UTF-8
155 Statyczna biblioteka Mesa libEGL.
156
157 %package libGLES
158 Summary:        Mesa libGLES runtime libraries
159 Group:          Libraries
160
161 %description libGLES
162 Mesa GLES runtime libraries.
163
164 %description libGLES -l pl.UTF-8
165 Biblioteka Mesa GLES.
166
167 %package libGLES-devel
168 Summary:        Header files for libGLES library
169 Group:          Development/Libraries
170 Requires:       %{name}-libGLES = %{version}-%{release}
171
172 %description libGLES-devel
173 Header files for libGLES library.
174
175 %description libGLES-devel -l pl.UTF-8
176 Pliki nagłówkowe biblioteki libGLES.
177
178 %package libGL
179 Summary:        Free Mesa3D implementation of libGL OpenGL library
180 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
181 License:        MIT
182 Group:          X11/Libraries
183 Requires:       libdrm >= %{libdrm_ver}
184 Provides:       OpenGL = 2.1
185 # reports version 1.3, but supports glXGetProcAddress() from 1.4
186 Provides:       OpenGL-GLX = 1.4
187 Obsoletes:      Mesa
188 Obsoletes:      Mesa-dri
189 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
190 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
191
192 %description libGL
193 Mesa is a 3-D graphics library with an API which is very similar to
194 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
195 syntax or state machine, it is being used with authorization from
196 Silicon Graphics, Inc. However, the author does not possess an OpenGL
197 license from SGI, and makes no claim that Mesa is in any way a
198 compatible replacement for OpenGL or associated with SGI.
199
200 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
201 specifications. It uses DRI for rendering.
202
203 %description libGL -l pl.UTF-8
204 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
205 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
206 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
207 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
208 OpenGL ani powiązana z SGI.
209
210 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
211 GLX 1.4. Używa DRI do renderowania.
212
213 %package libGL-devel
214 Summary:        Header files for Mesa3D libGL library
215 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
216 License:        MIT
217 Group:          X11/Development/Libraries
218 # loose dependency on libGL to use with other libGL binaries
219 Requires:       OpenGL >= 1.5
220 Requires:       libdrm-devel >= %{libdrm_ver}
221 Requires:       xorg-lib-libX11-devel
222 Requires:       xorg-lib-libXdamage-devel
223 Requires:       xorg-lib-libXext-devel
224 Requires:       xorg-lib-libXxf86vm-devel
225 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
226 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
227 Suggests:       OpenGL-doc-man
228 Provides:       OpenGL-GLX-devel = 1.4
229 Provides:       OpenGL-devel = 2.1
230 Obsoletes:      Mesa-devel
231 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
232 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
233 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
234 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
235
236 %description libGL-devel
237 Header files for Mesa3D libGL library.
238
239 %description libGL-devel -l pl.UTF-8
240 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
241
242 %package libGL-static
243 Summary:        Static Mesa3D libGL library
244 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
245 License:        MIT
246 Group:          X11/Development/Libraries
247 Requires:       %{name}-libGL-devel = %{version}-%{release}
248 Provides:       OpenGL-static = 2.1
249 Obsoletes:      Mesa-static
250 Obsoletes:      X11-OpenGL-static < 1:7.0.0
251 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
252
253 %description libGL-static
254 Static Mesa3D libGL library. It uses software renderer.
255
256 %description libGL-static -l pl.UTF-8
257 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
258 renderingu.
259
260 %package libGLU
261 Summary:        SGI implementation of libGLU OpenGL library
262 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
263 License:        SGI Free Software License B v2.0 (MIT-like)
264 Group:          Libraries
265 # loose dependency on libGL.so.1 to use with other libGL binaries
266 Requires:       OpenGL >= 1.2
267 Provides:       OpenGL-GLU = 1.3
268 Obsoletes:      Mesa-devel
269 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
270 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
271
272 %description libGLU
273 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
274 1.3 specifications.
275
276 %description libGLU -l pl.UTF-8
277 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
278 specyfikację OpenGL GLU 1.3.
279
280 %package libGLU-devel
281 Summary:        Header files for SGI libGLU library
282 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
283 License:        SGI Free Software License B v2.0 (MIT-like)
284 Group:          Development/Libraries
285 Requires:       %{name}-libGLU = %{version}-%{release}
286 Requires:       OpenGL-devel >= 1.2
287 Requires:       libstdc++-devel
288 Provides:       OpenGL-GLU-devel = 1.3
289
290 %description libGLU-devel
291 Header files for SGI libGLU library.
292
293 %description libGLU-devel -l pl.UTF-8
294 Pliki nagłówkowe biblioteki SGI libGLU.
295
296 %package libGLU-static
297 Summary:        Static SGI libGLU library
298 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
299 License:        SGI Free Software License B v2.0 (MIT-like)
300 Group:          Development/Libraries
301 Requires:       %{name}-libGLU-devel = %{version}-%{release}
302 Provides:       OpenGL-GLU-static = 1.3
303
304 %description libGLU-static
305 Static SGI libGLU library.
306
307 %description libGLU-static -l pl.UTF-8
308 Statyczna biblioteka SGI libGLU.
309
310 %package libOSMesa
311 Summary:        OSMesa (off-screen renderer) library
312 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
313 License:        MIT
314 Group:          Libraries
315 # doesn't require base
316
317 %description libOSMesa
318 OSMesa (off-screen renderer) library.
319
320 %description libOSMesa -l pl.UTF-8
321 Biblioteka OSMesa (renderująca bitmapy w pamięci).
322
323 %package libOSMesa-devel
324 Summary:        Header file for OSMesa (off-screen renderer) library
325 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
326 License:        MIT
327 Group:          Development/Libraries
328 Requires:       %{name}-libOSMesa = %{version}-%{release}
329 # for <GL/gl.h> only
330 Requires:       OpenGL-devel
331
332 %description libOSMesa-devel
333 Header file for OSMesa (off-screen renderer) library.
334
335 %description libOSMesa-devel -l pl.UTF-8
336 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
337
338 %package libOSMesa-static
339 Summary:        Static OSMesa (off-screen renderer) library
340 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
341 License:        MIT
342 Group:          Development/Libraries
343 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
344 # this static build of OSMesa needs static non-dri Mesa implementation
345 Requires:       %{name}-libGL-static = %{version}-%{release}
346
347 %description libOSMesa-static
348 Static OSMesa (off-screen renderer) library.
349
350 %description libOSMesa-static -l pl.UTF-8
351 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
352
353 %package libOpenVG
354 Summary:        OpenVG API implementation
355 Summary(pl.UTF-8):      Implementacja API OpenVG
356 License:        MIT
357 Group:          Libraries
358 # doesn't require base
359
360 %description libOpenVG
361 OpenVG API implementation.
362
363 %description libOpenVG -l pl.UTF-8
364 Implementacja API OpenVG.
365
366 %package libOpenVG-devel
367 Summary:        Header file for libOpenVG library
368 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libOpenVG
369 License:        MIT
370 Group:          Development/Libraries
371 # for <KHR/khrplatform.h>
372 Requires:       %{name}-libEGL-devel = %{version}-%{release}
373 Requires:       %{name}-libOpenVG = %{version}-%{release}
374
375 %description libOpenVG-devel
376 Header file for libOpenVG library.
377
378 %description libOpenVG-devel -l pl.UTF-8
379 Plik nagłówkowy biblioteki libOpenVG.
380
381 %package libXvMC
382 Summary:        XvMC implementations
383 Summary(pl.UTF-8):      Implementacje API XvMC
384 License:        MIT
385 Group:          Libraries
386 # doesn't require base
387
388 %description libXvMC
389 libXvMC implementations.
390
391 %description libXvMC -l pl.UTF-8
392 Implementacje API libXvMC.
393
394 %package utils
395 Summary:        OpenGL utilities from Mesa3D
396 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
397 License:        MIT
398 Group:          X11/Applications/Graphics
399 # loose deps on libGL/libGLU
400
401 %description utils
402 OpenGL utilities from Mesa3D: glxgears and glxinfo.
403
404 %description utils -l pl.UTF-8
405 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
406
407 %package dri-driver-ati-radeon-R100
408 Summary:        X.org DRI driver for ATI R100 card family
409 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
410 License:        MIT
411 Group:          X11/Libraries
412 Requires:       xorg-driver-video-ati
413 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
414 Requires:       xorg-xserver-server >= %{xserver_ver}
415 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
416
417 %description dri-driver-ati-radeon-R100
418 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
419
420 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
421 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
422
423 %package dri-driver-ati-radeon-R200
424 Summary:        X.org DRI driver for ATI R200 card family
425 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
426 License:        MIT
427 Group:          X11/Libraries
428 Requires:       xorg-driver-video-ati
429 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
430 Requires:       xorg-xserver-server >= %{xserver_ver}
431 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
432
433 %description dri-driver-ati-radeon-R200
434 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
435
436 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
437 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
438
439 %package dri-driver-ati-radeon-R300
440 Summary:        X.org DRI driver for ATI R300 card family
441 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
442 License:        MIT
443 Group:          X11/Libraries
444 Requires:       xorg-driver-video-ati
445 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
446 Requires:       xorg-xserver-server >= %{xserver_ver}
447 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
448
449 %description dri-driver-ati-radeon-R300
450 X.org DRI driver for ATI R300 card family.
451
452 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
453 Sterownik X.org DRI dla rodziny kart ATI R300.
454
455 %package dri-driver-ati-radeon-R600
456 Summary:        X.org DRI driver for ATI R600 card family
457 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
458 License:        MIT
459 Group:          X11/Libraries
460 Requires:       radeon-ucode
461 Requires:       xorg-driver-video-ati
462 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
463 Requires:       xorg-xserver-server >= %{xserver_ver}
464
465 %description dri-driver-ati-radeon-R600
466 X.org DRI driver for ATI R600 card family.
467
468 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
469 Sterownik X.org DRI dla rodziny kart ATI R600.
470
471 %package dri-driver-ffb
472 Summary:        X.org DRI driver for Sun FFB card family
473 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
474 License:        MIT
475 Group:          X11/Libraries
476 Requires:       xorg-driver-video-sunffb
477 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
478 Requires:       xorg-xserver-server >= %{xserver_ver}
479
480 %description dri-driver-ffb
481 X.org DRI driver for SUN Creator3D and Elite3D card family.
482
483 %description dri-driver-ffb -l pl.UTF-8
484 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
485
486 %package dri-driver-glint
487 Summary:        X.org DRI driver for GLINT/Permedia card family
488 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
489 License:        MIT
490 Group:          X11/Libraries
491 Requires:       xorg-driver-video-glint
492 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
493 Requires:       xorg-xserver-server >= %{xserver_ver}
494 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
495
496 %description dri-driver-glint
497 X.org DRI driver for GLINT/Permedia card family.
498
499 %description dri-driver-glint -l pl.UTF-8
500 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
501
502 %package dri-driver-intel-i915
503 Summary:        X.org DRI driver for Intel i915 card family
504 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
505 License:        MIT
506 Group:          X11/Libraries
507 Requires:       xorg-driver-video-intel
508 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
509 Requires:       xorg-xserver-server >= %{xserver_ver}
510 Obsoletes:      Mesa-dri-driver-intel-i830
511 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
512
513 %description dri-driver-intel-i915
514 X.org DRI driver for Intel i915 card family.
515
516 %description dri-driver-intel-i915 -l pl.UTF-8
517 Sterownik X.org DRI dla rodziny kart Intel i915.
518
519 %package dri-driver-intel-i965
520 Summary:        X.org DRI driver for Intel i965 card family
521 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
522 License:        MIT
523 Group:          X11/Libraries
524 Requires:       xorg-driver-video-intel
525 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
526 Requires:       xorg-xserver-server >= %{xserver_ver}
527 Obsoletes:      Mesa-dri-driver-intel-i830
528 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
529
530 %description dri-driver-intel-i965
531 X.org DRI driver for Intel i965 card family.
532
533 %description dri-driver-intel-i965 -l pl.UTF-8
534 Sterownik X.org DRI dla rodziny kart Intel i965.
535
536 %package dri-driver-nouveau
537 Summary:        X.org DRI driver for NVIDIA card family
538 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
539 License:        MIT
540 Group:          X11/Libraries
541 Requires:       xorg-driver-video-nouveau
542 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
543 Requires:       xorg-xserver-server >= %{xserver_ver}
544
545 %description dri-driver-nouveau
546 X.org DRI drivers for NVIDIA card family.
547
548 %description dri-driver-nouveau -l pl.UTF-8
549 Sterowniki X.org DRI dla rodziny kart NVIDIA.
550
551 %package dri-driver-swrast
552 Summary:        X.org DRI software rasterizer driver
553 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
554 License:        MIT
555 Group:          X11/Libraries
556 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
557 Requires:       xorg-xserver-server >= %{xserver_ver}
558
559 %description dri-driver-swrast
560 X.org DRI software rasterizer driver.
561
562 %description dri-driver-swrast -l pl.UTF-8
563 Sterownik X.org DRI obsługujący rysowanie programowe.
564
565 %package dri-driver-vmwgfx
566 Summary:        X.org DRI driver for VMware
567 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
568 License:        MIT
569 Group:          X11/Libraries
570 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
571 Requires:       xorg-xserver-server >= %{xserver_ver}
572
573 %description dri-driver-vmwgfx
574 X.org DRI driver for VMWare.
575
576 %description dri-driver-vmwgfx -l pl.UTF-8
577 Sterownik X.org DRI dla VMware.
578
579 %package -n libvdpau-driver-mesa
580 Summary:        Mesa driver for the vdpau API
581 Summary(pl.UTF-8):      Sterownik Mesa dla API vdpau
582 License:        MIT
583 Group:          X11/Libraries
584
585 %description -n libvdpau-driver-mesa
586 Mesa driver for the vdpau API.
587
588 %description -n libvdpau-driver-mesa -l pl.UTF-8
589 Sterownik Mesa dla API vdpau.
590
591 # llvm build broken
592 %define         filterout_ld    -Wl,--as-needed
593
594 %prep
595 %setup -q
596 %patch0 -p0
597
598 %build
599 %{__aclocal}
600 %{__autoconf}
601
602 dri_drivers="r200 radeon \
603 %if %{without gallium_intel}
604 i915 i965 \
605 %endif
606 %ifarch sparc sparcv9 sparc64
607 ffb \
608 %endif
609 swrast"
610
611 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
612
613 gallium_drivers="svga swrast \
614 %if %{with gallium_intel}
615 i915 \
616 i965 \
617 %endif
618 r300 \
619 r600 \
620 %if %{with gallium_nouveau}
621 nouveau \
622 %endif
623 "
624
625 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
626
627 common_flags="\
628         --enable-shared \
629         --enable-selinux \
630         --enable-pic \
631         --enable-glx-tls \
632 %if %{with egl}
633         --enable-egl \
634         --enable-gles1 \
635         --enable-gles2 \
636 %endif
637 "
638
639 osmesa_common_flags="\
640         --with-driver=osmesa \
641         --disable-asm \
642         --disable-glu \
643         --disable-egl"
644
645 %if %{with osmesa}
646 %configure $common_flags $osmesa_common_flags \
647         --with-osmesa-bits=8
648 %{__make}
649 mv %{_lib} osmesa8
650 %{__make} clean
651 %endif
652
653 %configure $common_flags \
654         --enable-shared-glapi \
655 %if %{with egl}
656         --enable-egl \
657         --enable-gles1 \
658         --enable-gles2 \
659         %{__enable gbm} \
660 %endif
661 %if %{with gallium}
662         --enable-openvg \
663         %{__enable egl gallium-egl} \
664         %{__enable gbm gallium-gbm} \
665         --enable-vdpau \
666         --enable-xvmc \
667         --with-gallium-drivers=${gallium_drivers} \
668 %else
669         --disable-gallium \
670 %endif
671         --with-driver=dri \
672         --with-dri-drivers=${dri_drivers} \
673         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
674
675 %{__make}
676
677 %install
678 rm -rf $RPM_BUILD_ROOT
679
680 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
681
682 # libs without drivers
683 %{__make} install \
684         DESTDIR=$RPM_BUILD_ROOT
685
686 %if %{with osmesa}
687 cp -dp osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
688 %endif
689
690 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
691
692 # strip out undesirable headers
693 olddir=$(pwd)
694 cd $RPM_BUILD_ROOT%{_includedir}/GL
695 rm [a-fh-np-wyz]*.h
696 cd $RPM_BUILD_ROOT%{_libdir}
697 cd $olddir
698
699 %if %{with multigl}
700 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
701
702 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
703 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
704
705 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
706 %endif
707
708 %clean
709 rm -rf $RPM_BUILD_ROOT
710
711 %post   libEGL -p /sbin/ldconfig
712 %postun libEGL -p /sbin/ldconfig
713
714 %post   libGL -p /sbin/ldconfig
715 %postun libGL -p /sbin/ldconfig
716
717 %post   libGLES -p /sbin/ldconfig
718 %postun libGLES -p /sbin/ldconfig
719
720 %post   libGLU -p /sbin/ldconfig
721 %postun libGLU -p /sbin/ldconfig
722
723 %post   libOSMesa -p /sbin/ldconfig
724 %postun libOSMesa -p /sbin/ldconfig
725
726 %post   libOpenVG -p /sbin/ldconfig
727 %postun libOpenVG -p /sbin/ldconfig
728
729 %post   libXvMC -p /sbin/ldconfig
730 %postun libXvMC -p /sbin/ldconfig
731
732 %if %{with egl}
733 %files libEGL
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
736 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
737 %if %{with gbm}
738 %dir %{_libdir}/gbm
739 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
741 %endif
742 %if %{with gallium}
743 %dir %{_libdir}/egl
744 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
745 #%attr(755,root,root) %{_libdir}/egl/st_GL.so
746 %attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
747 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
748 %if %{with gbm}
749 %attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
750 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
751 %if %{with gallium_nouveau}
752 %attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
753 %endif
754 %if %{with gallium_intel}
755 %attr(755,root,root) %{_libdir}/gbm/pipe_i915.so
756 %attr(755,root,root) %{_libdir}/gbm/pipe_i965.so
757 %endif
758 %endif
759 %endif
760
761 %files libEGL-devel
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/libEGL.so
764 %dir %{_includedir}/EGL
765 %{_includedir}/EGL/egl.h
766 %{_includedir}/EGL/eglext.h
767 %{_includedir}/EGL/eglplatform.h
768 %dir %{_includedir}/KHR
769 %{_includedir}/KHR/khrplatform.h
770 %{_pkgconfigdir}/egl.pc
771 %if %{with gbm}
772 %attr(755,root,root) %{_libdir}/libgbm.so
773 %{_includedir}/gbm.h
774 %{_pkgconfigdir}/gbm.pc
775 %endif
776
777 %if %{with static_libs}
778 %files libEGL-static
779 %defattr(644,root,root,755)
780 %{_libdir}/libEGL.a
781 %endif
782 %endif
783
784 %files libGL
785 %defattr(644,root,root,755)
786 %doc docs/{*.html,README.{MITS,QUAKE,THREADS},RELNOTES*}
787 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
788 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
789 %if %{with multigl}
790 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
791 %dir %{_libdir}/Mesa
792 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
793 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
794 %else
795 %attr(755,root,root) %{_libdir}/libGL.so.*.*
796 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
797 # symlink for binary apps which fail to conform Linux OpenGL ABI
798 # (and dlopen libGL.so instead of libGL.so.1)
799 %attr(755,root,root) %{_libdir}/libGL.so
800 %endif
801
802 %files libGL-devel
803 %defattr(644,root,root,755)
804 %doc docs/*.spec
805 %attr(755,root,root) %{_libdir}/libglapi.so
806 %if %{with multigl}
807 %attr(755,root,root) %{_libdir}/libGL.so
808 %endif
809 %dir %{_includedir}/GL
810 %{_includedir}/GL/gl.h
811 %{_includedir}/GL/glext.h
812 %{_includedir}/GL/gl_mangle.h
813 %{_includedir}/GL/glx.h
814 %{_includedir}/GL/glxext.h
815 %{_includedir}/GL/glx_mangle.h
816 %dir %{_includedir}/GL/internal
817 %{_includedir}/GL/internal/dri_interface.h
818 %{_pkgconfigdir}/dri.pc
819 %{_pkgconfigdir}/gl.pc
820
821 %files libGLES
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/libGLES*.so.*.*
824 %attr(755,root,root) %ghost %{_libdir}/libGLES*.so.[0-9]
825
826 %files libGLES-devel
827 %defattr(644,root,root,755)
828 %attr(755,root,root) %{_libdir}/libGLES*.so
829 %{_includedir}/GLES
830 %{_includedir}/GLES2
831 %{_pkgconfigdir}/gles*.pc
832
833 %if %{with static_libs}
834 %files libGL-static
835 %defattr(644,root,root,755)
836 %{_libdir}/libGL.a
837 %endif
838
839 %files libGLU
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
842 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
843
844 %files libGLU-devel
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_libdir}/libGLU.so
847 %{_includedir}/GL/glu.h
848 %{_includedir}/GL/glu_mangle.h
849 %{_pkgconfigdir}/glu.pc
850
851 %if %{with static_libs}
852 %files libGLU-static
853 %defattr(644,root,root,755)
854 %{_libdir}/libGLU.a
855 %endif
856
857 %if %{with osmesa}
858 %files libOSMesa
859 %defattr(644,root,root,755)
860 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
861 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
862
863 %files libOSMesa-devel
864 %defattr(644,root,root,755)
865 %attr(755,root,root) %{_libdir}/libOSMesa*.so
866 %{_includedir}/GL/osmesa.h
867
868 %if %{with static_libs}
869 %files libOSMesa-static
870 %defattr(644,root,root,755)
871 %{_libdir}/libOSMesa*.a
872 %endif
873 %endif
874
875 %if %{with gallium}
876 %files libOpenVG
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %ghost %{_libdir}/libOpenVG.so.1
879 %attr(755,root,root) %{_libdir}/libOpenVG.so.1.0.0
880
881 %files libOpenVG-devel
882 %defattr(644,root,root,755)
883 %{_includedir}/VG
884 %{_libdir}/libOpenVG.so
885 %{_pkgconfigdir}/vg.pc
886 %endif
887
888 %files libXvMC
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
891 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1.0
892 %attr(755,root,root) %ghost %{_libdir}/libXvMCr300.so.1
893 %attr(755,root,root) %{_libdir}/libXvMCr300.so.1.0
894 %attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
895 %attr(755,root,root) %{_libdir}/libXvMCr600.so.1.0
896 %attr(755,root,root) %ghost %{_libdir}/libXvMCsoftpipe.so.1
897 %attr(755,root,root) %{_libdir}/libXvMCsoftpipe.so.1.0
898
899 %files dri-driver-ati-radeon-R100
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
902
903 %files dri-driver-ati-radeon-R200
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
906
907 %files dri-driver-ati-radeon-R300
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
910
911 %files dri-driver-ati-radeon-R600
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
914
915 # sunffb (sparc only)
916 %ifarch sparc sparcv9 sparc64
917 %files dri-driver-ffb
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
920 %endif
921
922 # glint (requires update)
923 %if 0
924 %files dri-driver-glint
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
927 %endif
928
929 %files dri-driver-intel-i915
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
932
933 %files dri-driver-intel-i965
934 %defattr(644,root,root,755)
935 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
936 %if %{with gallium_intel}
937 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
938 %endif
939
940 %if %{with gallium}
941 %if %{with gallium_nouveau}
942 %files dri-driver-nouveau
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
945 %endif
946 %endif
947
948 %files dri-driver-swrast
949 %defattr(644,root,root,755)
950 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
951
952 %if %{with gallium}
953 %files dri-driver-vmwgfx
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
956 %endif
957
958 %files -n libvdpau-driver-mesa
959 %defattr(644,root,root,755)
960 # there is no ldconfig here
961 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
962 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
963 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
964 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
965 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
966 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
967 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
968 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
969 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
970 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1.0
971 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1
972 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so
This page took 0.345683 seconds and 3 git commands to generate.