]> git.pld-linux.org Git - packages/Lunchbox.git/commitdiff
- fix building with boost 1.57.0 auto/th/Lunchbox-1.10.0-2
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 18 Feb 2015 16:10:36 +0000 (17:10 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 18 Feb 2015 16:10:36 +0000 (17:10 +0100)
- disable broken hooks in cmakefiles
- rel 2

Lunchbox.spec
boost-1.57.0.patch [new file with mode: 0644]
disable-broken-cmakefiles.patch [new file with mode: 0644]

index 8a4f04e3224c65e1e3491b3c7299ca48daa9efce..054943452655f4bcdee7bfa09d6fdd1c9e30a0e5 100644 (file)
@@ -8,13 +8,15 @@ Summary:      Lunchbox - C++ library for multi-threading programming
 Summary(pl.UTF-8):     Lunchbox - biblioteka C++ do programowania wielowątkowego
 Name:          Lunchbox
 Version:       1.10.0
-Release:       1
+Release:       2
 License:       LGPL v2.1
 Group:         Libraries
 Source0:       https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 3e01c3a2ddeeb7b3682e88092831d5a5
 Source1:       https://github.com/Eyescale/CMake/archive/139ce7d/Eyescale-CMake-139ce7d.tar.gz
 # Source1-md5: 4a6abcd9e0fc417528a8ca68a97e65eb
+Patch0:                disable-broken-cmakefiles.patch
+Patch1:                boost-1.57.0.patch
 URL:           http://pogl.wordpress.com/category/lunchbox/
 BuildRequires: avahi-devel
 BuildRequires: boost-devel >= 1.41.0
@@ -79,6 +81,9 @@ Dokumentacja API biblioteki Lunchbox.
 %{__mv} CMake-* CMake/common
 %{__rm} .gitexternals
 
+%patch0 -p1
+%patch1 -p1
+
 %build
 install -d build
 cd build
diff --git a/boost-1.57.0.patch b/boost-1.57.0.patch
new file mode 100644 (file)
index 0000000..538ae53
--- /dev/null
@@ -0,0 +1,21 @@
+From a3b3b71f2d2fe7879fb9e444e70b2d74f0269fe1 Mon Sep 17 00:00:00 2001
+From: Stefan Eilemann <Stefan.Eilemann@epfl.ch>
+Date: Sat, 27 Dec 2014 14:44:16 +0100
+Subject: [PATCH] Compile fix for Boost 1.57
+
+---
+ lunchbox/any.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lunchbox/any.h b/lunchbox/any.h
+index 9f91e40..3618f3a 100644
+--- a/lunchbox/any.h
++++ b/lunchbox/any.h
+@@ -38,6 +38,7 @@
+ #include <boost/serialization/access.hpp>
+ #include <boost/serialization/assume_abstract.hpp>
+ #include <boost/serialization/base_object.hpp>
++#include <boost/serialization/type_info_implementation.hpp>
+ #include <boost/serialization/shared_ptr.hpp>
+ // See boost/python/type_id.hpp
diff --git a/disable-broken-cmakefiles.patch b/disable-broken-cmakefiles.patch
new file mode 100644 (file)
index 0000000..21f322f
--- /dev/null
@@ -0,0 +1,34 @@
+--- Lunchbox-1.10.0/CMake/common/TargetHooks.cmake.orig        2014-10-02 12:07:38.000000000 +0200
++++ Lunchbox-1.10.0/CMake/common/TargetHooks.cmake     2015-02-18 17:06:08.678295749 +0100
+@@ -4,9 +4,7 @@
+ # multiple subprojects are built in a single go, the properties are unique per project
+ include(CMakeParseArguments)
+-include(clangcheckTargets)
+ include(CppcheckTargets)
+-include(CpplintTargets)
+ set(ALL_DEP_TARGETS "")
+ set(ALL_LIB_TARGETS "")
+@@ -19,10 +17,7 @@
+   set_property(GLOBAL PROPERTY ADD_EXE_MACRO_DEFINED "1")
+   macro(add_executable _target)
+     _add_executable(${_target} ${ARGN})
+-    add_clangcheck(${_target})
+     add_cppcheck(${_target} POSSIBLE_ERROR FAIL_ON_WARNINGS EXCLUDE_QT_MOC_FILES)
+-    add_cpplint(${_target} CATEGORY_FILTER_OUT readability/streams
+-      EXCLUDE_PATTERN ".*moc_.*\\.cxx|Buildyard/Build")
+     set_property(GLOBAL APPEND PROPERTY ${PROJECT_NAME}_ALL_DEP_TARGETS ${_target})
+   endmacro()
+ endif()
+@@ -33,10 +28,7 @@
+   set_property(GLOBAL PROPERTY ADD_LIBRARY_MACRO_DEFINED "1")
+   macro(add_library _target)
+     _add_library(${_target} ${ARGN})
+-    add_clangcheck(${_target})
+     add_cppcheck(${_target} POSSIBLE_ERROR FAIL_ON_WARNINGS EXCLUDE_QT_MOC_FILES)
+-    add_cpplint(${_target} CATEGORY_FILTER_OUT readability/streams
+-      EXCLUDE_PATTERN ".*moc_.*\\.cxx|Buildyard/Build")
+     # ignore IMPORTED add_library from finders (e.g. Qt)
+     cmake_parse_arguments(_arg "IMPORTED" "" "" ${ARGN})
This page took 0.197886 seconds and 4 git commands to generate.