]> git.pld-linux.org Git - packages/Lunchbox.git/commitdiff
upstream fix for missing include for nanosleep
authorJan Palus <atler@pld-linux.org>
Sat, 18 Feb 2023 15:32:41 +0000 (16:32 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 18 Feb 2023 15:32:41 +0000 (16:32 +0100)
Lunchbox.spec
nanosleep.patch [new file with mode: 0644]

index 87a92a3585452723942f6f9ccded5709d859542c..143bac8dd52e75bd7dec909925a1b4089dd73648 100644 (file)
@@ -13,7 +13,8 @@ Group:                Libraries
 #Source0Download: https://github.com/Eyescale/Lunchbox/releases
 Source0:       https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 76bcd79003c9b9d58d5f772cfdd812c7
-Patch2:                cxx.patch
+Patch0:                cxx.patch
+Patch1:                nanosleep.patch
 URL:           http://pogl.wordpress.com/category/lunchbox/
 BuildRequires: Eyescale-CMake >= 2018.02
 BuildRequires: Servus-devel >= 1.5.0
@@ -77,7 +78,8 @@ Dokumentacja API biblioteki Lunchbox.
 rmdir CMake/common
 ln -s %{_datadir}/Eyescale-CMake CMake/common
 
-%patch2 -p1
+%patch0 -p1
+%patch1 -p1
 
 %build
 install -d build
diff --git a/nanosleep.patch b/nanosleep.patch
new file mode 100644 (file)
index 0000000..e15aab3
--- /dev/null
@@ -0,0 +1,31 @@
+From cc9bc2387fe19d6cb130460defe52ee8ecefe968 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
+ <congdanhqx@gmail.com>
+Date: Tue, 29 Nov 2022 07:34:17 +0700
+Subject: [PATCH] stl/tuple: change uarg##N to internal linkage
+
+8b6a9c2 (std::tuple support (Resolving #103) (#104), 2021-03-11) put
+uarg##N in all translation units, which includes
+boost/phoenix/stl/tuple.hpp or boost/phoenix/stl.hpp, with external
+linkage. Thus, we'll run into below error:
+
+> multiple definition of `boost::phoenix::placeholders::uarg1'
+
+Change it to internal linkage.
+---
+ include/boost/phoenix/stl/tuple.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/boost/phoenix/stl/tuple.hpp b/include/boost/phoenix/stl/tuple.hpp
+index a83014ac..d04ad16e 100644
+--- a/include/boost/phoenix/stl/tuple.hpp
++++ b/include/boost/phoenix/stl/tuple.hpp
+@@ -110,7 +110,7 @@ namespace boost { namespace phoenix {
+     namespace placeholders {
+         #define BOOST_PP_LOCAL_LIMITS (1, BOOST_PHOENIX_ARG_LIMIT)
+         #define BOOST_PP_LOCAL_MACRO(N)                                                \
+-            auto uarg##N =                                                             \
++            const auto uarg##N =                                                       \
+             boost::phoenix::get_<(N)-1>(boost::phoenix::placeholders::arg1);
+         #include BOOST_PP_LOCAL_ITERATE()
+     }
This page took 0.073586 seconds and 4 git commands to generate.