]> git.pld-linux.org Git - packages/Lunchbox.git/blobdiff - Lunchbox.spec
boost rebuild
[packages/Lunchbox.git] / Lunchbox.spec
index affdaba2176d0c9eb441ba242af252af5b687d0b..0bccdcbf6aa1617bcf5011bae4a749f8d564459e 100644 (file)
@@ -2,36 +2,35 @@
 # Conditional build:
 %bcond_without apidocs         # do not build and package API docs
 %bcond_with    mpi             # MPI support
-%bcond_with    skv             # SKV (Scalable Key-Value Store) support
 
 Summary:       Lunchbox - C++ library for multi-threading programming
 Summary(pl.UTF-8):     Lunchbox - biblioteka C++ do programowania wielowątkowego
 Name:          Lunchbox
-Version:       1.15.0
-Release:       1
+Version:       1.17.0
+Release:       8
 License:       LGPL v2.1
 Group:         Libraries
+#Source0Download: https://github.com/Eyescale/Lunchbox/releases
 Source0:       https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 5d36a9eb706ab65572fd208574c187a2
-Patch2:                cxx.patch
+# Source0-md5: 76bcd79003c9b9d58d5f772cfdd812c7
+Patch0:                cxx.patch
+Patch1:                nanosleep.patch
 URL:           http://pogl.wordpress.com/category/lunchbox/
-BuildRequires: Eyescale-CMake >= 2016.04
+BuildRequires: Eyescale-CMake >= 2018.02
 BuildRequires: Servus-devel >= 1.5.0
 BuildRequires: avahi-devel
 BuildRequires: boost-devel >= 1.41.0
-BuildRequires: cmake >= 2.8
+BuildRequires: cmake >= 3.1
 %{?with_apidocs:BuildRequires: doxygen}
-BuildRequires: gcc-c++ >= 6:4.2
 BuildRequires: hwloc-devel >= 1.3
-BuildRequires: leveldb-devel
-BuildRequires: libgomp-devel
-BuildRequires: libjpeg-turbo-devel >= 1.2.1
+BuildRequires: hwloc-devel < 2
 BuildRequires: libstdc++-devel
 %{?with_mpi:BuildRequires:     mpi-devel}
 BuildRequires: pkgconfig
-%{?with_skv:BuildRequires:     skv-devel}
+BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 1.605
+Requires:      Servus >= 1.5.0
 Requires:      hwloc-libs >= 1.3
-Requires:      libjpeg-turbo >= 1.2.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -53,8 +52,8 @@ Summary:      Header files for Lunchbox library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Lunchbox
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      Servus-devel >= 1.5.0
 Requires:      boost-devel >= 1.41.0
-Requires:      libgomp-devel
 Requires:      libstdc++-devel
 
 %description devel
@@ -67,9 +66,7 @@ Pliki nagłówkowe biblioteki Lunchbox.
 Summary:       Lunchbox API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki Lunchbox
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description apidocs
 API documentation for Lunchbox library.
@@ -80,18 +77,19 @@ Dokumentacja API biblioteki Lunchbox.
 %prep
 %setup -q
 
+rmdir CMake/common
 ln -s %{_datadir}/Eyescale-CMake CMake/common
-%{__rm} .gitexternals
 
-%patch2 -p1
+%patch0 -p1
+%patch1 -p1
 
 %build
 install -d build
 cd build
 %cmake .. \
-       -DBUILDYARD_DISABLED=ON \
-       %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON} \
-       %{!?with_skv:-DCMAKE_DISABLE_FIND_PACKAGE_skv=ON}
+       -DCOMMON_DISABLE_WERROR:BOOL=ON \
+       %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
+
 %{__make}
 
 %if %{with apidocs}
@@ -116,13 +114,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
 %attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.8
+%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
+%dir %{_datadir}/Lunchbox
+%{_datadir}/Lunchbox/benchmarks
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libLunchbox.so
 %{_includedir}/lunchbox
-%dir %{_datadir}/Lunchbox
 %{_datadir}/Lunchbox/CMake
 
 %if %{with apidocs}
This page took 0.112888 seconds and 4 git commands to generate.