]> git.pld-linux.org Git - packages/Lunchbox.git/blame - Lunchbox.spec
- disable -Werror to be able to build with modern gcc
[packages/Lunchbox.git] / Lunchbox.spec
CommitLineData
7c02bafe
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_with mpi # MPI support
5%bcond_with skv # SKV (Scalable Key-Value Store) support
3da0d941 6
7c02bafe
JB
7Summary: Lunchbox - C++ library for multi-threading programming
8Summary(pl.UTF-8): Lunchbox - biblioteka C++ do programowania wielowątkowego
9Name: Lunchbox
99b90907 10Version: 1.15.0
87a51c8c 11Release: 2
7c02bafe
JB
12License: LGPL v2.1
13Group: Libraries
14Source0: https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
99b90907 15# Source0-md5: 5d36a9eb706ab65572fd208574c187a2
382ae9ec 16Patch2: cxx.patch
7c02bafe 17URL: http://pogl.wordpress.com/category/lunchbox/
c6de7caf 18BuildRequires: Eyescale-CMake >= 2016.04
99b90907 19BuildRequires: Servus-devel >= 1.5.0
7c02bafe
JB
20BuildRequires: avahi-devel
21BuildRequires: boost-devel >= 1.41.0
22BuildRequires: cmake >= 2.8
23%{?with_apidocs:BuildRequires: doxygen}
24BuildRequires: gcc-c++ >= 6:4.2
25BuildRequires: hwloc-devel >= 1.3
26BuildRequires: leveldb-devel
27BuildRequires: libgomp-devel
28BuildRequires: libjpeg-turbo-devel >= 1.2.1
29BuildRequires: libstdc++-devel
30%{?with_mpi:BuildRequires: mpi-devel}
31BuildRequires: pkgconfig
32%{?with_skv:BuildRequires: skv-devel}
33Requires: hwloc-libs >= 1.3
34Requires: libjpeg-turbo >= 1.2.1
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
39formerly known as eq::base or co::base, the foundation for the
40Equalizer parallel rendering framework and the Collage network
41library. It is intended for all application developers creating
42high-performance multi-threaded programs.
43
44%description -l pl.UTF-8
45Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
46była znana jako eq::base lub co::base - podstawa szkieletu do
47renderowania wielowątkowego Equalizer lub biblioteki sieciowej
48Collage. Biblioteka jest przeznaczona dla wszystkich programistów
49tworzących wysoko wydajne, wielowątkowe aplikacje.
50
51%package devel
52Summary: Header files for Lunchbox library
53Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Lunchbox
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: boost-devel >= 1.41.0
57Requires: libgomp-devel
58Requires: libstdc++-devel
59
60%description devel
61Header files for Lunchbox library.
62
63%description devel -l pl.UTF-8
64Pliki nagłówkowe biblioteki Lunchbox.
65
66%package apidocs
67Summary: Lunchbox API documentation
68Summary(pl.UTF-8): Dokumentacja API biblioteki Lunchbox
69Group: Documentation
3da0d941
ER
70%if "%{_rpmversion}" >= "5"
71BuildArch: noarch
72%endif
7c02bafe
JB
73
74%description apidocs
75API documentation for Lunchbox library.
76
77%description apidocs -l pl.UTF-8
78Dokumentacja API biblioteki Lunchbox.
79
80%prep
c6de7caf 81%setup -q
7c02bafe 82
c6de7caf 83ln -s %{_datadir}/Eyescale-CMake CMake/common
7c02bafe
JB
84%{__rm} .gitexternals
85
382ae9ec 86%patch2 -p1
c428797b 87
7c02bafe
JB
88%build
89install -d build
90cd build
91%cmake .. \
92 -DBUILDYARD_DISABLED=ON \
87a51c8c 93 -DCOMMON_DISABLE_WERROR:BOOL=ON \
7c02bafe
JB
94 %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON} \
95 %{!?with_skv:-DCMAKE_DISABLE_FIND_PACKAGE_skv=ON}
96%{__make}
97
98%if %{with apidocs}
99doxygen doc/Doxyfile
100%endif
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105%{__make} -C build install \
106 DESTDIR=$RPM_BUILD_ROOT
107
108%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(644,root,root,755)
c6de7caf 118%doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
7c02bafe 119%attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
99b90907 120%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.8
7c02bafe
JB
121
122%files devel
123%defattr(644,root,root,755)
124%attr(755,root,root) %{_libdir}/libLunchbox.so
125%{_includedir}/lunchbox
7c02bafe
JB
126%dir %{_datadir}/Lunchbox
127%{_datadir}/Lunchbox/CMake
128
129%if %{with apidocs}
130%files apidocs
131%defattr(644,root,root,755)
132%doc build/doc/html/*
133%endif
This page took 0.087253 seconds and 4 git commands to generate.