]> git.pld-linux.org Git - packages/LiVES.git/blob - LiVES.spec
- cleaned up
[packages/LiVES.git] / LiVES.spec
1
2 # TODO
3 # - some platform-independent left in %{_libdir}
4
5 %define         _sname          lives
6
7 Summary:        LiVES - the Linux Video Editing System
8 Summary(pl):    LiVES - Linuksowy System Edycji Video
9 Name:           LiVES
10 Version:        0.9.5
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications/Multimedia
14 Source0:        http://www.xs4all.nl/%7Esalsaman/lives/current/%{name}-%{version}.tar.bz2
15 # Source0-md5:  256ff1389aa1d0051394272937611753
16 Source1:        %{name}.desktop
17 Patch0:         %{name}-Makefile.am-path.patch
18 URL:            http://www.xs4all.nl/~salsaman/lives/
19 BuildRequires:  SDL-devel
20 BuildRequires:  automake >= 1:1.7
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  gettext-devel >= 0.14.1
23 BuildRequires:  gtk+2-devel >= 2.0.0
24 BuildRequires:  libtheora-devel
25 BuildRequires:  libtool
26 BuildRequires:  libvisual-devel
27 BuildRequires:  mjpegtools-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  sed >= 4.0
30 Requires:       %{name}-plugins = %{version}-%{release}
31 Requires:       ImageMagick >= 5
32 Requires:       ffmpeg
33 Requires:       mplayer >= 0.90rc1
34 Requires:       ogmtools
35 Requires:       perl-base
36 Requires:       python >= 1:2.3
37 Requires:       sox
38 Requires:       transcode
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # workaround for the next change
42 %define         _localedir      %{_usr}/share/locale
43 # platform-dependent plugins in %{_datadir}
44 %define         _datadir        %{_libdir}
45 %define         _themesdir      %{_datadir}/%{_sname}/themes
46 # shared objects without .so (e.g. SDL), which we don't want to provide
47 %define         _noautoprovfiles        ^%{_datadir}/%{_sname}/.*
48
49 %description
50 LiVES began as the Linux Video Editing System. Since it now runs on
51 more operating systems, LiVES is a Video Editing System. It is
52 designed to be simple to use, yet powerful. It is small in size, yet
53 it has many advanced features.
54
55 %description -l pl
56 LiVES zaczyna³ jako Linuksowy System Edycji Video. Obecnie mo¿na
57 równie¿ uruchomiæ go na wiêkszej liczbie systemów operacyjnych.
58 Zaprojektowany zosta³ tak, by byæ zarówno prostym w u¿yciu jak
59 i mimo niewielkiego rozmiaru posiadaæ zaawansowane funkcje.
60
61 %package plugins
62 Summary:        Plugins for LiVES
63 Summary(pl):    Wtyczki dla LiVES
64 Group:          X11/Applications/Multimedia
65 Requires:       %{name} = %{version}-%{release}
66
67 %description plugins
68 Plugins for LiVES.
69
70 %description plugins -l pl
71 Wtyczki (plugins) dla LiVES.
72
73 %package themes
74 Summary:        Themes for LiVES
75 Summary(pl):    Motywy dla LiVES
76 Group:          Themes/GTK+
77 Requires:       %{name} = %{version}-%{release}
78
79 %description themes
80 Themes for LiVES.
81
82 %description themes -l pl
83 Motywy dla LiVES.
84
85 %prep
86 %setup -qn %{_sname}-%{version}
87 %patch0 -p1
88
89 # wrrr
90 sed -i -e 's,/share/,/%{_lib}/,' po/pxgettext po/make_rfx_builtin_list.pl
91
92 %build
93 %{__aclocal} -I m4
94 %{__autoconf}
95 %{__automake}
96 # hack: DATADIRNAME defined too late in configure
97 %configure \
98         DATADIRNAME=share
99 %{__make} \
100         CFLAGS="%{rpmcflags} -fPIC"
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_desktopdir}
105 install -d $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
106 for i in lives-plugins/plugins/effects/RFXscripts/*.script ; do
107         ./build-lives-rfx-plugin $i $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
108 done
109
110 # hack: override localedir because of redefined datadir
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         localedir=%{_localedir}
114
115 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
116 mv $RPM_BUILD_ROOT%{_docdir}/%{_sname}-%{version} \
117         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
118
119 mv -f $RPM_BUILD_ROOT%{_localedir}/{cz,cs}
120 mv -f $RPM_BUILD_ROOT%{_localedir}/nl{_NL,}
121
122 %find_lang %{_sname}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files -f %{_sname}.lang
128 %defattr(644,root,root,755)
129 %doc AUTHORS BUGS CHANGELOG FEATURES GETTING.STARTED NEWS RFX OMC
130 %attr(755,root,root) %{_bindir}/*
131 %dir %{_datadir}/%{_sname}
132 %{_datadir}/%{_sname}/icons
133 %{_desktopdir}/%{name}.desktop
134 %dir %{_themesdir}
135 %{_themesdir}/default
136
137 %files themes
138 %defattr(644,root,root,755)
139 %{_themesdir}/camera
140 %{_themesdir}/cutting_room
141 %{_themesdir}/greenish
142 %{_themesdir}/pinks
143 %{_themesdir}/sunburst
144 %{_themesdir}/editor
145
146 %files plugins
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_datadir}/%{_sname}/plugins
This page took 0.079171 seconds and 3 git commands to generate.