]> git.pld-linux.org Git - packages/LiVES.git/blob - LiVES.spec
- one fix more
[packages/LiVES.git] / LiVES.spec
1
2 # TODO
3 # - some platform-independent left in %{_libdir}
4
5 %define         _sname          lives
6 %define         _pre            pre4
7
8 Summary:        LiVES - the Linux Video Editing System
9 Summary(pl):    LiVES - Linuksowy System Edycji Video
10 Name:           LiVES
11 Version:        0.9.5
12 Release:        0.%{_pre}.4
13 License:        GPL v2
14 Group:          X11/Applications/Multimedia
15 Source0:        http://www.xs4all.nl/%7Esalsaman/lives/current/%{name}-%{version}-%{_pre}.tar.bz2
16 # Source0-md5:  009900a10fc2ce8221cdce4287f3ab42
17 Source1:        %{name}.desktop
18 Patch0:         %{name}-Makefile.am-path.patch
19 Patch1:         %{name}-DESTDIR.patch
20 URL:            http://www.xs4all.nl/~salsaman/lives/
21 BuildRequires:  SDL-devel
22 BuildRequires:  automake >= 1:1.7
23 BuildRequires:  autoconf >= 2.57
24 BuildRequires:  gettext-devel >= 0.14.1
25 BuildRequires:  gtk+2-devel >= 2.0.0
26 BuildRequires:  libtheora-devel
27 BuildRequires:  libtool
28 BuildRequires:  libvisual-devel
29 BuildRequires:  mjpegtools-devel
30 BuildRequires:  pkgconfig
31 BuildRequires:  sed >= 4.0
32 Requires:       %{name}-plugins = %{version}-%{release}
33 Requires:       ImageMagick >= 5
34 Requires:       ffmpeg
35 Requires:       mplayer >= 0.90rc1
36 Requires:       ogmtools
37 Requires:       perl-base
38 Requires:       python >= 1:2.3
39 Requires:       sox
40 Requires:       transcode
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 # workaround for the next change
44 %define         _localedir      %{_usr}/share/locale
45 # platform-dependent plugins in %{_datadir}
46 %define         _datadir        %{_libdir}
47 %define         _themesdir      %{_datadir}/%{_sname}/themes
48 # shared objects without .so (e.g. SDL), which we don't want to provide
49 %define         _noautoprovfiles        ^%{_datadir}/%{_sname}/.*
50
51 %description
52 LiVES began as the Linux Video Editing System. Since it now runs on
53 more operating systems, LiVES is a Video Editing System. It is
54 designed to be simple to use, yet powerful. It is small in size, yet
55 it has many advanced features.
56
57 %description -l pl
58 LiVES zaczyna³ jako Linuksowy System Edycji Video. Obecnie mo¿na
59 równie¿ uruchomiæ go na wiêkszej liczbie systemów operacyjnych.
60 Zaprojektowany zosta³ tak, by byæ zarówno prostym w u¿yciu jak
61 i mimo niewielkiego rozmiaru posiadaæ zaawansowane funkcje.
62
63 %package plugins
64 Summary:        Plugins for LiVES
65 Summary(pl):    Wtyczki dla LiVES
66 Group:          X11/Applications/Multimedia
67 Requires:       %{name} = %{version}-%{release}
68
69 %description plugins
70 Plugins for LiVES.
71
72 %description plugins -l pl
73 Wtyczki (plugins) dla LiVES.
74
75 %package themes
76 Summary:        Themes for LiVES
77 Summary(pl):    Motywy dla LiVES
78 Group:          Themes/GTK+
79 Requires:       %{name} = %{version}-%{release}
80
81 %description themes
82 Themes for LiVES.
83
84 %description themes -l pl
85 Motywy dla LiVES.
86
87 %prep
88 %setup -q -n %{_sname}-%{version}-%{_pre}
89 %patch0 -p1
90 %patch1 -p1
91
92 # wrrr
93 sed -i -e 's,/share/,/%{_lib}/,' po/pxgettext po/make_rfx_builtin_list.pl
94
95 %build
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__automake}
99 # hack: DATADIRNAME defined too late in configure
100 %configure \
101         DATADIRNAME=share
102 %{__make} \
103         CFLAGS="%{rpmcflags} -fPIC"
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT%{_desktopdir}
108 install -d $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
109 for i in lives-plugins/plugins/effects/RFXscripts/*.script ; do
110         ./build-lives-rfx-plugin $i $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
111 done
112
113 # hack: override localedir because of redefined datadir
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         localedir=%{_localedir}
117
118 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
119 mv $RPM_BUILD_ROOT%{_docdir}/%{_sname}-%{version}-%{_pre} \
120         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
121
122 mv -f $RPM_BUILD_ROOT%{_localedir}/{cz,cs}
123 mv -f $RPM_BUILD_ROOT%{_localedir}/nl{_NL,}
124
125 %find_lang %{_sname}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files -f %{_sname}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS BUGS CHANGELOG FEATURES GETTING.STARTED NEWS RFX OMC
133 %attr(755,root,root) %{_bindir}/*
134 %dir %{_datadir}/%{_sname}
135 %{_datadir}/%{_sname}/icons
136 %{_desktopdir}/%{name}.desktop
137 %dir %{_themesdir}
138 %{_themesdir}/default
139
140 %files themes
141 %defattr(644,root,root,755)
142 %{_themesdir}/camera
143 %{_themesdir}/cutting_room
144 %{_themesdir}/greenish
145 %{_themesdir}/pinks
146 %{_themesdir}/sunburst
147 %{_themesdir}/editor
148
149 %files plugins
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_datadir}/%{_sname}/plugins
This page took 0.074662 seconds and 3 git commands to generate.