]> git.pld-linux.org Git - packages/LiDIA.git/blob - LiDIA.spec
- build and install pdf documentation
[packages/LiDIA.git] / LiDIA.spec
1 Summary:        C++ library for number theoretical computations
2 Name:           LiDIA
3 Version:        2.2.0
4 Release:        0.1
5 License:        noncommercial
6 Group:          Development/Libraries
7 Source0:        ftp://ftp.informatik.tu-darmstadt.de/pub/TI/systems/LiDIA/current/lidia-%{version}.tar.gz
8 # Source0-md5:  d9e012bb666e7a7ba1b45283aa3bfe03
9 URL:            http://www.informatik.tu-darmstadt.de/TI/LiDIA/
10 BuildRequires:  gmp-devel
11 BuildRequires:  libstdc++-devel
12 BuildRequires:  tetex-dvips
13 BuildRequires:  tetex-format-latex
14 BuildRequires:  tetex-format-pdflatex
15 BuildRequires:  tetex-latex-ae
16 BuildRequires:  texinfo-texi2dvi
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 LiDIA is a C++ library for number-theoretical computations.
21
22 LiDIA provides parameterized as well as specialized classes together
23 with advanced methods for computing in a large variety of mathematical
24 groups, rings, and fields, ranging from arbitrary-length integers,
25 fractions, and floating-point approximations, over vectors and
26 matrices, to high-level constructs of finite fields, lattices,
27 quadratic and higher-order number fields, polynomial rings, and
28 elliptic curves. In addition to a rich set of methods for basic
29 structural operations, I/O, arithmetic, and common number-theoretical
30 primitives, there are functions for computationally intensive tasks:
31 reducing lattice bases; factoring polynomials, integers, or algebraic
32 ideals; computing discrete logarithms; determining group orders on
33 elliptic curves; and more...
34
35 LiDIA is free for non-commercial use. See the copyright notice in the
36 file COPYING. Contributors are welcome.
37
38 %prep
39 %setup -q -n lidia-%{version}
40
41 %build
42 %configure \
43         --enable-shared
44 %{__make}
45 %{__make} examples
46 %{__make} pdf
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 ln -sf lidia $RPM_BUILD_ROOT%{_includedir}/%{name}
54 ln -sf lidia $RPM_BUILD_ROOT%{_datadir}/%{name}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc COPYING NEWS README TODO
62 %doc doc/LiDIA.pdf
63 %attr(755,root,root) %{_libdir}/lib*.so*
64 %{_libdir}/lib*.la
65 %{_includedir}/lidia
66 %{_includedir}/%{name}
67 %{_datadir}/lidia
68 %{_datadir}/%{name}
This page took 0.11255 seconds and 4 git commands to generate.