]> git.pld-linux.org Git - packages/LiDIA.git/blob - LiDIA.spec
- dropped pre-cvs changelog
[packages/LiDIA.git] / LiDIA.spec
1 Summary:        C++ library for number theoretical computations
2 Summary(pl.UTF-8):      Biblioteka C++ do teoretycznych obliczeń numerycznych
3 Name:           LiDIA
4 Version:        2.2.0
5 Release:        0.1
6 License:        non-commercial
7 Group:          Libraries
8 Source0:        ftp://ftp.informatik.tu-darmstadt.de/pub/TI/systems/LiDIA/current/lidia-%{version}.tar.gz
9 # Source0-md5:  d9e012bb666e7a7ba1b45283aa3bfe03
10 Patch0:         lidia-fixes.patch
11 URL:            http://www.informatik.tu-darmstadt.de/TI/LiDIA/
12 BuildRequires:  gmp-devel
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  tetex-dvips
15 BuildRequires:  tetex-format-latex
16 BuildRequires:  tetex-format-pdflatex
17 BuildRequires:  tetex-latex-ae
18 BuildRequires:  texinfo-texi2dvi
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 LiDIA is a C++ library for number-theoretical computations.
23
24 LiDIA provides parameterized as well as specialized classes together
25 with advanced methods for computing in a large variety of mathematical
26 groups, rings, and fields, ranging from arbitrary-length integers,
27 fractions, and floating-point approximations, over vectors and
28 matrices, to high-level constructs of finite fields, lattices,
29 quadratic and higher-order number fields, polynomial rings, and
30 elliptic curves. In addition to a rich set of methods for basic
31 structural operations, I/O, arithmetic, and common number-theoretical
32 primitives, there are functions for computationally intensive tasks:
33 reducing lattice bases; factoring polynomials, integers, or algebraic
34 ideals; computing discrete logarithms; determining group orders on
35 elliptic curves; and more...
36
37 LiDIA is free for non-commercial use. See the copyright notice in the
38 file COPYING. Contributors are welcome.
39
40 %description -l pl.UTF-8
41 LiDIA to biblioteka C++ do teoretycznych obliczeń numerycznych.
42 Udostępnia sparametryzowane oraz wyspecjalizowane klasy wraz z
43 zaawansowanymi metodami do obliczeń w wielu grupach, pierścieniach i
44 przestrzeniach, od liczb całkowitych dowolnej długości, ułamków i
45 przybliżeń zmiennoprzecinkowych przez wektory i macierze do
46 konstrukcji wysokopoziomowych, takich jak przestrzenie skończone,
47 kraty, przestrzenie kwadratowe i wyższego stopnia, pierścienie
48 wielomianów i krzywe eliptyczne. Oprócz bogatego zbioru metod do
49 podstawowych operacji strukturalnych, wejścia/wyjścia, arytmetycznych
50 i ogólnych prymitywów teoretycznonumerycznych są także funkcje do
51 bardziej złożonych obliczeń: redukcji baz krat; rozkładu wielomianów,
52 liczb całkowitych i ideałów algebraicznych; obliczania logarytmów
53 dyskretnych; określania porządku w grupie na krzywych eliptycznych;
54 itp.
55
56 LiDIA jest darmowa do użytku niekomercyjnego. Informacje o prawach
57 autorskich znajdują się w pliku COPYING. Wspieranie rozwoju jest mile
58 widziane.
59
60 %package devel
61 Summary:        Header files for LiDIA library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LiDIA
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Header files for LiDIA library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki LiDIA.
71
72 %package static
73 Summary:        Static LiDIA library
74 Summary(pl.UTF-8):      Statyczna biblioteka LiDIA
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static LiDIA library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka LiDIA.
83
84 %prep
85 %setup -q -n lidia-%{version}
86 %patch0 -p1
87
88 %build
89 %configure \
90         --enable-shared
91 %{__make}
92 %{__make} examples
93 # "unknown language: LaTeX"
94 %{__make} pdf \
95         LATEX2DVI='$(TEXI2DVI) -l latex'
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 ln -sf lidia $RPM_BUILD_ROOT%{_includedir}/%{name}
104 ln -sf lidia $RPM_BUILD_ROOT%{_datadir}/%{name}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc COPYING ChangeLog NEWS README TODO
115 %attr(755,root,root) %{_libdir}/libLiDIA.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libLiDIA.so.5
117 %{_datadir}/lidia
118 %{_datadir}/%{name}
119
120 %files devel
121 %defattr(644,root,root,755)
122 %doc doc/LiDIA.pdf
123 %attr(755,root,root) %{_libdir}/libLiDIA.so
124 %{_libdir}/libLiDIA.la
125 %{_includedir}/lidia
126 %{_includedir}/%{name}
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libLiDIA.a
This page took 0.452752 seconds and 3 git commands to generate.