]> git.pld-linux.org Git - packages/LTI-Lib.git/blob - LTI-Lib.spec
- initial release.
[packages/LTI-Lib.git] / LTI-Lib.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx
4 %bcond_with     sse
5 %bcond_with     3dnow
6 %bcond_without  gtk
7
8 Summary:        LTI-Lib - computer vision library.
9 Summary(pl):    LTI-Lib - biblioteka do komputerowego przetwarzania obrazów.
10 Name:           LTI-Lib
11 Version:        1.9.8
12 Release:        1
13 License:        LGPL
14 Group:          Development/Libraries
15 Source0:        http://cesnet.dl.sourceforge.net/sourceforge/ltilib/031124_ltilib-%{version}.tar.bz2
16 # Source0-md5:  dfa6616f3dc5dae04e84311764181b96
17 Patch0:         %{name}-Makefile.patch
18 URL:            http://ltilib.sourceforge.net/doc/homepage/index.shtml
19 BuildRequires:  gcc-g77
20 BuildRequires:  doxygen
21 BuildRequires:  graphviz
22 BuildRequires:  tetex-latex-bibtex
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  XFree86-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 %if %{with gtk}
28 BuildRequires:  gtk+-devel
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The LTI-Lib is an object oriented library with algorithms and data
34 structures frequently used in image processing and computer vision.
35
36 %description -l pl
37 LTI-Lib jest zorientowan± obiektowo biliotek± zawieraj±c± najczê¶ciej
38 u¿ywane algorytmy i struktury danych w procesach przetwarzania
39 i analizy obrazów.
40
41 %package doc
42 Summary:        LTI-Lib - documentation
43 Summary(pl):    LTI-Lib - dokumentacja
44 Group:          Development/Libraries
45
46 %description doc
47 LTI-Lib documentation.
48
49 %description doc -l pl
50 Dokumentacja biblioteki LTI-Lib.
51
52 %prep
53 %setup -q -n ltilib
54 %patch0 -p1
55
56 %build
57 cd doc/styleguide/en
58 %{__make} pdf
59
60 cd ../../../linux
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64
65 %ifarch i386
66     _ac_cpu="Generic i386"      ; export _ac_cpu
67     _ac_mmx="no"                ; export _ac_mmx
68     _ac_sse="no"                ; export _ac_sse
69     _ac_3dnow="no"              ; export _ac_3dnow
70 %endif
71
72 %ifarch i486
73     _ac_cpu="Generic i486"      ; export _ac_cpu
74     _ac_mmx="no"                ; export _ac_mmx
75     _ac_sse="no"                ; export _ac_sse
76     _ac_3dnow="no"              ; export _ac_3dnow
77 %endif
78
79 %ifarch i586
80     _ac_cpu="Generic Pentium"   ; export _ac_cpu
81     _ac_mmx="no"                ; export _ac_mmx
82     _ac_sse="no"                ; export _ac_sse
83     _ac_3dnow="no"              ; export _ac_3dnow
84 %endif
85
86 %ifarch i686
87     _ac_cpu="Generic i686"      ; export _ac_cpu
88     _ac_mmx="yes"               ; export _ac_mmx
89     _ac_sse="no"                ; export _ac_sse
90     _ac_3dnow="no"              ; export _ac_3dnow
91 %endif
92
93 %ifarch athlon
94     _ac_cpu="Generic Athlon"    ; export _ac_cpu
95     _ac_mmx="yes"               ; export _ac_mmx
96     _ac_sse="no"                ; export _ac_sse
97     _ac_3dnow="yes"             ; export _ac_3dnow
98 %endif
99
100 %if %{with mmx}
101     _ac_mmx="yes"               ; export _ac_mmx
102 %endif
103
104 %if %{with sse}
105     _ac_sse="yes"               ; export _ac_sse
106 %endif
107
108 %if %{with 3dnow}
109     _ac_3dnow="yes"             ; export _ac_3dnow
110 %endif
111
112 %configure \
113 %if %{without gtk}
114         --without-gtk \
115 %endif
116         --disable-debug
117
118 %{__make} doxydoc
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT/%{_docdir}/%{name}-doc
125
126 cp doc/html/*.html      $RPM_BUILD_ROOT/%{_docdir}/%{name}-doc
127 cp doc/html/*.png       $RPM_BUILD_ROOT/%{_docdir}/%{name}-doc
128 cp doc/html/*.gif       $RPM_BUILD_ROOT/%{_docdir}/%{name}-doc
129
130 cd linux
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 rm -f $RPM_BUILD_ROOT%{_prefix}/lib/ltilib
135 rm -f $RPM_BUILD_ROOT%{_includedir}/ltilib
136
137 cd $RPM_BUILD_ROOT%{_prefix}/lib
138 ln -s ltilib-%{version} ltilib
139 cd $RPM_BUILD_ROOT%{_includedir}
140 ln -s ltilib-%{version} ltilib
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files
146 %defattr(644,root,root,755)
147 %doc README doc/styleguide/en/*.pdf
148 %attr(755,root,root) %{_bindir}/*
149 %{_includedir}/ltilib
150 %{_includedir}/ltilib-%{version}/*
151 %{_libdir}/ltilib
152 %{_libdir}/ltilib-%{version}/*
153
154 %files doc
155 %defattr(644,root,root,755)
156 %{_docdir}/%{name}-doc
This page took 0.04438 seconds and 4 git commands to generate.