]> git.pld-linux.org Git - packages/InDependence.git/blob - InDependence.spec
f8dafe87bfe6ab008a1c3b356f82e819c7927e84
[packages/InDependence.git] / InDependence.spec
1 Summary:        RPM Dependency Tracker
2 Name:           InDependence
3 Version:        1.0
4 Release:        1
5 Group:          Applications/System
6 Source0:        %{name}_%{version}.tar.gz
7 # Source0-md5:  df419e1443683305891060985f723902
8 Patch0:         %{name}_1.0-rpmlib.asp.patch
9 License:        Artistic License
10 URL:            http://www.cse.ogi.edu/DISC/projects/independence/
11 BuildArch:      noarch
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 InDependence is a suite of tools (well two :-) designed to help RPM
16 packagers and system administrators deal with the dependencies between
17 RPM packages. InDependence has two major components:
18
19 Dep: This tool is for the RPM packager that identifies external files
20 or RPM packages that a program uses.
21
22 RPMTC: "RPM Transitive Closure". This tool is for the RPM system
23 administrator. "rpmtc foo.rpm" will transitively compute the -
24 - *entire* set of RPMs necessary to support the foo.rpm package, i.e.
25   if foo.rpm depends on bar.rpm, and bar.rpm depends on baz.rpm, RPMTC
26   will report both bar and baz.
27
28 %prep
29 %setup -q -n %{name}_%{version}
30 %patch0 -p1
31
32 %build
33 %{__make}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d ${RPM_BUILD_ROOT}%{_bindir}
38 install dep/dep ${RPM_BUILD_ROOT}%{_bindir}/dep
39 install dep/swrapper.pl ${RPM_BUILD_ROOT}%{_bindir}/swrapper.pl
40 install rpmtc/rpmtc ${RPM_BUILD_ROOT}%{_bindir}/rpmtc
41 install rpmtc/rpmdep-pipe ${RPM_BUILD_ROOT}%{_bindir}/rpmdep-pipe
42 install -d ${RPM_BUILD_ROOT}%{_mandir}/man1
43 install dep/dep.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/dep.1
44 install rpmtc/rpmtc.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/rpmtc.1
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc README
52 %attr(755,root,root) %{_bindir}/dep
53 %attr(755,root,root) %{_bindir}/rpmdep-pipe
54 %attr(755,root,root) %{_bindir}/rpmtc
55 %attr(755,root,root) %{_bindir}/swrapper.pl
56 %{_mandir}/man1/dep.1*
57 %{_mandir}/man1/rpmtc.1*
This page took 0.070543 seconds and 2 git commands to generate.