]> git.pld-linux.org Git - packages/InDependence.git/blob - InDependence.spec
- cflags, and therefore not noarch
[packages/InDependence.git] / InDependence.spec
1 Summary:        RPM Dependency Tracker
2 Name:           InDependence
3 Version:        1.0
4 Release:        1
5 Group:          Applications/System
6 Source0:        %{name}_%{version}.tar.gz
7 # Source0-md5:  df419e1443683305891060985f723902
8 Patch0:         %{name}-rpmlib.patch
9 License:        Artistic License
10 URL:            http://www.cse.ogi.edu/DISC/projects/independence/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 InDependence is a suite of tools (well two :-) designed to help RPM
15 packagers and system administrators deal with the dependencies between
16 RPM packages. InDependence has two major components:
17
18 Dep: This tool is for the RPM packager that identifies external files
19 or RPM packages that a program uses.
20
21 RPMTC: "RPM Transitive Closure". This tool is for the RPM system
22 administrator. "rpmtc foo.rpm" will transitively compute the -
23 - *entire* set of RPMs necessary to support the foo.rpm package, i.e.
24   if foo.rpm depends on bar.rpm, and bar.rpm depends on baz.rpm, RPMTC
25   will report both bar and baz.
26
27 %prep
28 %setup -q -n %{name}_%{version}
29 %patch0 -p1
30
31 %build
32 %{__make} \
33         CC="%{__cc}"
34         CFLAGS="%{rpmcflags}" \
35         LDFLAGS="%{rpmldflags}"
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d ${RPM_BUILD_ROOT}%{_bindir}
40 install dep/dep ${RPM_BUILD_ROOT}%{_bindir}/dep
41 install dep/swrapper.pl ${RPM_BUILD_ROOT}%{_bindir}/swrapper.pl
42 install rpmtc/rpmtc ${RPM_BUILD_ROOT}%{_bindir}/rpmtc
43 install rpmtc/rpmdep-pipe ${RPM_BUILD_ROOT}%{_bindir}/rpmdep-pipe
44 install -d ${RPM_BUILD_ROOT}%{_mandir}/man1
45 install dep/dep.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/dep.1
46 install rpmtc/rpmtc.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/rpmtc.1
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README
54 %attr(755,root,root) %{_bindir}/dep
55 %attr(755,root,root) %{_bindir}/rpmdep-pipe
56 %attr(755,root,root) %{_bindir}/rpmtc
57 %attr(755,root,root) %{_bindir}/swrapper.pl
58 %{_mandir}/man1/dep.1*
59 %{_mandir}/man1/rpmtc.1*
This page took 0.083789 seconds and 3 git commands to generate.