]> git.pld-linux.org Git - packages/ImageMagick.git/blobdiff - ImageMagick.spec
- unified heif bcond name (for heic module)
[packages/ImageMagick.git] / ImageMagick.spec
index b4c88ef6dab0425e4b3ceb46629a0cafa99a76bb..f5cfa33cc5e7919512a7a8bdec3a3de09a167ff8 100644 (file)
@@ -3,6 +3,7 @@
 #   https://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=26801
 #
 # Conditional build:
+%bcond_without  tests
 # - features:
 %bcond_without cxx             # Magick++ library
 %bcond_without opencl          # OpenCL computing support
@@ -16,7 +17,8 @@
 %bcond_without fpx             # FlashPIX module (which uses fpx library)
 %bcond_without flif            # FLIF (Free Lossless Image Format) module (which uses flif library)
 %bcond_without graphviz        # dot module (which uses GraphViz libraries)
-%bcond_without libjxl          # JPEG-XL module (not ready for 0.6)
+%bcond_without heif            # HEIC module (which uses libheif library)
+%bcond_without libjxl          # JPEG-XL module
 %bcond_without openjpeg        # JPEG2000 module (which uses openjpeg 2 library)
 %bcond_without wmf             # WMF module (which uses libwmf library)
 # - module features:
@@ -24,8 +26,8 @@
 
 %define        libpng_ver 2:1.6.34
 
-%define                ver     7.1.0
-%define                pver    60
+%define                ver     7.1.1
+%define                pver    31
 Summary:       Image display, conversion, and manipulation under X
 Summary(de.UTF-8):     Darstellen, Konvertieren und Bearbeiten von Grafiken unter X
 Summary(es.UTF-8):     Exhibidor, convertidor y manipulador de imágenes bajo X
@@ -37,33 +39,31 @@ Summary(tr.UTF-8):  X altında resim gösterme, çevirme ve değişiklik yapma
 Summary(uk.UTF-8):     Перегляд, конвертування та обробка зображень під X Window
 Name:          ImageMagick
 Version:       %{ver}%{?pver:.%{pver}}
-Release:       0.1
+Release:       1
 Epoch:         1
 License:       Apache-like
 Group:         X11/Applications/Graphics
-Source0:       https://www.imagemagick.org/download/releases/%{name}-%{ver}-%{pver}.tar.xz
-# Source0-md5: fbb79241137a6c8f7f161eda29973f62
-Patch0:                config.patch
+Source0:       https://download.imagemagick.org/archive/releases/%{name}-%{ver}-%{pver}.tar.lz
+# Source0-md5: 70ca8d5bed3e99dd9b828571b78825d8
+Patch0:                %{name}-perl.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-libpath.patch
 Patch3:                %{name}-ldflags.patch
 Patch4:                %{name}-lt.patch
 Patch5:                %{name}-OpenCL.patch
-Patch6:                %{name}-autotrace.patch
-Patch7:                %{name}-jxl.patch
 URL:           https://imagemagick.org/
 %{?with_opencl:BuildRequires:  OpenCL-devel}
 %{?with_exr:BuildRequires:     OpenEXR-devel >= 1.0.6}
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake >= 1:1.12
-%{?with_autotrace:BuildRequires:       autotrace-devel >= 0.31.1}
+%{?with_autotrace:BuildRequires:       autotrace-devel >= 0.31.2}
 BuildRequires: bzip2-devel >= 1.0.1
 %{?with_djvu:BuildRequires:    djvulibre-devel >= 3.5.0}
 BuildRequires: expat-devel >= 1.95.7
 BuildRequires: fftw3-devel >= 3.0
 %{?with_flif:BuildRequires:    flif-devel}
 BuildRequires: fontconfig-devel >= 2.1.0
-BuildRequires: freetype-devel >= 2.0.2-2
+BuildRequires: freetype-devel >= 1:2.8.0
 %{?with_openmp:BuildRequires:  gcc-c++ >= 6:4.2}
 %{?with_gs:BuildRequires:      ghostscript-devel}
 %{?with_graphviz:BuildRequires:        graphviz-devel >= 2.9.0}
@@ -71,9 +71,9 @@ BuildRequires:        jbigkit-devel
 BuildRequires: lcms2-devel >= 2.0
 %{?with_fpx:BuildRequires:     libfpx-devel >= 1.2.0.4-3}
 %{?with_openmp:BuildRequires:  libgomp-devel}
-BuildRequires: libheif-devel
+%{?with_heif:BuildRequires:    libheif-devel >= 1.4.0}
 BuildRequires: libjpeg-devel >= 6b
-%{?with_libjxl:BuildRequires:  libjxl-devel >= 0.6.1}
+%{?with_libjxl:BuildRequires:  libjxl-devel >= 0.7.0}
 BuildRequires: liblqr-devel >= 0.1.0
 BuildRequires: libltdl-devel
 BuildRequires: libpng-devel >= %{libpng_ver}
@@ -87,6 +87,7 @@ BuildRequires:        libwebp-devel >= 0.5.0
 %{?with_wmf:BuildRequires:     libwmf-devel >= 2:0.2.2}
 BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libzip-devel >= 1.0.0
+BuildRequires: lzip
 %{?with_openjpeg:BuildRequires:        openjpeg2-devel >= 2.1.0}
 BuildRequires: pango-devel >= 1:1.28.1
 BuildRequires: perl-devel >= 1:5.8.1
@@ -98,7 +99,6 @@ BuildRequires:        tar >= 1:1.22
 #BuildRequires:        txt2html
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
-BuildRequires: xz
 BuildRequires: xz-devel >= 2.9.0
 BuildRequires: zlib-devel >= 1.0.0
 BuildRequires: zstd-devel >= 1.0.0
@@ -215,7 +215,7 @@ Requires:   %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      bzip2-devel >= 1.0.1
 Requires:      fftw3-devel >= 3.0
 Requires:      fontconfig-devel >= 2.1.0
-Requires:      freetype-devel >= 2.0.2
+Requires:      freetype-devel >= 1:2.8.0
 Requires:      lcms2-devel >= 2.0
 %{?with_openmp:Requires:       libgomp-devel}
 Requires:      liblqr-devel >= 0.1.0
@@ -532,6 +532,7 @@ Summary:    Coder module for HEIC files
 Summary(pl.UTF-8):     Moduł kodera dla plików HEIC
 Group:         X11/Applications/Graphics
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      libheif >= 1.4.0
 
 %description coder-heic
 Coder module for HEIC files.
@@ -581,7 +582,7 @@ Summary:    Coder module for JPEG-XL files
 Summary(pl.UTF-8):     Moduł kodera dla plików JPEG-XL
 Group:         X11/Applications/Graphics
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      libjxl >= 0.6.1
+Requires:      libjxl >= 0.7.0
 
 %description coder-jxl
 Coder module for JPEG-XL files.
@@ -751,8 +752,6 @@ Moduł kodera dla plików WMF.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1 -R
-#%patch7 -p1
 
 find -type f | xargs grep -l '/usr/local/bin/perl' | xargs %{__sed} -i -e 's=!/usr/local/bin/perl=!%{__perl}='
 
@@ -784,6 +783,7 @@ touch www/Magick++/NEWS.html www/Magick++/ChangeLog.html
        --with-gs-font-dir=%{_fontsdir}/Type1 \
        --with-gslib%{!?with_gs:=no} \
        --with-gvc%{!?with_graphviz:=no} \
+       --with-heic%{!?with_heif:=no} \
        --with-jxl%{!?with_libjxl:=no} \
        --with-magick_plus_plus%{!?with_cxx:=no} \
        --with-openexr%{!?with_exr:=no} \
@@ -801,6 +801,8 @@ touch www/Magick++/NEWS.html www/Magick++/ChangeLog.html
 %{__make} -j1
 %{__sed} -i -e 's,/%{name}-%{ver}/,/%{name}-doc-%{version}/,' utilities/*.1
 
+%{?with_tests:%{__make} check}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-perl-%{version}
@@ -818,7 +820,7 @@ cp -p PerlMagick/demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-perl-%{version}
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Image/Magick/.packlist
 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
 # packaged as %doc
-%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{mver}/{LICENSE,NEWS.txt}
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{mver}/LICENSE
 # obsoleted by pkg-config
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
 
@@ -1165,11 +1167,13 @@ rm -rf $RPM_BUILD_ROOT
 %{modulesdir}/coders/fpx.la
 %endif
 
+%if %{with heif}
 %files coder-heic
 %defattr(644,root,root,755)
 # R: libheif
 %attr(755,root,root) %{modulesdir}/coders/heic.so
 %{modulesdir}/coders/heic.la
+%endif
 
 %files coder-jbig
 %defattr(644,root,root,755)
@@ -1191,7 +1195,6 @@ rm -rf $RPM_BUILD_ROOT
 %{modulesdir}/coders/jp2.la
 %endif
 
-%if 0
 %if %{with libjxl}
 %files coder-jxl
 %defattr(644,root,root,755)
@@ -1199,7 +1202,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{modulesdir}/coders/jxl.so
 %{modulesdir}/coders/jxl.la
 %endif
-%endif
 
 %files coder-miff
 %defattr(644,root,root,755)
This page took 0.050198 seconds and 4 git commands to generate.