]> git.pld-linux.org Git - packages/Glide_V3-DRI.git/blob - Glide_V3-DRI.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/Glide_V3-DRI.git] / Glide_V3-DRI.spec
1 %define snapdate 20010309
2 Summary:        Glide runtime for 3Dfx Voodoo Banshee and Voodoo3 boards
3 Summary(pl):    Biblioteki Glide dla kart 3Dfx Voodoo Banshee oraz Voodoo3
4 Name:           Glide_V3-DRI
5 Version:        3.10.0
6 Release:        0.%{snapdate}.6
7 Epoch:          1
8 License:        3dfx Glide General Public License, 3Dfx Interactive Inc.
9 Vendor:         3dfx Interactive Inc.
10 Group:          X11/Libraries
11 Source0:        cvs://anonymous@cvs.glide.sourceforge.net:/cvsroot/glide/glide3x-%{snapdate}.tar.gz
12 Patch0:         glide-ia64.patch
13 Patch1:         glide-ac-workaround.patch
14 Patch2:         glide-h3.patch
15 Patch3:         glide-h5.patch
16 Icon:           3dfx.gif
17 URL:            http://glide.sourceforge.net/
18 BuildRequires:  XFree86-devel
19 BuildRequires:  automake
20 BuildRequires:  autoconf
21 BuildRequires:  libtool
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 Provides:       Glide3-DRI
24 Obsoletes:      Glide_V5-DRI
25
26 %description 
27 This library allows the user to use a 3dfx Interactive Voodoo Banshee
28 or Voodoo3 card under Linux with DRI support. The source support DRI
29 or non-DRI versions of Glide.
30
31 %description -l pl
32 Ta biblioteka pozwala u¿ytkownikowi na u¿ywanie kart 3dfx Interactive
33 Voodoo Banshee lub Voodoo3 pod Linuksem z DRI. Ta wersja zawiera
34 wsparcie dla wersji Glide z DRI i bez DRI.
35
36 %package devel
37 Summary:        Development headers for Glide 3.x
38 Summary(pl):    Pliki nag³ówkowe Glide 3.x
39 Group:          X11/Development/Libraries
40 Requires:       %{name} = %{version}
41 Provides:       Glide3-DRI-devel
42 Obsoletes:      Glide_V5-DRI-devel
43
44 %description devel
45 This package includes the headers files, documentation, and test files
46 necessary for developing applications that use the 3Dfx Interactive
47 Voodoo Banshee or Voodoo3 cards.
48
49 %description devel -l pl
50 Ten pakiet zawiera pliki nag³ówkowe, dokumentacje, oraz pliki tekstowe
51 wymagane przez aplikacje deweloperskie, które u¿ywaj± kart 3Dfx
52 Interactive Voodoo Banshe lub Voodoo3.
53
54 %package static
55 Summary:        Static library Glide 3.x
56 Summary(pl):    Statyczne biblioteki Glide 3.x
57 Group:          X11/Development/Libraries
58 Requires:       %{name}-devel = %{version}
59 Provides:       Glide3-DRI-static
60 Obsoletes:      Glide_V5-DRI-static
61
62 %description static
63 This package includes the static Glide3 library for Voodoo Banshee or
64 Voodoo3 cards.
65
66 %description static -l pl
67 Ten pakiet zawiera statyczne biblioteki Glide3 dla kart Voodoo Banshee
68 lub Voodoo3.
69
70 %prep
71 %setup -q -n glide3x-%{snapdate}
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76
77 %build
78 rm -f missing
79 libtoolize --copy --force
80 aclocal
81 autoconf
82 automake -a -c -i
83 %configure \
84         --enable-fx-dri-build \
85         --enable-fx-glide-hw=h3 \
86         --enable-fx-debug=no \
87 %ifarch i586 i686 athlon
88         --enable-amd3d
89 %endif
90
91 %{__make} -f makefile.autoconf all \
92         GLIDE_DEBUG_GCFLAGS="%{rpmcflags} -fno-expensive-optimizations %{!?debug:-fomit-frame-pointer -ffast-math}" \
93         GLIDE_DEBUG_GDEFS="%{!?debug:-DBIG_OPT} %{?debug:-DGDBG_INFO_ON -DGLIDE_DEBUG}"
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
98
99 # something is recompiled - use GCFLAGS too
100 %{__make} -f makefile.autoconf install \
101         GLIDE_DEBUG_GCFLAGS="%{rpmcflags} -fno-expensive-optimizations %{!?debug:-fomit-frame-pointer -ffast-math}" \
102         GLIDE_DEBUG_GDEFS="%{!?debug:-DBIG_OPT} %{?debug:-DGDBG_INFO_ON -DGLIDE_DEBUG}" \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 ln -sf libglide3.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libglide3x_V3.so
106 ln -sf libglide3.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libglide3x.so
107
108 # Install the examples and their source, no binaries
109 install h3/glide3/tests/makefile.distrib $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests/makefile
110 install h3/glide3/tests/*.3df $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
111 install h3/glide3/tests/test??.c $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
112 install h3/glide3/tests/tldata.inc $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
113 install h3/glide3/tests/tlib.[ch] $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
114
115 gzip -9nf glide_license.txt
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc glide_license.txt.gz
126 %attr(755,root,root) %{_libdir}/libglide3.so.*.*.*
127 %attr(755,root,root) %{_libdir}/libglide3x.so
128 %attr(755,root,root) %{_libdir}/libglide3x_V3.so
129
130 %files devel
131 %defattr(644,root,root,755)
132 %{_examplesdir}/glide3
133 %attr(755,root,root) %{_libdir}/lib*.la
134 %attr(755,root,root) %{_libdir}/libglide3.so
135 %{_includedir}/glide3
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/lib*.a
This page took 0.086838 seconds and 3 git commands to generate.