]> git.pld-linux.org Git - packages/GeoIP-db-City.git/blobdiff - GeoIP-db-City.spec
updated to 2016.10.31
[packages/GeoIP-db-City.git] / GeoIP-db-City.spec
index ef0819ea34d18baf03fbf32feeab4080a42c4881..23a1e5f7c45327badb479a1381f6c385c5bd91e8 100644 (file)
@@ -2,15 +2,17 @@ Summary:      GeoLite City - City database for GeoIP
 Summary(pl.UTF-8):     GeoLite City - baza danych miast dla GeoIP
 Name:          GeoIP-db-City
 # Updated every month:
-Version:       2012.10.03
+Version:       2016.10.31
 Release:       1
-License:       OPEN DATA LICENSE (see LICENSE.txt)
+License:       CC 3.0 BY-SA
 Group:         Applications/Databases
-Source0:       http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
-# Source0-md5: cba2cf7359950e6010aa752721008f16
-Source1:       http://www.maxmind.com/download/geoip/database/LICENSE.txt
-# Source1-md5: a1381bd1aa0a0c91dc31b3f1e847cf4a
-URL:           http://www.maxmind.com/app/geolitecity
+Source0:       http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.xz?/GeoLiteCity-%{version}.dat.xz
+# Source0-md5: b5756b048ecc680140bd2bbe9874cc96
+Source1:       http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz?/GeoLiteCityv6-%{version}.dat.gz
+# Source1-md5: 78c56505f04a31e499c8ee1c5dcabbaa
+URL:           http://dev.maxmind.com/geoip/legacy/geolite/
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -28,16 +30,32 @@ miejski, szerokość i wysokość geograficzną dla adresów IP z całego
 świata.
 
 Informacja licencyjna: ten produkt zawiera dane GeoLite stworzone
-przez MaxWind, dostępne z <http://www.maxwind.com/>.
+przez MaxMind, dostępne z <http://www.maxmind.com/>.
 
 %prep
 %setup -qcT
 cp -p %{SOURCE0} .
 cp -p %{SOURCE1} .
 
-gunzip GeoLiteCity.dat.gz
+xz -d GeoLiteCity-%{version}.dat.xz
+gunzip GeoLiteCityv6-%{version}.dat.gz
 
-ver=$(TZ=GMT stat -c '%y' GeoLiteCity.dat | awk '{print $1}' | tr - .)
+%build
+# get file DATE in GMT timezone
+filedate() {
+       TZ=GMT stat -c '%y' "$1" | awk '{print $1}'
+}
+
+# use newest file date as version
+d1=$(filedate GeoLiteCity-%{version}.dat)
+d2=$(filedate GeoLiteCityv6-%{version}.dat)
+if [ "$(echo $d1 | tr -d -)" -gt "$(echo $d2 | tr -d -)" ]; then
+       d=$d1
+else
+       d=$d2
+fi
+
+ver=$(echo $d | tr - .)
 if [ "$ver" != %{version} ]; then
        exit 1
 fi
@@ -45,13 +63,15 @@ fi
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_datadir}/GeoIP
-cp -p GeoLiteCity.dat $RPM_BUILD_ROOT%{_datadir}/GeoIP
+cp -p GeoLiteCity-%{version}.dat $RPM_BUILD_ROOT%{_datadir}/GeoIP/GeoLiteCity.dat
 ln -s GeoLiteCity.dat $RPM_BUILD_ROOT%{_datadir}/GeoIP/GeoIPCity.dat
 
+cp -p GeoLiteCityv6-%{version}.dat $RPM_BUILD_ROOT%{_datadir}/GeoIP/GeoLiteCityv6.dat
+ln -s GeoLiteCityv6.dat $RPM_BUILD_ROOT%{_datadir}/GeoIP/GeoIPCityv6.dat
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.txt
 %{_datadir}/GeoIP/*.dat
This page took 0.093511 seconds and 4 git commands to generate.