]> git.pld-linux.org Git - packages/Gauche.git/blob - Gauche.spec
- massive attack s/pld.org.pl/pld-linux.org/
[packages/Gauche.git] / Gauche.spec
1 # $Id: Gauche.spec,v 1.5 2003-05-25 05:45:21 misi3k Exp $
2 Summary:        Scheme script interpreter with multibyte character handling
3 Summary(pl):    Interpreter Scheme obs³uguj±cy wielobajtowe kodowanie znaków
4 Name:           Gauche
5 Version:        0.5.5
6 Release:        2
7 License:        BSD
8 Group:          Development/Languages
9 Source0:        http://telia.dl.sourceforge.net/sourceforge/gauche/%{name}-%{version}.tgz
10 Patch0:         %{name}-install.patch
11 BuildRequires:  gdbm-devel >= 1.8.0
12 BuildRequires:  slib
13 Requires:       slib
14 URL:            http://www.shiro.dreamhost.com/scheme/gauche/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Gauche is a Scheme interpreter conforming Revised^5 Report on
19 Algorithmic Language Scheme. It is designed for rapid development of
20 daily tools like system management and text processing. It can handle
21 multibyte character strings natively. This package is compiled with
22 utf-8 as the native character encoding.
23
24 %description -l pl
25 Gauche jest interpreterem jêzyka Scheme zgodnym z "Revised^5 Report on
26 Algorithmic Language Scheme". Jest on zaprojektowany do szybkiego
27 tworzenia codziennych narzêdzi, jak zarz±dzania systemem lub
28 przetwarzanie tekstu. Potrafi on obs³ugiwaæ natywnie wielobajtowe
29 kodowanie znaków (jak na przyk³ad unicode). Ten pakiet jest
30 skompilowany z utf-8 jako natywnym kodowaniem znaków.
31
32 %package static
33 Summary:        Static version of Gauche runtime libary
34 Summary(pl):    Statyczna wersja biblioteki czasu wykonania Gauche
35 Group:          Development/Languages
36 Requires:       %{name} = %{version}
37
38 %description static
39 Static version of Gauche runtime libary.
40
41 %description static -l pl
42 Statyczna wersja biblioteki czasu wykonania Gauche.
43
44 %package dbm
45 Summary:        Gauche bindings for GDBM library
46 Summary(pl):    Wi±zania do biblioteki GDBM dla Gauche
47 Group:          Development/Languages
48 Requires:       %{name} = %{version}
49
50 %description dbm
51 Gauche bindings for GDBM library.
52
53 %description dbm -l pl
54 Wi±zania do biblioteki GDBM dla Gauche.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59
60 %build
61 %configure \
62         --enable-multibyte=utf-8 \
63         --with-slib=%{_datadir}/guile/slib \
64         --with-pthread
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT
71
72 echo "echo $RPM_BUILD_ROOT\$(sh $(pwd)/src/gauche-config \"\$@\")" >src/gauche-config-install
73
74 %{__make} \
75         LIB_INSTALL_DIR=$RPM_BUILD_ROOT%{_libdir} \
76         BIN_INSTALL_DIR=$RPM_BUILD_ROOT%{_bindir} \
77         DATA_INSTALL_DIR=$RPM_BUILD_ROOT%{_datadir} \
78         GAUCHE_DATA_DIR=$RPM_BUILD_ROOT%{_datadir}/gauche \
79         GAUCHE_ARCH_DIR=$RPM_BUILD_ROOT%{_libdir}/gauche \
80         SCM_INSTALL_DIR=$RPM_BUILD_ROOT%{_datadir}/gauche/%{version}/lib \
81         GAUCHE_CONFIG="sh $(pwd)/src/gauche-config-install" \
82         install-rpm
83
84 install -d $RPM_BUILD_ROOT%{_includedir}
85 mv $RPM_BUILD_ROOT%{_libdir}/gauche/%{version}/include/* $RPM_BUILD_ROOT%{_includedir}
86
87 install -d $RPM_BUILD_ROOT%{_mandir}/man1
88 install doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
89
90 install -d $RPM_BUILD_ROOT%{_aclocaldir}
91 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/gauche.m4
92
93 %clean
94 rm -rf ${RPM_BUILD_ROOT}
95
96 %post
97 # creates slib catalog, if possible.
98 /usr/bin/gosh -u slib -e "(require 'logical)" -e "(exit 0)" > /dev/null 2>&1 || :
99 /sbin/ldconfig
100
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc COPYING ChangeLog
106 %attr(755,root,root) %{_bindir}/gosh
107 %attr(755,root,root) %{_bindir}/gauche-config
108 %attr(755,root,root) %{_libdir}/libgauche.so
109 %attr(755,root,root) %{_libdir}/gauche/%{version}/*/*
110 %exclude %attr(755,root,root) %{_libdir}/gauche/%{version}/*/[nog]dbm.so
111 %dir %{_libdir}/gauche/site/%{version}/*
112 %{_datadir}/gauche/%{version}/lib
113 %exclude %{_datadir}/gauche/%{version}/lib/dbm*
114 %dir %{_datadir}/gauche/site/lib
115 %{_includedir}/gauche
116 %{_includedir}/gauche.h
117 %{_mandir}/man1/*
118 %{_aclocaldir}/*.m4
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libgauche.a
123
124 %files dbm
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/gauche/%{version}/*/[nog]dbm.so
127 %{_datadir}/gauche/%{version}/lib/dbm
128 %{_datadir}/gauche/%{version}/lib/dbm.scm
This page took 0.160167 seconds and 3 git commands to generate.