]> git.pld-linux.org Git - packages/GUIlib.git/blob - GUIlib.spec
- converted to UTF-8
[packages/GUIlib.git] / GUIlib.spec
1 Summary:        Simple GUI framework for use with SDL
2 Summary(pl.UTF-8):   Prosty szkielet GUI do używania z SDL
3 Name:           GUIlib
4 Version:        1.1.2
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://www.libsdl.org/projects/GUIlib/src/%{name}-%{version}.tar.gz
9 # Source0-md5:  831d03b8e5bd3898b368d78e65c2ec2e
10 Patch0:         %{name}-gcc4.patch
11 URL:            http://www.libsdl.org/projects/GUIlib/
12 BuildRequires:  SDL-devel >= 1.0.1
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.4d
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is a very simple GUI framework, for use with SDL. It is very
21 flexible, but is by no means a complete windowing system. It contains
22 a C++ GUI class with a very rudimentary C interface, and a set of
23 useful widget classes.
24
25 %description -l pl.UTF-8
26 To jest bardzo prosty szkielet GUI (graficznego interfejsu
27 użytkownika) do używania z SDL. Jest bardzo elastyczny, ale w żaden
28 sposób nie jest pełnym systemem okienkowym. Zawiera klasę GUI w C++
29 z bardzo podstawowym interfejsem w C oraz zestaw przydatnych klas
30 widgetów.
31
32 %package devel
33 Summary:        GUIlib header files
34 Summary(pl.UTF-8):   Pliki nagłówkowe GUIlib
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       SDL-devel >= 1.0.1
38 Requires:       libstdc++-devel
39
40 %description devel
41 GUIlib header files.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe GUIlib.
45
46 %package static
47 Summary:        GUIlib static library
48 Summary(pl.UTF-8):   Statyczna biblioteka GUIlib
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 GUIlib static library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka GUIlib.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 rm -f acinclude.m4
63
64 %build
65 %{__libtoolize}
66 %{__aclocal}
67 %{__autoconf}
68 %{__automake}
69 %configure
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79 install hello.cpp hello_C.c *.bmp keyboard.cpp okay.c \
80         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc CHANGES README
91 %attr(755,root,root) %{_libdir}/libGUI-*.so.*.*.*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libGUI.so
96 %{_libdir}/libGUI.la
97 %{_includedir}/GUI
98 %{_examplesdir}/%{name}-%{version}
99
100 %files static
101 %defattr(644,root,root,755)
102 %{_libdir}/libGUI.a
This page took 0.298812 seconds and 3 git commands to generate.