]> git.pld-linux.org Git - packages/GLM.git/blob - GLM.spec
11ce11c6b9ade7641f1cdc20a36493e85477e0d1
[packages/GLM.git] / GLM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 %bcond_with     p7zip           # plain p7zip (compatible with both rpm4/rpm5)
5 #
6 Summary:        OpenGL Mathematics (GLM) - C++ mathematics library for GLSL
7 Summary(pl.UTF-8):      OpenGL Mathematics (GLM) - biblioteka matematyczna C++ dla GLSL
8 Name:           GLM
9 Version:        0.9.9.8
10 Release:        1
11 License:        MIT
12 Group:          Development/Libraries
13 #Source0Download: https://github.com/g-truc/glm/releases
14 Source0:        https://github.com/g-truc/glm/releases/download/%{version}/glm-%{version}.7z
15 # Source0-md5:  c8342552801ebeb31497288192c4e793
16 Patch0:         x32.patch
17 URL:            https://glm.g-truc.net/
18 BuildRequires:  cmake >= 3.2
19 %if %{with p7zip}
20 BuildRequires:  p7zip
21 %else
22 BuildRequires:  p7zip-standalone
23 BuildRequires:  rpm-build >= 5
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 OpenGL Mathematics (GLM) is a C++ mathematics library for graphics
29 software based on the OpenGL Shading Language (GLSL) specification.
30
31 GLM is a header only library, there is nothing to build, just include
32 it.
33
34 %description -l pl.UTF-8
35 OpenGL Mathematics (GLM) to biblioteka matematyczna C++ dla programów
36 graficznych opartych na specyfikacji OpenGL Shading Language (GLSL).
37
38 %prep
39 %if %{with p7zip}
40 %setup -q -c -T -n glm
41 7z x %{SOURCE0} -o..
42 %else
43 %setup -q -n glm
44 %endif
45 %patch0 -p1
46
47 %build
48 mkdir build
49 cd build
50 %cmake .. \
51         -DGLM_TEST_ENABLE:BOOL=%{!?with_tests:OFF}%{?with_tests:ON}
52
53 %if %{with tests}
54 %{__make}
55 %{__make} test
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_includedir}
61
62 cp -a glm $RPM_BUILD_ROOT%{_includedir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc manual.md readme.md
70 %{_includedir}/glm
This page took 0.107349 seconds and 3 git commands to generate.