]> git.pld-linux.org Git - packages/GConf2.git/blob - GConf2.spec
- R: automake for -devel
[packages/GConf2.git] / GConf2.spec
1 #
2 # TODO:
3 # - install evoldap.scheme ?
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNOME2 configuration database system
9 Summary(pl):    System konfiguracyjnej bazy danych dla GNOME 2
10 Summary(pt_BR): Sistema de Configuração do GNOME 2
11 Summary(ru):    óÉÓÔÅÍÁ ËÏÎÆÉÇÕÒÁÃÉÉ GNOME 2
12 Name:           GConf2
13 Version:        2.12.1
14 Release:        2
15 License:        LGPL
16 Group:          X11/Applications
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/GConf/2.12/GConf-%{version}.tar.bz2
18 # Source0-md5:  247110de013ed24b17cf4191eb6daec5
19 Source1:        %{name}-merge-tree.xinit
20 Patch0:         %{name}-NO_MAJOR_VERSION.patch
21 Patch1:         %{name}-path.patch
22 URL:            http://www.gnome.org/
23 BuildRequires:  ORBit2-devel >= 1:2.12.3
24 BuildRequires:  autoconf
25 BuildRequires:  automake >= 1:1.7
26 BuildRequires:  gettext-devel
27 BuildRequires:  gtk+2-devel >= 2:2.8.3
28 BuildRequires:  gtk-doc >= 1.4-2
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel >= 1:2.6.21
31 BuildRequires:  perl-base
32 BuildRequires:  pkgconfig
33 BuildRequires:  popt-devel
34 BuildRequires:  rpmbuild(macros) >= 1.197
35 Obsoletes:      libGConf2
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GConf2 is a configuration database system, functionally similar to the
40 Windows registry but lots better. :-) It's being written for the
41 GNOME2 desktop but does not require GNOME2; configure should notice if
42 GNOME2 is not installed and compile the basic GConf2 library anyway.
43
44 %description -l pl
45 GConf2 jest systemem konfiguracyjnej bazy danych, funkcjonalnie
46 podobnej do rejestru Windows, ale o wiele lepszej :-). Jest pisana dla
47 desktopu GNOME2, ale nie wymaga GNOME2; skrypt configure powinien
48 wykryæ brak GNOME2 i skompilowaæ tylko wersjê podstawow± GConf2.
49
50 %description -l pt_BR
51 Gconf2 é o sistema de banco de dados de configuração do GNOME2.
52
53 %package devel
54 Summary:        GConf2 includes, etc
55 Summary(pl):    Pliki nag³ówkowe GConf2
56 Summary(pt_BR): Sistema de Configuração do GNOME2 - arquivos para desenvolvimento
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       ORBit2-devel >= 1:2.12.3
60 Requires:       automake
61 Requires:       gtk-doc-common
62 Requires:       libxml2-devel >= 1:2.6.21
63 Requires:       pkgconfig
64 Obsoletes:      libGConf2-devel
65
66 %description devel
67 GConf2 includes etc.
68
69 %description devel -l pl
70 Pliki nag³ówkowe GConf2.
71
72 %description devel -l pt_BR
73 Sistema de Configuração do GNOME2 - arquivos para desenvolvimento.
74
75 %package static
76 Summary:        GConf2 static libraries
77 Summary(pl):    Biblioteki statyczne GConf2
78 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com gconf2
79 Group:          X11/Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 GConf2 static libraries.
84
85 %description static -l pl
86 Biblioteki statyczne GConf2.
87
88 %description static -l pt_BR
89 Bibliotecas estáticas para desenvolvimento com gconf
90
91 %prep
92 %setup -q -n GConf-%{version}
93 %patch0 -p1
94 %patch1 -p1
95
96 %build
97 rm -f acinclude.m4
98 %{__glib_gettextize}
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoheader}
102 %{__autoconf}
103 %{__automake}
104 %configure \
105         --with-html-dir=%{_gtkdocdir} \
106         %{!?with_static_libs:--disable-static} \
107 %ifarch ppc
108         --disable-gtk-doc
109 %else
110         --enable-gtk-doc
111 %endif
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_sysconfdir}{/gconf/schemas,/X11/xinit/xinitrc.d}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/GConf2-merge-tree
123
124 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
125
126 %find_lang %{name}
127
128 # no *.{la,a} for modules - shut up check-files
129 rm -f $RPM_BUILD_ROOT%{_libdir}/GConf2/lib*.{la,a}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files -f %{name}.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS NEWS README
140 %attr(755,root,root) %{_bindir}/gconf*
141 %attr(755,root,root) %{_libdir}/gconf-sanity-check-2
142 %attr(755,root,root) %{_libdir}/gconfd-2
143 %attr(755,root,root) %{_libdir}/lib*.so.*.*
144 %dir %{_libdir}/GConf2
145 %attr(755,root,root) %{_libdir}/GConf2/lib*.so
146 %{_sysconfdir}/gconf
147 %attr(755,root,root) %{_sysconfdir}/X11/xinit/xinitrc.d/*
148 %{_datadir}/sgml/gconf
149 %{_mandir}/man1/*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %doc ChangeLog TODO
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_libdir}/lib*.la
156 %{_includedir}/gconf2
157 %{_aclocaldir}/*.m4
158 %{_pkgconfigdir}/*.pc
159 %{_gtkdocdir}/gconf
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/lib*.a
165 %endif
This page took 0.652691 seconds and 3 git commands to generate.