]> git.pld-linux.org Git - packages/GConf2.git/blob - GConf2.spec
- 2.12.1
[packages/GConf2.git] / GConf2.spec
1 #
2 # TODO:
3 # - install evoldap.scheme ?
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNOME2 configuration database system
9 Summary(pl):    System konfiguracyjnej bazy danych dla GNOME 2
10 Summary(pt_BR): Sistema de Configuração do GNOME 2
11 Summary(ru):    óÉÓÔÅÍÁ ËÏÎÆÉÇÕÒÁÃÉÉ GNOME 2
12 Name:           GConf2
13 Version:        2.12.1
14 Release:        1
15 License:        LGPL
16 Group:          X11/Applications
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/GConf/2.12/GConf-%{version}.tar.bz2
18 # Source0-md5:  247110de013ed24b17cf4191eb6daec5
19 Patch0:         %{name}-NO_MAJOR_VERSION.patch
20 Patch1:         %{name}-path.patch
21 URL:            http://www.gnome.org/
22 BuildRequires:  ORBit2-devel >= 1:2.12.3
23 BuildRequires:  autoconf
24 BuildRequires:  automake >= 1:1.7
25 BuildRequires:  gettext-devel
26 BuildRequires:  gtk+2-devel >= 2:2.8.3
27 BuildRequires:  gtk-doc >= 1.4-2
28 BuildRequires:  libtool
29 BuildRequires:  libxml2-devel >= 1:2.6.21
30 BuildRequires:  perl-base
31 BuildRequires:  pkgconfig
32 BuildRequires:  popt-devel
33 BuildRequires:  rpmbuild(macros) >= 1.197
34 Obsoletes:      libGConf2
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 GConf2 is a configuration database system, functionally similar to the
39 Windows registry but lots better. :-) It's being written for the
40 GNOME2 desktop but does not require GNOME2; configure should notice if
41 GNOME2 is not installed and compile the basic GConf2 library anyway.
42
43 %description -l pl
44 GConf2 jest systemem konfiguracyjnej bazy danych, funkcjonalnie
45 podobnej do rejestru Windows, ale o wiele lepszej :-). Jest pisana dla
46 desktopu GNOME2, ale nie wymaga GNOME2; skrypt configure powinien
47 wykryæ brak GNOME2 i skompilowaæ tylko wersjê podstawow± GConf2.
48
49 %description -l pt_BR
50 Gconf2 é o sistema de banco de dados de configuração do GNOME2.
51
52 %package devel
53 Summary:        GConf2 includes, etc
54 Summary(pl):    Pliki nag³ówkowe GConf2
55 Summary(pt_BR): Sistema de Configuração do GNOME2 - arquivos para desenvolvimento
56 Group:          X11/Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       ORBit2-devel >= 1:2.12.3
59 Requires:       gtk-doc-common
60 Requires:       libxml2-devel >= 1:2.6.21
61 Obsoletes:      libGConf2-devel
62
63 %description devel
64 GConf2 includes etc.
65
66 %description devel -l pl
67 Pliki nag³ówkowe GConf2.
68
69 %description devel -l pt_BR
70 Sistema de Configuração do GNOME2 - arquivos para desenvolvimento.
71
72 %package static
73 Summary:        GConf2 static libraries
74 Summary(pl):    Biblioteki statyczne GConf2
75 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com gconf2
76 Group:          X11/Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 GConf2 static libraries.
81
82 %description static -l pl
83 Biblioteki statyczne GConf2.
84
85 %description static -l pt_BR
86 Bibliotecas estáticas para desenvolvimento com gconf
87
88 %prep
89 %setup -q -n GConf-%{version}
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 rm -f acinclude.m4
95 %{__glib_gettextize}
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoheader}
99 %{__autoconf}
100 %{__automake}
101 %configure \
102         --with-html-dir=%{_gtkdocdir} \
103         %{!?with_static_libs:--disable-static} \
104 %ifarch ppc
105         --disable-gtk-doc
106 %else
107         --enable-gtk-doc
108 %endif
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
120
121 %find_lang %{name}
122
123 # no *.{la,a} for modules - shut up check-files
124 rm -f $RPM_BUILD_ROOT%{_libdir}/GConf2/lib*.{la,a}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files -f %{name}.lang
133 %defattr(644,root,root,755)
134 %doc AUTHORS NEWS README
135 %attr(755,root,root) %{_bindir}/gconf*
136 %attr(755,root,root) %{_libdir}/gconf-sanity-check-2
137 %attr(755,root,root) %{_libdir}/gconfd-2
138 %attr(755,root,root) %{_libdir}/lib*.so.*.*
139 %dir %{_libdir}/GConf2
140 %attr(755,root,root) %{_libdir}/GConf2/lib*.so
141 %{_sysconfdir}/gconf
142 %{_datadir}/sgml/gconf
143 %{_mandir}/man1/*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %doc ChangeLog TODO
148 %attr(755,root,root) %{_libdir}/lib*.so
149 %{_libdir}/lib*.la
150 %{_includedir}/gconf2
151 %{_aclocaldir}/*.m4
152 %{_pkgconfigdir}/*.pc
153 %{_gtkdocdir}/gconf
154
155 %if %{with static_libs}
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
159 %endif
This page took 0.174092 seconds and 3 git commands to generate.