]> git.pld-linux.org Git - packages/GConf2.git/blob - GConf2.spec
- release 3 for rebuild with new ldap.
[packages/GConf2.git] / GConf2.spec
1 #
2 # TODO:
3 # - install evoldap.scheme ?
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNOME2 configuration database system
9 Summary(pl):    System konfiguracyjnej bazy danych dla GNOME 2
10 Summary(pt_BR): Sistema de Configuração do GNOME 2
11 Summary(ru):    óÉÓÔÅÍÁ ËÏÎÆÉÇÕÒÁÃÉÉ GNOME 2
12 Name:           GConf2
13 Version:        2.12.1
14 Release:        2
15 License:        LGPL
16 Group:          X11/Applications
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/GConf/2.12/GConf-%{version}.tar.bz2
18 # Source0-md5:  247110de013ed24b17cf4191eb6daec5
19 Source1:        %{name}-merge-tree.xinit
20 Patch0:         %{name}-NO_MAJOR_VERSION.patch
21 Patch1:         %{name}-path.patch
22 URL:            http://www.gnome.org/
23 BuildRequires:  ORBit2-devel >= 1:2.12.3
24 BuildRequires:  autoconf
25 BuildRequires:  automake >= 1:1.7
26 BuildRequires:  gettext-devel
27 BuildRequires:  gtk+2-devel >= 2:2.8.3
28 BuildRequires:  gtk-doc >= 1.4-2
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel >= 1:2.6.21
31 BuildRequires:  perl-base
32 BuildRequires:  pkgconfig
33 BuildRequires:  popt-devel
34 BuildRequires:  rpmbuild(macros) >= 1.197
35 Obsoletes:      libGConf2
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GConf2 is a configuration database system, functionally similar to the
40 Windows registry but lots better. :-) It's being written for the
41 GNOME2 desktop but does not require GNOME2; configure should notice if
42 GNOME2 is not installed and compile the basic GConf2 library anyway.
43
44 %description -l pl
45 GConf2 jest systemem konfiguracyjnej bazy danych, funkcjonalnie
46 podobnej do rejestru Windows, ale o wiele lepszej :-). Jest pisana dla
47 desktopu GNOME2, ale nie wymaga GNOME2; skrypt configure powinien
48 wykryæ brak GNOME2 i skompilowaæ tylko wersjê podstawow± GConf2.
49
50 %description -l pt_BR
51 Gconf2 é o sistema de banco de dados de configuração do GNOME2.
52
53 %package devel
54 Summary:        GConf2 includes, etc
55 Summary(pl):    Pliki nag³ówkowe GConf2
56 Summary(pt_BR): Sistema de Configuração do GNOME2 - arquivos para desenvolvimento
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       ORBit2-devel >= 1:2.12.3
60 Requires:       gtk-doc-common
61 Requires:       libxml2-devel >= 1:2.6.21
62 Obsoletes:      libGConf2-devel
63
64 %description devel
65 GConf2 includes etc.
66
67 %description devel -l pl
68 Pliki nag³ówkowe GConf2.
69
70 %description devel -l pt_BR
71 Sistema de Configuração do GNOME2 - arquivos para desenvolvimento.
72
73 %package static
74 Summary:        GConf2 static libraries
75 Summary(pl):    Biblioteki statyczne GConf2
76 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com gconf2
77 Group:          X11/Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 GConf2 static libraries.
82
83 %description static -l pl
84 Biblioteki statyczne GConf2.
85
86 %description static -l pt_BR
87 Bibliotecas estáticas para desenvolvimento com gconf
88
89 %prep
90 %setup -q -n GConf-%{version}
91 %patch0 -p1
92 %patch1 -p1
93
94 %build
95 rm -f acinclude.m4
96 %{__glib_gettextize}
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoheader}
100 %{__autoconf}
101 %{__automake}
102 %configure \
103         --with-html-dir=%{_gtkdocdir} \
104         %{!?with_static_libs:--disable-static} \
105 %ifarch ppc
106         --disable-gtk-doc
107 %else
108         --enable-gtk-doc
109 %endif
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_sysconfdir}{/gconf/schemas,/X11/xinit/xinitrc.d}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/GConf2-merge-tree
121
122 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
123
124 %find_lang %{name}
125
126 # no *.{la,a} for modules - shut up check-files
127 rm -f $RPM_BUILD_ROOT%{_libdir}/GConf2/lib*.{la,a}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS NEWS README
138 %attr(755,root,root) %{_bindir}/gconf*
139 %attr(755,root,root) %{_libdir}/gconf-sanity-check-2
140 %attr(755,root,root) %{_libdir}/gconfd-2
141 %attr(755,root,root) %{_libdir}/lib*.so.*.*
142 %dir %{_libdir}/GConf2
143 %attr(755,root,root) %{_libdir}/GConf2/lib*.so
144 %{_sysconfdir}/gconf
145 %attr(755,root,root) %{_sysconfdir}/X11/xinit/xinitrc.d/*
146 %{_datadir}/sgml/gconf
147 %{_mandir}/man1/*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc ChangeLog TODO
152 %attr(755,root,root) %{_libdir}/lib*.so
153 %{_libdir}/lib*.la
154 %{_includedir}/gconf2
155 %{_aclocaldir}/*.m4
156 %{_pkgconfigdir}/*.pc
157 %{_gtkdocdir}/gconf
158
159 %if %{with static_libs}
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
163 %endif
This page took 0.043175 seconds and 3 git commands to generate.