]> git.pld-linux.org Git - packages/FreeMat.git/blob - FreeMat.spec
feba300e4a663702ff8cf8124c33d9b1b44e151a
[packages/FreeMat.git] / FreeMat.spec
1 # TODO:
2 # - look at MPI support - doesn't work with lam for me :/
3 %define         fversion        %(echo %{version} |tr r -)
4 %define         mversion        %(echo %{version} |cut -f -1 -d r)
5 Summary:        FreeMat - an environment for rapid engineering and scientific processing
6 Summary(pl.UTF-8):      FreeMat - środowisko do szybkiego przetwarzania inżynieryjnego i naukowego
7 Name:           FreeMat
8 Version:        3.5
9 Release:        0.1
10 License:        MIT
11 Group:          Applications/Math
12 Source0:        http://dl.sourceforge.net/freemat/%{name}-%{fversion}.tar.gz
13 # Source0-md5:  4cc41c1f9265a86134fd338076d1a65f
14 Source1:        %{name}.desktop
15 Patch0:         %{name}-qt4.patch
16 URL:            http://freemat.sourceforge.net
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  blas-devel
20 BuildRequires:  gcc-g77
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libpng-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtiff-devel
25 BuildRequires:  ncurses-devel
26 BuildRequires:  QtCore-devel
27 BuildRequires:  QtGui-devel
28 BuildRequires:  QtOpenGL-devel
29 BuildRequires:  QtNetwork-devel
30 BuildRequires:  QtXml-devel
31 BuildRequires:  qt4-build
32 BuildRequires:  zlib-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 FreeMat is a free environment for rapid entineering and scientific
37 prototyping and data processing. It is similar to commercial systems
38 such as MATLAB from Mathworks, and IDL from Research Systems, but is
39 Open Source. FreeMat includes several novel features such as a
40 codeless interface to external C/C++/FORTRAN code,
41 parallel/distributed algorithm development (via MPI), and plotting and
42 visualiation capabilities.
43
44 %description -l pl.UTF-8
45 FreeMat jest darmowym środowiskiem do szybkiego przetwarzania
46 prototypów i danych dla inżynierów i naukowców. Jest podobny do
47 komercyjnych systemów takich jak MATLAB z Mathworks i IDL z Research
48 Group, ale na licencji Open Source. FreeMat cechuje się między innymi
49 bezkodowym interfejsem do zewnętrznego kodu C/C++/FORTRAN,
50 równoległym/rozproszonym algorytmem obliczeń (poprzez MPI), oraz
51 rysowaniem i wyświetlaniem możliwości.
52
53 %prep
54 %setup -q -n %{name}-%{mversion}
55 %patch0 -p1
56
57 %build
58 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
59 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
60 %{__aclocal}
61 %{__autoconf}
62 %{__automake}
63 %configure \
64         --with-ncurses
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{_infodir},%{_desktopdir}}
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT \
74         prefix=$RPM_BUILD_ROOT%{_prefix}
75
76 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/%{name}
84 %{_datadir}/%{name}
85 %{_desktopdir}/%{name}.desktop
This page took 0.077486 seconds and 3 git commands to generate.