]> git.pld-linux.org Git - packages/FreeMat.git/blob - FreeMat.spec
37dbec056682164f2318fd9155fbb920d8499341
[packages/FreeMat.git] / FreeMat.spec
1 # TODO:
2 # - look at MPI support - doesn't work with lam for me :/
3 # - use system libffi
4 %define         fversion        %(echo %{version} |tr r -)
5 %define         mversion        %(echo %{version} |cut -f -1 -d r)
6 Summary:        FreeMat - an environment for rapid engineering and scientific processing
7 Summary(pl):    FreeMat - ¶rodowisko do szybkiego przetwarzania in¿ynieryjnego i naukowego
8 Name:           FreeMat
9 Version:        1.10r1
10 Release:        1
11 License:        MIT
12 Group:          Applications/Math
13 Source0:        http://dl.sourceforge.net/freemat/%{name}-%{fversion}.tar.gz
14 # Source0-md5:  46c02f2c8c882c7d6f968d21c5a62b27
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-system_ffi.patch
17 URL:            http://freemat.sourceforge.net
18 BuildRequires:  XFree86-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  blas-devel
22 BuildRequires:  fltk-devel
23 BuildRequires:  gcc-g77
24 BuildRequires:  libffi-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel
29 BuildRequires:  ncurses-devel
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 FreeMat is a free environment for rapid entineering and scientific
35 prototyping and data processing. It is similar to commercial systems
36 such as MATLAB from Mathworks, and IDL from Research Systems, but is
37 Open Source. FreeMat includes several novel features such as a
38 codeless interface to external C/C++/FORTRAN code,
39 parallel/distributed algorithm development (via MPI), and plotting and
40 visualiation capabilities.
41
42 %description -l pl
43 FreeMat jest darmowym ¶rodowiskiem do szybkiego przetwarzania
44 prototypów i danych dla in¿ynierów i naukowców. Jest podobny do
45 komercyjnych systemów takich jak MATLAB z Mathworks i IDL z Research
46 Group, ale na licencji Open Source. FreeMat cechuje siê miêdzy innymi
47 bezkodowym interfejsem do zewnêtrznego kodu C/C++/FORTRAN,
48 równoleg³ym/rozproszonym algorytmem obliczeñ (poprzez MPI), oraz
49 rysowaniem i wy¶wietlaniem mo¿liwo¶ci.
50
51 %prep
52 %setup -q -n %{name}-%{mversion}
53 %patch0
54
55 %build
56 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
57 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
58 %{__aclocal}
59 %{__autoconf}
60 %{__automake}
61 %configure \
62         --with-ncurses
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_infodir},%{_desktopdir}}
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT \
72         prefix=$RPM_BUILD_ROOT%{_prefix}
73
74 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_bindir}/%{name}
82 %{_datadir}/%{name}
83 %{_desktopdir}/%{name}.desktop
This page took 0.152849 seconds and 2 git commands to generate.