]> git.pld-linux.org Git - packages/FlightGear.git/blobdiff - FlightGear.spec
- quick and dirty repair of linux build with RTI enabled
[packages/FlightGear.git] / FlightGear.spec
index c149ffa9051a8d4e4abe368ff4a6e92dbce1dad9..e7fa5f2730ca359b042f4465033fb7ea42d13ead 100644 (file)
@@ -3,38 +3,43 @@
 #   http://www.flightgear.org/Downloads/aircraft/index.shtml
 
 Summary:       Free Flight Simulator
-Summary(pl):   darmowy symulator lotu
+Summary(pl.UTF-8):     darmowy symulator lotu
 Name:          FlightGear
-Version:       0.9.10
-Release:       1
+Version:       3.2.0
+Release:       2
 License:       GPL
 Group:         X11/Applications/Games
-Source0:       ftp://ftp.flightgear.org/pub/fgfs/Source/%{name}-%{version}.tar.gz
-# Source0-md5: f4b89c9cafc18d56beab77a04f1ebdce
-Source1:       ftp://ftp.flightgear.org/pub/fgfs/Shared/fgfs-base-%{version}.tar.bz2
-# Source1-md5: 0ff82689a1877de95490c429e717d8a2
-Source2:       ftp://ftp.flightgear.org/pub/fgfs/Everything-0.7/Base-Packages/fgfs-docs-0.7.7.tar.gz
-# Source2-md5: 31f35d3e63e522565e8990ead99e7507
-Patch0:                %{name}-libs.patch
+Source0:       ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/flightgear-%{version}.tar.bz2
+# Source0-md5: 0a16920cc22ea070f8bb345e76c55e05
+Source1:       ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Shared/%{name}-data-%{version}.tar.bz2
+# Source1-md5: 24774fae7199bcbc5e23672f4a586884
+#Source2:      ftp://ftp.flightgear.org/pub/fgfs/Everything-0.7/Base-Packages/fgfs-docs-0.7.7.tar.gz
+## Source2-md5:        31f35d3e63e522565e8990ead99e7507
+Patch0:                flightgear-cmake.patch
+Patch1:                OpenSceneGraph-3.3.2.patch
+Patch2:                rtti-fix.patch
 URL:           http://www.flightgear.org/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-devel
-BuildRequires: SimGear-devel >= 0.3.10
-BuildRequires: XFree86-devel
-BuildRequires: autoconf >= 2.52
-BuildRequires: automake
-BuildRequires: glut-devel
+BuildRequires: OpenSceneGraph-devel
+BuildRequires: SimGear-devel = %{version}
+BuildRequires: cmake
+BuildRequires: flite-devel
+BuildRequires: fltk-gl-devel
+BuildRequires: freeglut-devel
+BuildRequires: libgsm-devel
 BuildRequires: libstdc++-devel
-BuildRequires: libxml-devel
-BuildRequires: metakit-devel >= 2.4.3
-BuildRequires: plib-devel >= 1.8.4
+BuildRequires: speex-devel
+BuildRequires: sqlite3-devel
+BuildRequires: plib-devel >= 1.8.5-3
 BuildRequires: zlib-devel
+Requires:      %{name}-data = %{version}
 Requires:      OpenGL
-Requires:      SimGear >= 0.3.10
+Requires:      OpenSceneGraph-plugins
 Requires:      plib >= 1.8.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define _noautoreqdep  libGL.so.1 libGLU.so.1 libGLcore.so.1
+%define                _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
 
 %description
 The Flight Gear project is working to create a sophisticated flight
@@ -42,46 +47,60 @@ simulator framework for the development and pursuit of interesting
 flight simulator ideas. We are developing a solid basic sim that can
 be expanded and improved upon by anyone interested in contributing.
 
-%description -l pl
-Projekt Flight Gear to wyrafinowany symulator lotów pozwalaj±cy
-rozpowszechniaæ idee tego typu symulacji.
+%description -l pl.UTF-8
+Projekt Flight Gear to wyrafinowany symulator lotów pozwalający
+rozpowszechniać idee tego typu symulacji.
+
+%package data
+Summary:       FlightGear base scenery and data files
+License:       GPL v2+
+Group:         Applications/Games
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description data
+This package contains the base scenery for FlightGear and must be
+installed
 
 %prep
-%setup -q -a 1 -a 2
+%setup -q -n flightgear-%{version} -a 1
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
-find %{name} -name 'CVS' -type d | xargs rm -rf
+cat > runfgfs <<'EOF'
+#!/bin/sh
+exec %{_bindir}/fgfs --fg-root=%{_datadir}/games/%{name}/fgdata "$@"
+EOF
 
 %build
-rm -f missing
-%{__aclocal}
-%{__autoconf}
-%{__automake}
-%configure \
-       --with-network-olk \
-       --with-multiplayer \
-       --libdir=%{_datadir}/games
+install -d build
+cd build
+%cmake .. \
+       -DSYSTEM_SQLITE:BOOL=ON
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_datadir}/games
+install -d $RPM_BUILD_ROOT%{_datadir}/games/%{name}
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-echo "#!/bin/sh" > runfgfs
-echo "exec %{_bindir}/fgfs --fg-root=%{_datadir}/games/%{name} \$*" >> runfgfs
-install runfgfs $RPM_BUILD_ROOT%{_bindir}
-cp -a %{name} $RPM_BUILD_ROOT%{_datadir}/games
-cp -R data $RPM_BUILD_ROOT%{_datadir}/games/%{name}
+install -p runfgfs $RPM_BUILD_ROOT%{_bindir}
+cp -a fgdata $RPM_BUILD_ROOT%{_datadir}/games/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS NEWS %{name}/Docs/*
+%doc AUTHORS NEWS docs-mini/*
 %attr(755,root,root) %{_bindir}/*
-%{_datadir}/games/%{name}
 %{_mandir}/*/*
+
+%files data
+%defattr(644,root,root,755)
+%{_datadir}/games/%{name}
This page took 0.091413 seconds and 4 git commands to generate.