]> git.pld-linux.org Git - packages/Firebird.git/commitdiff
- updated to 3.0.10.33601 auto/th/Firebird-3.0.10.33601-1
authorBartek Szady <bszx@bszx.eu>
Fri, 1 Jul 2022 22:04:30 +0000 (00:04 +0200)
committerBartek Szady <bszx@bszx.eu>
Sat, 2 Jul 2022 09:17:18 +0000 (11:17 +0200)
- debuginfo restored

Firebird-FHS.patch
Firebird-opt.patch
Firebird.spec
firebird-classic.service
firebird.service
mod_loader.patch [new file with mode: 0644]
parallel-build.patch

index 7e7a938d58f169c8856eab3adf4ccffc36b2755a..ccbb86f432db45b8bc55ab51467a51a342b3db09 100644 (file)
@@ -1,10 +1,13 @@
---- Firebird-3.0.0.32483-0/src/yvalve/gds.cpp.orig     2016-08-30 21:31:23.418702669 +0200
-+++ Firebird-3.0.0.32483-0/src/yvalve/gds.cpp  2016-08-31 20:24:57.044428320 +0200
-@@ -3785,7 +3785,7 @@
+--- Firebird-3.0.10.33601-0/src/yvalve/gds.cpp.orig    2022-07-01 08:34:37.770832195 +0200
++++ Firebird-3.0.10.33601-0/src/yvalve/gds.cpp 2022-07-01 08:41:44.837560283 +0200
+@@ -3826,10 +3826,7 @@
                if (!fb_utils::readenv(FB_LOCK_ENV, lockPrefix))
                {
- #ifndef WIN_NT
--                      PathUtils::concatPath(lockPrefix, WORKFILE, LOCKDIR);
+ #if !defined(WIN_NT)
+-                      const char* tmp = getTemporaryFolder();
+-                      if (!tmp)
+-                              tmp = WORKFILE;
+-                      PathUtils::concatPath(lockPrefix, tmp, LOCKDIR);
 +                      PathUtils::concatPath(lockPrefix, "/var/lib", LOCKDIR);
  #else
  #ifdef WIN9X_SUPPORT
index 0fceeb5925d617bf357063f3ab0e007ec7a1c90d..2fbc06658c83a780599b59d9276c1fd8ecd5e969 100644 (file)
  WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable -Wno-narrowing
  
  PROD_FLAGS=$(COMMON_FLAGS) $(OPTIMIZE_FLAGS)
---- Firebird-3.0.4.33054-0/builds/posix/prefix.linux_amd64.orig        2018-10-22 15:04:00.969062218 +0200
-+++ Firebird-3.0.4.33054-0/builds/posix/prefix.linux_amd64     2018-10-31 08:03:59.521778075 +0100
+diff -up Firebird-3.0.9.33560-0/builds/posix/prefix.linux_amd64.orig Firebird-3.0.9.33560-0/builds/posix/prefix.linux_amd64
+--- Firebird-3.0.9.33560-0/builds/posix/prefix.linux_amd64.orig        2022-04-25 12:12:11.720212530 +0200
++++ Firebird-3.0.9.33560-0/builds/posix/prefix.linux_amd64     2022-04-25 13:04:31.045965585 +0200
 @@ -18,9 +18,9 @@
  #
  # 2 Oct 2002, Nickolay Samofatov - Major cleanup
+
 -COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DAMD64 -pipe -MMD -fPIC -fmessage-length=0 -fno-delete-null-pointer-checks
 +COMMON_FLAGS=@CFLAGS@ -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DAMD64 -pipe -MMD -fPIC -fmessage-length=0 -fno-delete-null-pointer-checks
  CXXFLAGS=-std=gnu++03
 -OPTIMIZE_FLAGS=-O3 -fno-omit-frame-pointer
 +OPTIMIZE_FLAGS=-fno-omit-frame-pointer
- WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable -Wno-invalid-offsetof -Wno-narrowing -Wno-unused-local-typedefs
+ WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable -Wno-invalid-offsetof -Wno-narrowing -Wno-unused-local-typedefs -Wno-class-memaccess
+
+ PROD_FLAGS=$(COMMON_FLAGS) $(OPTIMIZE_FLAGS)
+diff -up Firebird-3.0.9.33560-0/builds/posix/prefix.linux_arm.orig Firebird-3.0.9.33560-0/builds/posix/prefix.linux_arm
+--- Firebird-3.0.9.33560-0/builds/posix/prefix.linux_arm.orig  2022-04-25 12:12:11.720212530 +0200
++++ Firebird-3.0.9.33560-0/builds/posix/prefix.linux_arm       2022-04-25 13:07:08.771586881 +0200
+@@ -21,9 +21,9 @@
+ #PROD_FLAGS=-O3 -DLINUX -DARM -pipe -p -MMD -fPIC -fsigned-char -fmessage-length=0 -DFB_SEND_FLAGS=MSG_NOSIGNAL
+ #DEV_FLAGS=-ggdb -DLINUX -DARM -pipe -p -MMD -fPIC -Wall -fsigned-char -fmessage-length=0 -Wno-non-virtual-dtor -DFB_SEND_FLAGS=MSG_NOSIGNAL
+
+-COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DARM -pipe -p -MMD -fPIC -fmessage-length=0 -fno-delete-null-pointer-checks -fsigned-char
++COMMON_FLAGS=@CFLAGS@ -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DARM -pipe -p -MMD -fPIC -fmessage-length=0 -fno-delete-null-pointer-checks -fsigned-char
+ CXXFLAGS=-std=gnu++03
+-OPTIMIZE_FLAGS=-O3 -fno-omit-frame-pointer
++OPTIMIZE_FLAGS=-fno-omit-frame-pointer
+ WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable -Wno-invalid-offsetof -Wno-narrowing -Wno-unused-local-typedefs -Wno-non-virtual-dtor
+
+ PROD_FLAGS=$(COMMON_FLAGS) $(OPTIMIZE_FLAGS)
+diff -up Firebird-3.0.9.33560-0/builds/posix/prefix.linux_arm64.orig Firebird-3.0.9.33560-0/builds/posix/prefix.linux_arm64
+--- Firebird-3.0.9.33560-0/builds/posix/prefix.linux_arm64.orig        2022-04-25 12:12:11.720212530 +0200
++++ Firebird-3.0.9.33560-0/builds/posix/prefix.linux_arm64     2022-04-25 13:07:58.594590193 +0200
+@@ -21,9 +21,9 @@
+ #PROD_FLAGS=-O3 -DLINUX -DARM64 -pipe -p -MMD -fPIC -fsigned-char -fmessage-length=0 -DFB_SEND_FLAGS=MSG_NOSIGNAL
+ #DEV_FLAGS=-ggdb -DLINUX -DARM64 -pipe -p -MMD -fPIC -Wall -fsigned-char -fmessage-length=0 -Wno-non-virtual-dtor -DFB_SEND_FLAGS=MSG_NO
+
+-COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DARM64 -pipe -p -MMD -fPIC -fmessage-length=0 -fno-delete-null-pointer-checks -fsigned-char
++COMMON_FLAGS=@CFLAGS@ -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DARM64 -pipe -p -MMD -fPIC -fmessage-length=0 -fno-delete-null-pointer-checks -fsigned-char
+ CXXFLAGS=-std=gnu++03
+-OPTIMIZE_FLAGS=-O3 -fno-omit-frame-pointer
++OPTIMIZE_FLAGS=-fno-omit-frame-pointer
+ WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable -Wno-invalid-offsetof -Wno-narrowing -Wno-unused-local-typedefs -Wno-non-virtual-dtor
+
  PROD_FLAGS=$(COMMON_FLAGS) $(OPTIMIZE_FLAGS)
---- Firebird-3.0.4.33054-0/builds/posix/prefix.linux_arm.orig  2018-10-22 15:04:00.969062218 +0200
-+++ Firebird-3.0.4.33054-0/builds/posix/prefix.linux_arm       2018-10-31 08:15:50.260068447 +0100
-@@ -20,8 +20,9 @@
- #LD=@CXX@
--#PROD_FLAGS=-ggdb -O3 -fno-omit-frame-pointer -DLINUX -pipe -MMD -fPIC
--#DEV_FLAGS=-ggdb -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -p -fPIC -Wall -Wno-switch
--PROD_FLAGS=-O3 -DLINUX -DARM -pipe -p -MMD -fPIC -fsigned-char -fmessage-length=0 -DFB_SEND_FLAGS=MSG_NOSIGNAL
--DEV_FLAGS=-ggdb -DLINUX -DARM -pipe -p -MMD -fPIC -Wall -fsigned-char -fmessage-length=0 -Wno-non-virtual-dtor -DFB_SEND_FLAGS=MSG_NOSIGNAL
-+COMMON_FLAGS=@CFLAGS@ -DLINUX -DARM -pipe -p -MMD -fPIC -fsigned-char -fmessage-length=0 -DFB_SEND_FLAGS=MSG_NOSIGNAL
-+OPTIMIZE_FLAGS=
-+
-+PROD_FLAGS=$(COMMON_FLAGS) $(OPTIMIZE_FLAGS)
-+DEV_FLAGS=$(COMMON_FLAGS) -Wall -Wno-non-virtual-dtor
---- Firebird-3.0.4.33054-0/builds/posix/prefix.linux_arm64.orig        2018-10-22 15:04:00.969062218 +0200
-+++ Firebird-3.0.4.33054-0/builds/posix/prefix.linux_arm64     2018-10-31 07:58:52.167509266 +0100
-@@ -20,8 +20,8 @@
- #LD=@CXX@
--#PROD_FLAGS=-ggdb -O3 -fno-omit-frame-pointer -DLINUX -pipe -MMD -fPIC
--#DEV_FLAGS=-ggdb -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -p -fPIC -Wall -Wno-switch
-+COMMON_FLAGS=@CFLAGS@ -DLINUX -DARM64 -pipe -MMD -fPIC -fsigned-char -fmessage-length=0 -DFB_SEND_FLAGS=MSG_NOSIGNAL
-+OPTIMIZE_FLAGS=
--PROD_FLAGS=-O3 -DLINUX -DARM64 -pipe -p -MMD -fPIC -fsigned-char -fmessage-length=0 -DFB_SEND_FLAGS=MSG_NOSIGNAL
--DEV_FLAGS=-ggdb -DLINUX -DARM64 -pipe -p -MMD -fPIC -Wall -fsigned-char -fmessage-length=0 -Wno-non-virtual-dtor -DFB_SEND_FLAGS=MSG_NOSIGNAL
-+PROD_FLAGS=$(COMMON_FLAGS) $(OPTIMIZE_FLAGS)
-+DEV_FLAGS=$(COMMON_FLAGS) -Wall -Wno-non-virtual-dtor
 --- Firebird-3.0.4.33054-0/builds/posix/prefix.linux_generic.orig      2018-10-22 15:04:00.969062218 +0200
 +++ Firebird-3.0.4.33054-0/builds/posix/prefix.linux_generic   2018-10-31 08:25:12.372864962 +0100
 @@ -18,8 +18,9 @@
index f90dcde7add51a7692da1ac135462b419b0cd513..511912fc7c1e33d5ba2f31e6cec6ccdb3aad0812 100644 (file)
@@ -15,31 +15,39 @@ Summary:    Firebird SQL Database Server and Client tools
 Summary(de.UTF-8):     Firebird - relationalen Open-Source- Datenbankmanagementsystems
 Summary(pl.UTF-8):     Firebird - serwer baz danych SQL oraz narzÄ™dzia klienckie
 Name:          Firebird
-Version:       3.0.7.33374
-Release:       2
+Version:       3.0.10.33601
+Release:       1
 License:       Interbase Public License 1.0, Initial Developer's Public License 1.0
 Group:         Applications/Databases
-Source0:       https://github.com/FirebirdSQL/firebird/releases/download/R3_0_7/%{name}-%{version}-0.tar.bz2
-# Source0-md5: 84f35c910bb8ba6d9fd985062240c900
+Source0:       https://github.com/FirebirdSQL/firebird/releases/download/v3.0.10/%{name}-%{version}-0.tar.bz2
+# Source0-md5: 849bbc5913276161cc5250d0a9d925d8
 Source1:       http://www.firebirdsql.org/file/documentation/reference_manuals/user_manuals/%{name}-3-QuickStart.pdf
-# Source1-md5: 8e029d449e9cb3e1da8213ac6c11ad02
+# Source1-md5: 1e7032a176e4dc1eca6b1e9babf297c4
 # distfiles refuses this, would require some audit to allow '('/')' chars
 #Source2:      http://www.firebirdsql.org/pdfmanual/Using-Firebird_(wip).pdf
 ## Source2-md5:        9eb90583c200bdd7292a80ecc1df1178
 Source3:       http://www.firebirdsql.org/pdfmanual/%{name}-Null-Guide.pdf
-# Source3-md5: d1f8ba75fe3bb9eb9d203ce3f82a1a1a
+# Source3-md5: dc8e5e234b2138af9a472feca6565359
 Source4:       http://www.firebirdsql.org/pdfmanual/%{name}-Generator-Guide.pdf
-# Source4-md5: 44e7568ef477072a8ad5f381c3e12a75
+# Source4-md5: 23926037205ab8716cf0a54544585231
 Source5:       http://www.firebirdsql.org/pdfmanual/MSSQL-to-%{name}.pdf
 # Source5-md5: 230ef237842d255916398f408f459281
 Source6:       http://www.firebirdsql.org/pdfmanual/%{name}-nbackup.pdf
-# Source6-md5: 7ef8a8b9a899d06bec2a5da0bb5fea0e
-Source7:       http://www.firebirdsql.org/pdfmanual/%{name}-Utils-WIP.pdf
-# Source7-md5: 39b9a4f3c9d9e27d985e9277ae163ceb
+# Source6-md5: 5fd9de7144610ab45bdbb03cfc491adb
+Source7:       http://www.firebirdsql.org/pdfmanual/%{name}-shell-scripts.pdf
+# Source7-md5: 01c5e91de9f1639f62f93b3e486584c8
 Source8:       http://www.firebirdnews.org/docs/fb2min.pdf
-# Source8-md5: ebac312c0afbe97b1850bdc74c553c28
-Source9:       http://www.firebirdsql.org/doc/contrib/fb_2_1_errorcodes.pdf
+# Source8-md5: 5e192abaf5db4417b29ad871716522b5
+Source9:       https://firebirdsql.org/file/documentation/reference_manuals/reference_material/Firebird-2.1-ErrorCodes.pdf
 # Source9-md5: 9ab392dc349657dbcf9a9c35acd8e8db
+Source10:      http://www.firebirdsql.org/pdfmanual/%{name}-gsec.pdf
+# Source10-md5:        326ef6f7afebf369b534838945ee4f74
+Source11:      http://www.firebirdsql.org/pdfmanual/%{name}-gfix.pdf
+# Source11-md5:        22e2cdc1058dd4f764728bcb3a8644f0
+Source12:      http://www.firebirdsql.org/pdfmanual/%{name}-gsplit.pdf
+# Source12-md5:        0147b5d2118e2e80c93762600107a71f
+Source13:      https://firebirdsql.org/file/documentation/pdf/en/refdocs/fblangref30/firebird-30-language-reference.pdf
+# Source13-md5:        20c7cf7d0c102f5b21342fa4472d7938
 Source100:     firebird.init
 Source101:     firebird.sysconfig
 Source102:     firebird.inetd
@@ -64,6 +72,7 @@ Patch10:      no-copy-from-icu.patch
 Patch11:       config.patch
 Patch12:       chown.patch
 Patch13:       cloop-honour-build-flags.patch
+Patch14:       mod_loader.patch
 URL:           http://www.firebirdsql.org/
 BuildRequires: autoconf >= 2.67
 BuildRequires: automake
@@ -87,7 +96,6 @@ Requires:     %{name}-lib = %{version}-%{release}
 ExclusiveArch: %{ix86} %{x8664} x32 arm ia64 mips mipsel ppc sparc sparcv9 alpha
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _debugsource_packages   0
 %define                ibdir   %{_libdir}/interbase
 %define                specflags       -fno-strict-aliasing
 %define                debugcflags     -O1 -g -Wall -fno-strict-aliasing
@@ -201,13 +209,14 @@ Skrypty startowe Firebirda w wersji Classic (inetd).
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
 
 mkdir docs
-cp %{SOURCE1} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} docs
+cp %{SOURCE1} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
+  %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} docs
 
 # not processed by configure
 %{__sed} -i -e 's/^CFLAGS.*$/& %{rpmcflags} %{rpmcppflags}/' extern/btyacc/Makefile
@@ -221,7 +230,6 @@ cp %{SOURCE1} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8}
 %configure \
        CFLAGS="%{rpmcflags} -fno-delete-null-pointer-checks" \
        --prefix=%{ibdir} \
-       --with-system-editline \
        --with-fbconf=%{_sysconfdir}/firebird \
        --with-fbinclude=%{_includedir} \
        --with-fblib=%{_libdir} \
@@ -240,7 +248,7 @@ cp %{SOURCE1} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8}
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} -C src -f ../gen/Makefile.install buildImageDir
+%{__make} -C src -f ../gen/Makefile.install buildRoot
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{firebird{,/conf.d},rc.d/init.d,sysconfig/rc-inetd}
 install -d $RPM_BUILD_ROOT{%{_bindir},%{ibdir},%{_libdir},%{_includedir},%{_pkgconfigdir}} \
index ed2562da2baa6c9a5f87ee787f28cdda58583f2f..6d729fdef72654230b38f68a44a478577b0802c0 100644 (file)
@@ -7,7 +7,6 @@ User=firebird
 Group=firebird
 ExecStart=/usr/lib/interbase/bin/firebird -el /var/lib/firebird
 StandardInput=socket
-StandardError=syslog
 
 [Install]
 Also=firebird-classic.socket
index 340bf8db0bb51e91d067f6f57a810aeda728eafb..2db5fbe3757ba4c28216a6e51084447a21586cbb 100644 (file)
@@ -7,9 +7,7 @@ Conflicts=firebird-classic.socket
 User=firebird
 Group=firebird
 Type=forking
-PIDFile=/run/firebird/default.pid
 ExecStart=/usr/lib/interbase/bin/fbguard -pidfile /run/firebird/default.pid -daemon -forever
-StandardError=syslog
 
 [Install]
 WantedBy=multi-user.target
diff --git a/mod_loader.patch b/mod_loader.patch
new file mode 100644 (file)
index 0000000..f811119
--- /dev/null
@@ -0,0 +1,22 @@
+Loosen a bit a module filename check
+
+diff -up Firebird-3.0.10.33601-0/src/common/os/posix/mod_loader.cpp._orig Firebird-3.0.10.33601-0/src/common/os/posix/mod_loader.cpp
+--- Firebird-3.0.10.33601-0/src/common/os/posix/mod_loader.cpp._orig   2022-06-07 10:18:52.000000000 +0200
++++ Firebird-3.0.10.33601-0/src/common/os/posix/mod_loader.cpp 2022-06-30 14:14:59.963868203 +0200
+@@ -149,7 +149,6 @@ void* DlfcnModule::findSymbol(const Fire
+       if (!dladdr(result, &info))
+               return NULL;
+-      if (PathUtils::isRelative(fileName) || PathUtils::isRelative(info.dli_fname))
+       {
+               // check only name (not path) of the library
+               Firebird::PathName dummyDir, nm1, nm2;
+@@ -158,8 +157,6 @@ void* DlfcnModule::findSymbol(const Fire
+               if (nm1 != nm2)
+                       return NULL;
+       }
+-      else if (fileName != info.dli_fname)
+-              return NULL;
+ #endif
+       return result;
index 30a393f8c8f6bd6a568657db4479038153b40db1..24155ae2f9110903dff0c70e02e12ef444732b60 100644 (file)
@@ -8,10 +8,9 @@ Description: allow building with make -jN
 Author: Damyan Ivanov <dmn@debian.org>
 Forwarded: no
 
-diff -urNp -x '*.orig' Firebird-3.0.7.33374-0.org/builds/posix/Makefile.in Firebird-3.0.7.33374-0/builds/posix/Makefile.in
---- Firebird-3.0.7.33374-0.org/builds/posix/Makefile.in        2022-04-04 17:53:31.957821756 +0000
-+++ Firebird-3.0.7.33374-0/builds/posix/Makefile.in    2022-04-04 17:53:33.598825549 +0000
-@@ -359,8 +359,8 @@ yachts.lnk:                metadata.fdb
+--- Firebird-3.0.10.33601-0/builds/posix/Makefile.in.orig      2022-06-24 13:13:29.537501538 +0200
++++ Firebird-3.0.10.33601-0/builds/posix/Makefile.in   2022-06-24 13:15:39.739885352 +0200
+@@ -364,8 +364,8 @@
  
  metadata.fdb: $(RUN_ISQL) $(SRC_ROOT)/dbs/metadata.sql
        -$(RM) $@
@@ -22,16 +21,16 @@ diff -urNp -x '*.orig' Firebird-3.0.7.33374-0.org/builds/posix/Makefile.in Fireb
        $(CHMOD) 0444 $@
  
  $(HELP_FDB):  help.fdb
-@@ -369,7 +369,7 @@ $(HELP_FDB):       help.fdb
+@@ -374,7 +374,7 @@
        $(CHMOD) 0444 $@
  
  help.fdb:     $(BLD_ROOT)/misc/help.gbak
--      $(RUN_GBAK) -MODE read_only -R $< $@
-+      $(call LOCK_RUN,$(RUN_GBAK) -MODE read_only -R $< $@)
+-      $(RUN_GBAK) -MODE read_only -replace $< $@
++      $(call LOCK_RUN,$(RUN_GBAK) -MODE read_only -replace $< $@)
        $(CHMOD) 0444 $@
  
  $(SECURITY_FDB):      security.fdb
-@@ -379,18 +379,18 @@ $(SECURITY_FDB): security.fdb
+@@ -384,18 +384,18 @@
  security.fdb: $(SRC_ROOT)/dbs/security.sql
        -$(RM) $@
        -$(RM) $(SECURITY_TMP)
@@ -57,7 +56,7 @@ diff -urNp -x '*.orig' Firebird-3.0.7.33374-0.org/builds/posix/Makefile.in Fireb
        $(TOUCH) $@
  
  
-@@ -562,7 +562,7 @@ codes:     gen_codes
+@@ -567,7 +567,7 @@
  ids:  $(IDS)
  
  gen_codes:    $(CODES) msg.timestamp
@@ -65,8 +64,8 @@ diff -urNp -x '*.orig' Firebird-3.0.7.33374-0.org/builds/posix/Makefile.in Fireb
 +      $(call LOCK_RUN,$(CODES) $(SRC_ROOT)/include/gen $(LNG_ROOT))
  
  $(CODES):     $(CODES_Objects) $(COMMON_LIB)
-       $(EXE_LINK) $(EXE_LINK_OPTIONS) $^ -o $@ $(FIREBIRD_LIBRARY_LINK) $(LINK_LIBS) $(call LINK_DARWIN_RPATH,..)
-@@ -598,7 +598,7 @@ examples: include_generic
+       $(EXE_LINK) $(EXE_LINK_OPTIONS) $^ -o $@ $(FIREBIRD_LIBRARY_LINK) $(LINK_LIBS)
+@@ -603,7 +603,7 @@
  message_file: $(FIREBIRD_MSG)
  
  $(FIREBIRD_MSG):      $(BUILD_FILE) msg.timestamp
This page took 0.111209 seconds and 4 git commands to generate.