]> git.pld-linux.org Git - packages/Firebird.git/blob - Firebird.spec
- added gcc33 patch
[packages/Firebird.git] / Firebird.spec
1 Summary:        Firebird SQL Database Server and Client tools
2 Summary(pl):    Firebird - serwer baz danych SQL oraz narzêdzia klienckie
3 Name:           Firebird
4 # FirebirdCS/FirebirdSS (Classic Server/Super Server)?
5 Version:        1.0.2.908
6 Release:        1
7 License:        Interbase Public License 1.0
8 Group:          Applications/Databases
9 Source0:        http://dl.sourceforge.net/firebird/%{name}-%{version}.src.tar.gz
10 # Source0-md5: 8ca9aac6cfe2670659d00bb2decb3456
11 Source1:        http://dl.sourceforge.net/firebird/bootkit-%{version}.tar.gz
12 # Source1-md5: 3ce1d058d568242843fa0f92d5ae7018
13 Source2:        http://www.ibphoenix.com/downloads/60All.zip
14 # Source2-md5:  f86a132012361cd4ae88563105741a4c
15 Source3:        http://www.ibphoenix.com/downloads/ib_4_0_docs.tar.gz
16 # Source3-md5: f4176d5dec952ee774bb8ee74c1f715d
17 Source4:        http://www.ibphoenix.com/downloads/isc_docs.zip
18 # Source4-md5:  66eef71c188215d10988788282c014a7
19 # dirty "fixes" for missing error contants and conflict with isql from unixODBC
20 # (gds__bad_{limit,skip}_param are defined in supplied codes.h, but removed
21 #  by codes.h regeneration from messages.gbak(?))
22 Patch0:         %{name}-fix.patch
23 Patch1:         %{name}-gcc33.patch
24 URL:            http://firebird.sourceforge.net/
25 BuildRequires:  unzip
26 Requires:       %{name}-lib = %{version}
27 # see firebird-*/jrd/{common.h,gds.h,ibase.h} if you want to add support for more
28 ExclusiveArch:  %{ix86}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         ibdir   %{_libdir}/interbase
32
33 %description
34 Firebird is a powerful, high-performance relational database designed
35 to be embedded into applications on multiple platforms.
36
37 %description -l pl
38 Firebird jest potê¿nym, wysoko wydajnym systemem relacyjnych baz
39 danych zaprojektowanym do osadzania w aplikacjach na wielu
40 platformach.
41
42 %package lib
43 Summary:        Firebird shared library
44 Summary(pl):    Biblioteka wspó³dzielona Firebird
45 Group:          Libraries
46
47 %description lib
48 Firebird shared library (libgds).
49
50 %description lib -l pl
51 Biblioteka wspó³dzielona Firebird (libgds).
52
53 %package devel
54 Summary:        Header files for Firebird library
55 Summary(pl):    Pliki nag³ówkowe biblioteki Firebird
56 Group:          Development/Libraries
57 Requires:       %{name}-lib = %{version}
58
59 %description devel
60 Header files for Firebird library.
61
62 %description devel -l pl
63 Pliki nag³ówkowe biblioteki Firebird.
64
65 %package static
66 Summary:        Static Firebird library
67 Summary(pl):    Statyczna biblioteka Firebird
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}
70
71 %description static
72 Static Firebird library (libgds).
73
74 %description static -l pl
75 Statyczna biblioteka Firebird (libgds).
76
77 %package doc
78 Summary:        Extensive InterBase and Firebird documentation
79 Summary(pl):    Obszerna dokumentacja do baz InterBase i Firebird
80 Group:          Documentation
81
82 %description doc
83 Extensive InterBase and Firebird documentation.
84
85 %description doc -l pl
86 Obszerna dokumentacja do baz InterBase i Firebird.
87
88 %prep
89 %setup -q -n firebird-%{version} -a1
90 %patch0 -p1
91 %patch1 -p1
92
93 install -d docs/{IB3.0,IB4.0,IB6.0}
94 unzip -q %{SOURCE2} -d docs/IB6.0
95 tar xzf %{SOURCE3} -C docs/IB4.0
96 unzip -q %{SOURCE4} -d docs/IB3.0
97 # standardize extension, also avoids gzipping by compress-doc
98 mv -f docs/IB6.0/LANGREF.{PDF,pdf}
99
100 %build
101 INTERBASE=/usr/lib/interbase; export INTERBASE
102 echo 'y' | ./Configure.sh PROD
103 . ./Configure_SetupEnv.sh
104
105 %{__make} firebird \
106         CC="%{__cc}" \
107         PROD_CFLAGS="%{rpmcflags} -fpic -DFLINTSTONE"
108
109 # classic/super - what's the difference?
110 #%%{__make} super_firebird
111
112 #-Isource/interbase/include"
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 INTERBASE=/usr/lib/interbase; export INTERBASE
117 . ./Configure_SetupEnv.sh
118
119 %{__make} buildclassicimage -f firebird/install/linux/Makefile
120
121 install -d $RPM_BUILD_ROOT{%{ibdir},%{_libdir},%{_includedir}} \
122         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
123 cd buildroot/opt/interbase
124 rm -f bin/isc4.gbak
125 cp -af UDF bin help intl interbase.msg isc4.gdb isc_config \
126         $RPM_BUILD_ROOT%{ibdir}
127 install include/* $RPM_BUILD_ROOT%{_includedir}
128 install lib/* $RPM_BUILD_ROOT%{_libdir}
129 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc builds_win32/install/{*License,Readme}.txt
137 %attr(755,root,root) %{_libdir}/libib_util.so
138 %dir %{ibdir}
139 %attr(755,root,root) %{ibdir}/UDF
140 %attr(755,root,root) %{ibdir}/bin
141 %{ibdir}/help
142 %{ibdir}/intl
143 %{ibdir}/interbase.msg
144 # following two files should be in /var and /etc resp.?
145 %{ibdir}/isc4.gdb
146 %{ibdir}/isc_config
147
148 %files lib
149 %defattr(644,root,root,755)
150 # .so link needed here - library doesn't have SONAME
151 %attr(755,root,root) %{_libdir}/libgds.so*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %{_includedir}/*
156 %{_examplesdir}/%{name}-%{version}
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libgds.a
161
162 %files doc
163 %defattr(644,root,root,755)
164 %doc docs/*
This page took 0.043078 seconds and 4 git commands to generate.