]> git.pld-linux.org Git - packages/FileZilla.git/blobdiff - FileZilla.spec
- up to 3.67.0
[packages/FileZilla.git] / FileZilla.spec
index d5ae38fb679042bdfa5bcef21aa106c13fa7e5a1..15547939e0dd168ffb661017fd8eaa83d18d32cc 100644 (file)
@@ -1,7 +1,6 @@
-# TODO
-# - /usr/share/locale/ca_ES@valencia is needed by FileZilla-3.0.5.2-1.i686
-#   (there is probably ca_ES@valencia locale in Debian glibc - merge it)
-#   Temporary removed locale...
+%bcond_with    storj   # support for Storj decentralized cloud storage provider
+
+%define                libfilezilla_ver        0.47.0
 Summary:       FTP client for X Window
 Summary(es.UTF-8):     Cliente FTP para el X Window
 Summary(ja.UTF-8):     X Window System 用マルチスレッド FTP クライアント
@@ -10,35 +9,43 @@ Summary(pt_BR.UTF-8):        Cliente FTP para o X Window
 Summary(ru.UTF-8):     FTP клиент для X Window
 Summary(uk.UTF-8):     FTP клієнт для X Window
 Name:          FileZilla
-Version:       3.23.0.2
-Release:       2
-License:       GPL
+Version:       3.67.0
+Release:       1
+License:       GPL v2+
 Group:         X11/Applications/Networking
-Source0:       http://downloads.sourceforge.net/filezilla/%{name}_%{version}_src.tar.bz2
-# Source0-md5: 5f52629d11a16ed2d547a4b200d3448c
+Source0:       https://download.filezilla-project.org/client/%{name}_%{version}_src.tar.xz
+# Source0-md5: ddcf03519e2e55ada0bb77c2a6a73fba
 Patch0:                %{name}-desktop.patch
-URL:           http://filezilla-project.org/
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: cppunit-devel
-BuildRequires: dbus-devel
-BuildRequires: gettext-tools
-BuildRequires: gnutls-devel >= 3.4.0
-BuildRequires: gtk+2-devel
-BuildRequires: libfilezilla-devel >= 0.9.0
+Patch1:                disable-avx-on-i686.patch
+URL:           https://filezilla-project.org/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake >= 1.6
+BuildRequires: boost-devel >= 1.76
+BuildRequires: cppunit-devel >= 1.13.0
+BuildRequires: dbus-devel >= 1.2
+BuildRequires: gettext-tools >= 0.11.0
+BuildRequires: gtk+3-devel
+BuildRequires: libfilezilla-devel >= %{libfilezilla_ver}
 BuildRequires: libidn-devel
-BuildRequires: libtool >= 2:1.5
+# -std=c++17
+BuildRequires: libstdc++-devel >= 6:7
+BuildRequires: libtool >= 2:2
 BuildRequires: nettle-devel >= 3.1
 BuildRequires: pkgconfig
-BuildRequires: pugixml-devel >= 1.6-2
-BuildRequires: systemd-devel
-BuildRequires: wxGTK2-unicode-devel >= 3.0.1
-BuildRequires: wxWidgets-devel >= 3.0.1
-BuildRequires: wxWidgets-utils >= 3.0.1
+BuildRequires: pugixml-devel >= 1.9
+BuildRequires: sqlite3-devel >= 3.7
+%{?with_storj:BuildRequires:   storj-uplink-c-devel}
+BuildRequires: wxGTK3-unicode-devel >= 3.0.4
+BuildRequires: wxWidgets-devel >= 3.0.4
+BuildRequires: wxWidgets-utils >= 3.0.4
 BuildRequires: xdg-utils
-Requires:      wxWidgets >= 3.0.1
+Requires:      dbus-libs >= 1.2
+Requires:      libfilezilla >= %{libfilezilla_ver}
+Requires:      nettle >= 3.1
+Requires:      pugixml >= 1.9
+Requires:      wxGTK3-unicode >= 3.0.4
 Provides:      filezilla
-Obsoletes:     filezilla
+Obsoletes:     filezilla < 3.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -52,12 +59,12 @@ opcjami oraz intuicyjnym interfejsem.
 %prep
 %setup -q -n filezilla-%{version}
 %patch0 -p1
+%patch1 -p1
 
 cd locales
 %{__mv} bg{_BG,}.po
+%{__mv} ca{_ES,}@valencia.po
 %{__mv} cs{_CZ,}.po
-#%{__mv} da{_DK,}.po
-#%{__mv} et{_EE,}.po
 %{__mv} fa{_IR,}.po
 %{__mv} fi{_FI,}.po
 %{__mv} gl{_ES,}.po
@@ -67,6 +74,7 @@ cd locales
 %{__mv} ja{_JP,}.po
 %{__mv} km{_KH,}.po
 %{__mv} ko{_KR,}.po
+%{__mv} lo{_LA,}.po
 %{__mv} lt{_LT,}.po
 %{__mv} lv{_LV,}.po
 %{__mv} mk{_MK,}.po
@@ -80,8 +88,6 @@ cd locales
 %{__mv} th{_TH,}.po
 %{__mv} uk{_UA,}.po
 %{__mv} vi{_VN,}.po
-# Temporary - FIXME:
-%{__rm} ca@valencia.po
 
 %build
 %{__libtoolize}
@@ -90,7 +96,10 @@ cd locales
 %{__autoheader}
 %{__automake}
 %configure \
-       --with-wx-config=wx-gtk2-unicode-config \
+       xdgopen=/usr/bin/xdg-open \
+       --disable-precomp \
+       --with-wx-config=wx-gtk3-unicode-config \
+       %{?with_storj:--enable-storj} \
        --with-tinyxml=builtin
 %{__make}
 
@@ -100,8 +109,12 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# Temporary - FIXME:
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ca_ES@valencia,co,kab,lo_LA}
+# API not exported
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfzclient-private.{la,so}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfzclient-commonui-private.{la,so}
+
+# not supported by glibc (as of 2.32)
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
 
 # Remove oversized icons
 %{__rm} -r $RPM_BUILD_ROOT%{_iconsdir}/hicolor/480x480
@@ -111,22 +124,27 @@ rm -rf $RPM_BUILD_ROOT
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files -f filezilla.lang
 %defattr(644,root,root,755)
-%doc AUTHORS NEWS README
+%doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/filezilla
-%attr(755,root,root) %{_bindir}/fzsftp
 %attr(755,root,root) %{_bindir}/fzputtygen
+%attr(755,root,root) %{_bindir}/fzsftp
+%if %{with storj}
+%attr(755,root,root) %{_bindir}/fzstorj
+%endif
+%attr(755,root,root) %{_libdir}/libfzclient-commonui-private-%{version}.so
+%attr(755,root,root) %{_libdir}/libfzclient-private-%{version}.so
 %{_datadir}/appdata/filezilla.appdata.xml
 %dir %{_datadir}/filezilla
 %dir %{_datadir}/filezilla/docs
 %{_datadir}/filezilla/docs/*
 %dir %{_datadir}/filezilla/resources
-%{_datadir}/filezilla/resources/*.png
 %{_datadir}/filezilla/resources/*.wav
 %{_datadir}/filezilla/resources/*.xml
-%dir %{_datadir}/filezilla/resources/xrc
-%{_datadir}/filezilla/resources/xrc/*.xrc
 %dir %{_datadir}/filezilla/resources/16x16
 %{_datadir}/filezilla/resources/16x16/*.gif
 %{_datadir}/filezilla/resources/16x16/*.png
@@ -208,8 +226,11 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/filezilla/resources/default/480x480
 %{_datadir}/filezilla/resources/default/480x480/*.png
 %{_datadir}/filezilla/resources/default/theme.xml
-%{_iconsdir}/hicolor/*/apps/filezilla.png
-%{_desktopdir}/*.desktop
-%{_pixmapsdir}/*.png
-%{_mandir}/man1/*.1*
-%{_mandir}/man5/*.5*
+%{_iconsdir}/hicolor/*x*/apps/filezilla.png
+%{_iconsdir}/hicolor/scalable/apps/filezilla.svg
+%{_desktopdir}/filezilla.desktop
+%{_pixmapsdir}/filezilla.png
+%{_mandir}/man1/filezilla.1*
+%{_mandir}/man1/fzputtygen.1*
+%{_mandir}/man1/fzsftp.1*
+%{_mandir}/man5/fzdefaults.xml.5*
This page took 0.035192 seconds and 4 git commands to generate.