]> git.pld-linux.org Git - packages/FileZilla.git/blame - FileZilla.spec
- up to 3.63.1
[packages/FileZilla.git] / FileZilla.spec
CommitLineData
2db1d6ff
JB
1%bcond_with storj # support for Storj decentralized cloud storage provider
2
cc3b045e 3%define libfilezilla_ver 0.41.0
8c15d1b4
PG
4Summary: FTP client for X Window
5Summary(es.UTF-8): Cliente FTP para el X Window
6Summary(ja.UTF-8): X Window System 用マルチスレッド FTP クライアント
7Summary(pl.UTF-8): Klient FTP dla X Window
8Summary(pt_BR.UTF-8): Cliente FTP para o X Window
9Summary(ru.UTF-8): FTP клиент для X Window
10Summary(uk.UTF-8): FTP клієнт для X Window
11Name: FileZilla
cc3b045e 12Version: 3.63.1
e5ae0513 13Release: 1
a8a8fc30 14License: GPL v2+
8c15d1b4 15Group: X11/Applications/Networking
581f74e5 16Source0: https://download.filezilla-project.org/client/%{name}_%{version}_src.tar.bz2
cc3b045e 17# Source0-md5: eeac92ca2b1972e6f666254dc51a1452
73f60021 18Patch0: %{name}-desktop.patch
094a2115 19Patch1: disable-avx-on-i686.patch
0b4099f1 20URL: https://filezilla-project.org/
0d2392f9
JB
21BuildRequires: autoconf >= 2.50
22BuildRequires: automake >= 1.6
1c4da0aa 23BuildRequires: cppunit-devel >= 1.13.0
0d2392f9
JB
24BuildRequires: dbus-devel >= 1.2
25BuildRequires: gettext-tools >= 0.11.0
378a2a24 26BuildRequires: gtk+3-devel
9ae3d50e 27BuildRequires: libfilezilla-devel >= %{libfilezilla_ver}
43109387 28BuildRequires: libidn-devel
a8a8fc30
JB
29# -std=c++17
30BuildRequires: libstdc++-devel >= 6:7
0d2392f9 31BuildRequires: libtool >= 2:2
7b8cc717 32BuildRequires: nettle-devel >= 3.1
43109387 33BuildRequires: pkgconfig
378a2a24 34BuildRequires: pugixml-devel >= 1.9
0d2392f9 35BuildRequires: sqlite3-devel >= 3.7
9ae3d50e 36%{?with_storj:BuildRequires: storj-uplink-c-devel}
378a2a24 37BuildRequires: wxGTK3-unicode-devel >= 3.0.4
1c4da0aa
AG
38BuildRequires: wxWidgets-devel >= 3.0.4
39BuildRequires: wxWidgets-utils >= 3.0.4
4a0af371 40BuildRequires: xdg-utils
0d2392f9 41Requires: dbus-libs >= 1.2
9ae3d50e 42Requires: libfilezilla >= %{libfilezilla_ver}
0d2392f9 43Requires: nettle >= 3.1
378a2a24
KM
44Requires: pugixml >= 1.9
45Requires: wxGTK3-unicode >= 3.0.4
0ae50dd3 46Provides: filezilla
d26a5ccb 47Obsoletes: filezilla < 3.1
8c15d1b4
PG
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
73f60021
PG
51FileZilla is a fast and reliable FTP client with lots of useful
52features and an intuitive interface.
53
54%description -l pl.UTF-8
55FileZilla to szybki i wiarygodny klient FTP z wieloma przydatnymi
56opcjami oraz intuicyjnym interfejsem.
8c15d1b4
PG
57
58%prep
3872d915 59%setup -q -n filezilla-%{version}
73f60021 60%patch0 -p1
094a2115 61%patch1 -p1
fe7d5f4d 62
73f60021 63cd locales
8d1f840a 64%{__mv} bg{_BG,}.po
0d2392f9 65%{__mv} ca{_ES,}@valencia.po
8d1f840a 66%{__mv} cs{_CZ,}.po
8d1f840a
JR
67%{__mv} fa{_IR,}.po
68%{__mv} fi{_FI,}.po
69%{__mv} gl{_ES,}.po
70%{__mv} he{_IL,}.po
71%{__mv} hu{_HU,}.po
72%{__mv} id{_ID,}.po
73%{__mv} ja{_JP,}.po
74%{__mv} km{_KH,}.po
75%{__mv} ko{_KR,}.po
0d2392f9 76%{__mv} lo{_LA,}.po
8d1f840a
JR
77%{__mv} lt{_LT,}.po
78%{__mv} lv{_LV,}.po
79%{__mv} mk{_MK,}.po
80%{__mv} nb{_NO,}.po
81%{__mv} nn{_NO,}.po
82%{__mv} pl{_PL,}.po
83%{__mv} pt{_PT,}.po
84%{__mv} ro{_RO,}.po
85%{__mv} sk{_SK,}.po
86%{__mv} sl{_SI,}.po
87%{__mv} th{_TH,}.po
88%{__mv} uk{_UA,}.po
89%{__mv} vi{_VN,}.po
5b27871b 90
8c15d1b4 91%build
d2e4d3bc 92%{__libtoolize}
4da37731 93%{__aclocal} -I m4
d2e4d3bc
JB
94%{__autoconf}
95%{__autoheader}
96%{__automake}
7b023f3b 97%configure \
0d2392f9 98 xdgopen=/usr/bin/xdg-open \
0eeb1394 99 --disable-precomp \
378a2a24 100 --with-wx-config=wx-gtk3-unicode-config \
2db1d6ff 101 %{?with_storj:--enable-storj} \
4da37731 102 --with-tinyxml=builtin
8c15d1b4
PG
103%{__make}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108%{__make} install \
109 DESTDIR=$RPM_BUILD_ROOT
110
9ae3d50e
JB
111# API not exported
112%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfzclient-private.{la,so}
0da08b8e 113%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfzclient-commonui-private.{la,so}
9ae3d50e
JB
114
115# not supported by glibc (as of 2.32)
116%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
8d1f840a
JR
117
118# Remove oversized icons
119%{__rm} -r $RPM_BUILD_ROOT%{_iconsdir}/hicolor/480x480
4089d4bd 120
73f60021 121%find_lang filezilla
8c15d1b4
PG
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
9ae3d50e
JB
126%post -p /sbin/ldconfig
127%postun -p /sbin/ldconfig
128
73f60021 129%files -f filezilla.lang
8c15d1b4 130%defattr(644,root,root,755)
0d2392f9 131%doc AUTHORS ChangeLog NEWS README
73f60021 132%attr(755,root,root) %{_bindir}/filezilla
4089d4bd 133%attr(755,root,root) %{_bindir}/fzputtygen
2db1d6ff
JB
134%attr(755,root,root) %{_bindir}/fzsftp
135%if %{with storj}
136%attr(755,root,root) %{_bindir}/fzstorj
137%endif
0da08b8e 138%attr(755,root,root) %{_libdir}/libfzclient-commonui-private-%{version}.so
9ae3d50e 139%attr(755,root,root) %{_libdir}/libfzclient-private-%{version}.so
daf29a03 140%{_datadir}/appdata/filezilla.appdata.xml
73f60021
PG
141%dir %{_datadir}/filezilla
142%dir %{_datadir}/filezilla/docs
143%{_datadir}/filezilla/docs/*
144%dir %{_datadir}/filezilla/resources
73f60021
PG
145%{_datadir}/filezilla/resources/*.wav
146%{_datadir}/filezilla/resources/*.xml
8c5f2e30
WF
147%dir %{_datadir}/filezilla/resources/xrc
148%{_datadir}/filezilla/resources/xrc/*.xrc
73f60021 149%dir %{_datadir}/filezilla/resources/16x16
daf29a03 150%{_datadir}/filezilla/resources/16x16/*.gif
73f60021 151%{_datadir}/filezilla/resources/16x16/*.png
daf29a03
WF
152%dir %{_datadir}/filezilla/resources/20x20
153%{_datadir}/filezilla/resources/20x20/*.png
154%dir %{_datadir}/filezilla/resources/24x24
155%{_datadir}/filezilla/resources/24x24/*.png
73f60021
PG
156%dir %{_datadir}/filezilla/resources/32x32
157%{_datadir}/filezilla/resources/32x32/*.png
158%dir %{_datadir}/filezilla/resources/48x48
159%{_datadir}/filezilla/resources/48x48/*.png
160%dir %{_datadir}/filezilla/resources/blukis
4089d4bd 161%{_datadir}/filezilla/resources/blukis/theme.xml
73f60021
PG
162%dir %{_datadir}/filezilla/resources/blukis/16x16
163%{_datadir}/filezilla/resources/blukis/16x16/*.png
164%dir %{_datadir}/filezilla/resources/blukis/32x32
165%{_datadir}/filezilla/resources/blukis/32x32/*.png
166%dir %{_datadir}/filezilla/resources/blukis/48x48
167%{_datadir}/filezilla/resources/blukis/48x48/*.png
168%dir %{_datadir}/filezilla/resources/cyril
4089d4bd 169%{_datadir}/filezilla/resources/cyril/theme.xml
73f60021
PG
170%dir %{_datadir}/filezilla/resources/cyril/16x16
171%{_datadir}/filezilla/resources/cyril/16x16/*.png
daf29a03
WF
172%dir %{_datadir}/filezilla/resources/flatzilla
173%dir %{_datadir}/filezilla/resources/flatzilla/16x16
174%{_datadir}/filezilla/resources/flatzilla/16x16/*.png
175%dir %{_datadir}/filezilla/resources/flatzilla/24x24
176%{_datadir}/filezilla/resources/flatzilla/24x24/*.png
177%dir %{_datadir}/filezilla/resources/flatzilla/32x32
178%{_datadir}/filezilla/resources/flatzilla/32x32/*.png
179%dir %{_datadir}/filezilla/resources/flatzilla/48x48
180%{_datadir}/filezilla/resources/flatzilla/48x48/*.png
181%{_datadir}/filezilla/resources/flatzilla/theme.xml
937a9452 182%dir %{_datadir}/filezilla/resources/lone
183%{_datadir}/filezilla/resources/lone/theme.xml
184%dir %{_datadir}/filezilla/resources/lone/16x16
185%{_datadir}/filezilla/resources/lone/16x16/*.png
186%dir %{_datadir}/filezilla/resources/lone/32x32
187%{_datadir}/filezilla/resources/lone/32x32/*.png
188%dir %{_datadir}/filezilla/resources/lone/48x48
189%{_datadir}/filezilla/resources/lone/48x48/*.png
cc058e20 190%dir %{_datadir}/filezilla/resources/minimal
191%{_datadir}/filezilla/resources/minimal/theme.xml
192%dir %{_datadir}/filezilla/resources/minimal/16x16
193%{_datadir}/filezilla/resources/minimal/16x16/*.png
194%dir %{_datadir}/filezilla/resources/minimal/32x32
195%{_datadir}/filezilla/resources/minimal/32x32/file.png
4c3dec04 196%dir %{_datadir}/filezilla/resources/opencrystal
197%{_datadir}/filezilla/resources/opencrystal/theme.xml
198%dir %{_datadir}/filezilla/resources/opencrystal/16x16
199%{_datadir}/filezilla/resources/opencrystal/16x16/*.png
daf29a03
WF
200%dir %{_datadir}/filezilla/resources/opencrystal/20x20
201%{_datadir}/filezilla/resources/opencrystal/20x20/*.png
202%dir %{_datadir}/filezilla/resources/opencrystal/24x24
203%{_datadir}/filezilla/resources/opencrystal/24x24/*.png
4c3dec04 204%dir %{_datadir}/filezilla/resources/opencrystal/32x32
205%{_datadir}/filezilla/resources/opencrystal/32x32/*.png
206%dir %{_datadir}/filezilla/resources/opencrystal/48x48
207%{_datadir}/filezilla/resources/opencrystal/48x48/*.png
daf29a03
WF
208%dir %{_datadir}/filezilla/resources/sun
209%dir %{_datadir}/filezilla/resources/sun/48x48
210%{_datadir}/filezilla/resources/sun/48x48/*.png
211%{_datadir}/filezilla/resources/sun/theme.xml
212%dir %{_datadir}/filezilla/resources/tango
213%dir %{_datadir}/filezilla/resources/tango/16x16
214%{_datadir}/filezilla/resources/tango/16x16/*.png
215%dir %{_datadir}/filezilla/resources/tango/32x32
216%{_datadir}/filezilla/resources/tango/32x32/*.png
217%dir %{_datadir}/filezilla/resources/tango/48x48
218%{_datadir}/filezilla/resources/tango/48x48/*.png
219%{_datadir}/filezilla/resources/tango/theme.xml
7ff4dadc
WF
220%dir %{_datadir}/filezilla/resources/480x480
221%{_datadir}/filezilla/resources/480x480/*.png
222%dir %{_datadir}/filezilla/resources/classic
223%dir %{_datadir}/filezilla/resources/classic/16x16
224%{_datadir}/filezilla/resources/classic/16x16/*.png
225%{_datadir}/filezilla/resources/classic/theme.xml
226%dir %{_datadir}/filezilla/resources/default
227%dir %{_datadir}/filezilla/resources/default/480x480
228%{_datadir}/filezilla/resources/default/480x480/*.png
229%{_datadir}/filezilla/resources/default/theme.xml
0d2392f9 230%{_iconsdir}/hicolor/*x*/apps/filezilla.png
b4cca2f4 231%{_iconsdir}/hicolor/scalable/apps/filezilla.svg
0d2392f9
JB
232%{_desktopdir}/filezilla.desktop
233%{_pixmapsdir}/filezilla.png
234%{_mandir}/man1/filezilla.1*
235%{_mandir}/man1/fzputtygen.1*
236%{_mandir}/man1/fzsftp.1*
237%{_mandir}/man5/fzdefaults.xml.5*
This page took 0.487247 seconds and 4 git commands to generate.