]> git.pld-linux.org Git - packages/Field3D.git/commitdiff
- new
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 18 Nov 2011 18:28:16 +0000 (18:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Field3D-install.patch -> 1.1
    Field3D.spec -> 1.1

Field3D-install.patch [new file with mode: 0644]
Field3D.spec [new file with mode: 0644]

diff --git a/Field3D-install.patch b/Field3D-install.patch
new file mode 100644 (file)
index 0000000..1092642
--- /dev/null
@@ -0,0 +1,50 @@
+--- imageworks-Field3D-7b8b5d9/CMakeLists.txt.orig     2010-11-12 18:35:52.000000000 +0100
++++ imageworks-Field3D-7b8b5d9/CMakeLists.txt  2011-11-18 17:01:54.869318971 +0100
+@@ -147,40 +147,17 @@
+   DESTINATION lib
+ )
++FILE(GLOB Field3d_Includes  "${CMAKE_CURRENT_SOURCE_DIR}/export/*.h")
+ INSTALL ( FILES
+-  export/StdMathLib.h
+-  export/MACFieldIO.h
+-  export/Types.h
+-  export/FieldIO.h
+-  export/PluginLoader.h
+-  export/EmptyField.h
+-  export/Exception.h
+-  export/SpiMathLib.h
+-  export/MACField.h
+-  export/DenseField.h
+-  export/DataTypeConversion.h
+-  export/Hdf5Util.h
+-  export/SparseField.h
+-  export/FieldMapping.h
+-  export/Log.h
+-  export/Field3DFile.h
+-  export/ClassFactory.h
+-  export/RefCount.h
+-  export/Field.h
+-  export/FieldMappingIO.h
+-  export/InitIO.h
+-  export/ns.h
+-  export/SparseFile.h
+-  export/ProceduralField.h
+-  export/FieldInterp.h
+-  export/Documentation.h
+-  export/SparseDataReader.h
+-  export/SparseFieldIO.h
+-  export/MACFieldUtil.h
+-  export/DenseFieldIO.h
++  ${Field3d_Includes}
+   DESTINATION include/Field3D
+ )
++INSTALL( PROGRAMS
++  "${CMAKE_CURRENT_BINARY_DIR}/f3dinfo"
++  DESTINATION bin
++)
++
+ INSTALL (DIRECTORY ${CMAKE_HOME_DIRECTORY}/docs
+   DESTINATION ${CMAKE_INSTALL_PREFIX}
+ )
diff --git a/Field3D.spec b/Field3D.spec
new file mode 100644 (file)
index 0000000..c68f67d
--- /dev/null
@@ -0,0 +1,99 @@
+Summary:       Field3D - open source library for storing voxel data
+Summary(pl.UTF-8):     Field3D - mająca otwarte źródła biblioteka do przechowywania danych vokseli
+Name:          Field3D
+Version:       1.2.0
+Release:       1
+License:       BSD
+Group:         Libraries
+#Source0Download: https://sites.google.com/site/field3d/downloads
+Source0:       http://github.com/imageworks/Field3D/tarball/v%{version}#/%{name}-%{version}.tar.gz
+# Source0-md5: e77d4f6e455860291f8e0e0ce547aa50
+Patch0:                %{name}-install.patch
+URL:           http://opensource.imageworks.com/?p=field3d
+BuildRequires: cmake >= 2.8
+BuildRequires: boost-devel >= 1.34.0
+BuildRequires: doxygen
+BuildRequires: hdf5-devel >= 1.8
+BuildRequires: ilmbase-devel >= 1.0.1
+BuildRequires: libstdc++-devel
+Requires:      hdf5 >= 1.8
+Requires:      ilmbase >= 1.0.1
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Field3D is an open source library for storing voxel data. It provides
+C++ classes that handle in-memory storage and a file format based on
+HDF5 that allows the C++ objects to be written to and read from disk.
+
+%description -l pl.UTF-8
+Field3D to mająca otwarte źródła biblioteka do przechowywania danych
+vokseli. Udostępnia klasy C++ obsługujące przechowywanie ich w pamięci
+oraz format plików oparty na HDF5 pozwalający na zapis i odczyt
+obiektów C++ z dysku.
+
+%package devel
+Summary:       Header files for Field3D library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Field3D
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      boost-devel >= 1.34.0
+Requires:      hdf5-devel >= 1.8
+Requires:      ilmbase-devel >= 1.0.1
+Requires:      libstdc++-devel
+
+%description devel
+Header files for Field3D library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki Field3D.
+
+%package apidocs
+Summary:       Field3D API documentation
+Summary(pl.UTF-8):     Dokumentacja API biblioteki Field3D
+Group:         Documentation
+
+%description apidocs
+API and internal documentation for Field3D library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki Field3D.
+
+%prep
+%setup -q -n imageworks-Field3D-7b8b5d9
+%patch0 -p1
+
+%build
+# main build system is scons, but there is cmake alternative, which is slightly more usable in rpm building
+install -d build
+cd build
+%cmake ..
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/docs
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc CHANGES COPYING README
+%attr(755,root,root) %{_bindir}/f3dinfo
+%attr(755,root,root) %{_libdir}/libField3D.so
+
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/Field3D
+
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/html/*.{css,html,js,png}
This page took 0.130317 seconds and 4 git commands to generate.