]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
update url
[packages/FHS.git] / FHS.spec
1 # TODO
2 # - revise and update to 3.0:
3 #  - https://en.wikipedia.org/wiki/Filesystem_Hierarchy_Standard
4 #  - http://www.linuxfoundation.org/collaborate/workgroups/lsb/fhs
5 # NOTE
6 # - don't use %{_*dir} macros for paths defined by FHS
7 # - do not add any dependencies to this pkg, FHS should be the first package being installed
8 # - do not use any other user/group than "root", as then we have to depend on "setup" package.
9 Summary:        Basic FHS 2.3 filesystem layout
10 Summary(de.UTF-8):      Grundlegende Dateisystemstruktur
11 Summary(fr.UTF-8):      Arborescence de base du système de fichiers
12 Summary(pl.UTF-8):      Podstawowy układ katalogów systemu Linux zgodny z FHS 2.3
13 Summary(tr.UTF-8):      Temel dosya sistemi yapısı
14 Name:           FHS
15 Version:        2.3
16 Release:        39
17 License:        GPL
18 Group:          Base
19 URL:            http://refspecs.linuxfoundation.org/fhs.shtml
20 Source0:        locale-dirs
21 BuildRequires:  mktemp
22 BuildRequires:  rpmbuild(macros) >= 1.213
23 Conflicts:      setup < 2.7
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # nothing to put there
27 %define         _enable_debug_packages  0
28
29 %if "%{_lib}" == "lib64"
30 %define         with_lib64      1
31 %endif
32 %if "%{_lib}" == "libx32"
33 %define         with_libx32     1
34 %define         with_lib64      1
35 %else
36 %ifarch %{x8664}
37 # x32 as additional ABI
38 %define         with_libx32     1
39 %endif
40 %endif
41
42 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
43 %define         __spec_clean_body       %{nil}
44
45 %define         _locmandir      /usr/local/man
46
47 # doesn't contain any files, but we're not noarch package
48 %define         no_install_post_strip   1
49 %define         no_install_post_chrpath 1
50 %define         no_install_post_compress_modules        1
51
52 # we have to use numeric uids/groups. see comment above
53
54 %define         gid_uucp        14
55 %define         gid_mail        12
56
57 %description
58 This package contains the basic directory layout for a Linux system,
59 including the proper permissions for the directories. This layout
60 conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
61
62 %description -l de.UTF-8
63 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
64 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
65 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
66
67 %description -l fr.UTF-8
68 Ce package contient l'arborescence type pour système Linux y compris
69 les permissions adéquates pour les répertoires. Cette arborescence est
70 conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
71
72 %description -l pl.UTF-8
73 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
74 systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
75 2.3.
76
77 %prep
78 %setup -qcT
79 cp -a %{SOURCE0} .
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 install -d \
85         $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,srv} \
86         $RPM_BUILD_ROOT/etc/{X11,opt} \
87         $RPM_BUILD_ROOT/lib/modules \
88         $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
89         $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
90         $RPM_BUILD_ROOT/usr/share/{dict,doc,games,info,misc,tmac,xml} \
91         $RPM_BUILD_ROOT/usr/lib/games \
92         $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
93         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,lock,log,mail,opt,run,spool,tmp,yp}
94
95 %if %{with lib64}
96 install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
97 %endif
98 %if %{with libx32}
99 install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
100 %endif
101
102 install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
103 install -d $RPM_BUILD_ROOT%{_locmandir}/man{1,2,3,4,5,6,7,8}
104
105 # "/usr/local/share/man and /usr/local/man must be synonomous" per FHS 2.3
106 ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
107
108 > %{name}.lang
109 for mloc in $(cat locale-dirs); do
110         echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
111         for manp in man{1,2,3,4,5,6,7,8}; do
112                 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
113                 echo "%%lang($mloc) %dir /usr/share/man/${mloc}/${manp}" >> %{name}.lang
114         done
115 done
116
117 %clean
118 cd $RPM_BUILD_ROOT
119
120 check_filesystem_dirs() {
121         RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
122         TMPFILE=$(mktemp)
123         find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
124
125         # find finds also '.', so use option -B for diff
126         if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
127                 rm -rf $RPM_BUILD_ROOT
128         else
129                 echo -e "\nNot so good, some directories are not included in package\n"
130                 exit 1
131         fi
132         rm -f $TMPFILE
133 }
134 check_filesystem_dirs
135
136 # XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
137 %post -p <lua>
138 posix.chown("/var/mail", 0, %{gid_mail})
139 posix.chown("/var/lock", 0, %{gid_uucp})
140
141 %files -f %{name}.lang
142 %defattr(644,root,root,755)
143 %dir /
144 %dir /bin
145 %dir /boot
146 %dir /dev
147 %dir /etc
148 %dir /etc/X11
149 %dir /etc/opt
150 %dir /home
151 %dir /lib
152 %dir /lib/modules
153 %dir /media
154 %dir /mnt
155 %dir /opt
156 %dir %attr(555,root,root) %verify(not group) /proc
157 %dir %attr(700,root,root) /root
158 %dir %attr(700,root,root) /root/tmp
159 %dir /sbin
160 %dir %attr(755,root,root) /srv
161 %dir %attr(1777,root,root) /tmp
162 %dir /usr
163 %dir /usr/bin
164 %dir /usr/games
165 %dir /usr/include
166 %dir /usr/lib
167 %dir /usr/lib/games
168 %dir /usr/sbin
169 %dir /usr/share
170 %dir /usr/share/dict
171 %dir /usr/share/doc
172 %dir /usr/share/games
173 %dir /usr/share/info
174 %dir /usr/share/man
175 %dir /usr/share/man/man[1-8]
176 %dir /usr/share/misc
177 %dir /usr/share/tmac
178 %dir /usr/share/xml
179 %dir /usr/src
180 %dir /usr/local
181 %dir /usr/local/bin
182 %dir /usr/local/etc
183 %dir /usr/local/games
184 %dir /usr/local/include
185 %dir /usr/local/lib
186 %dir /usr/local/sbin
187 %dir /usr/local/share
188 %dir /usr/local/share/doc
189 %dir /usr/local/share/info
190 /usr/local/share/man
191 %{_locmandir}
192 %dir /usr/local/src
193 %dir /var
194 %dir /var/cache
195 %dir /var/crash
196 %dir /var/db
197 %dir /var/games
198 %dir /var/lib
199 %dir /var/lib/misc
200 %dir /var/local
201 %dir %attr(1771,root,root) /var/lock
202 %dir %attr(751,root,root) /var/log
203 %dir %attr(2775,root,root) /var/mail
204 %dir /var/opt
205 %dir /var/run
206 %dir /var/spool
207 %dir /var/yp
208 %dir %attr(1777,root,root) /var/tmp
209 %if %{with lib64}
210 %dir /lib64
211 %dir /usr/lib64
212 %dir /usr/lib64/games
213 %dir /usr/local/lib64
214 %endif
215 %if %{with libx32}
216 %dir /libx32
217 %dir /usr/libx32
218 %dir /usr/libx32/games
219 %dir /usr/local/libx32
220 %endif
This page took 0.071203 seconds and 3 git commands to generate.