]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
828f7507471ff239f0fa9909a9a09f45c13ee84b
[packages/FHS.git] / FHS.spec
1 # NOTE
2 # - don't use %{_*dir} macros for paths defined by FHS
3 # - do not add any dependencies to this pkg, FHS should be the first package being installed
4 # - do not use any other user/group than "root", as then we have to depend on "setup" package.
5 Summary:        Basic FHS 2.3 filesystem layout
6 Summary(de.UTF-8):      Grundlegende Dateisystemstruktur
7 Summary(fr.UTF-8):      Arborescence de base du système de fichiers
8 Summary(pl.UTF-8):      Podstawowy układ katalogów systemu Linux zgodny z FHS 2.3
9 Summary(tr.UTF-8):      Temel dosya sistemi yapısı
10 Name:           FHS
11 Version:        2.3
12 Release:        27
13 License:        GPL
14 Group:          Base
15 URL:            http://www.pathname.com/fhs/
16 Source0:        locale-dirs
17 BuildRequires:  mktemp
18 BuildRequires:  rpmbuild(macros) >= 1.213
19 Conflicts:      setup < 2.7
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # nothing to put there
23 %define         _enable_debug_packages  0
24
25 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
26 %define         __spec_clean_body       %{nil}
27
28 %define         _locmandir      /usr/local/man
29
30 # doesn't contain any files, but we're not noarch package
31 %define         no_install_post_strip   1
32 %define         no_install_post_chrpath 1
33 %define         no_install_post_compress_modules        1
34
35 # we have to use numeric uids/groups. see comment above
36
37 %define         gid_uucp        14
38 %define         gid_mail        12
39
40 %description
41 This package contains the basic directory layout for a Linux system,
42 including the proper permissions for the directories. This layout
43 conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
44
45 %description -l de.UTF-8
46 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
47 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
48 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
49
50 %description -l fr.UTF-8
51 Ce package contient l'arborescence type pour système Linux y compris
52 les permissions adéquates pour les répertoires. Cette arborescence est
53 conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
54
55 %description -l pl.UTF-8
56 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
57 systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
58 2.3.
59
60 %description -l tr.UTF-8
61 Bu paket GNU makro işleme dilini içerir. Mantıksal olarak
62 ayrıştırılabilen metin dosyaları yazımı için yararlıdır.
63
64 %prep
65 %setup -qc
66 cp -a %{SOURCE0} .
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 install -d \
72         $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,srv} \
73         $RPM_BUILD_ROOT/etc/{X11,opt} \
74         $RPM_BUILD_ROOT/lib/modules \
75         $RPM_BUILD_ROOT/{mnt,media/{cdrom,floppy},proc,root/tmp,sbin,tmp} \
76         $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
77         $RPM_BUILD_ROOT/usr/share/{dict,doc,games,info,misc,tmac,xml} \
78         $RPM_BUILD_ROOT/usr/lib/games \
79         $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
80         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,lock,log,mail,opt,run,spool,tmp,yp}
81
82 %if "%{_lib}" == "lib64"
83 install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
84 %endif
85
86 for manp in man{1,2,3,4,5,6,7,8} ; do
87         install -d $RPM_BUILD_ROOT/usr/share/man/${manp}
88         install -d $RPM_BUILD_ROOT%{_locmandir}/${manp}
89         for mloc in $(cat locale-dirs); do
90                 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
91         done
92 done
93
94 # "/usr/local/share/man and /usr/local/man must be synonomous" per FHS 2.3
95 ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
96
97 %clean
98 cd $RPM_BUILD_ROOT
99
100 check_filesystem_dirs() {
101         RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
102         TMPFILE=$(mktemp)
103         find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
104
105         # find finds also '.', so use option -B for diff
106         if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
107                 rm -rf $RPM_BUILD_ROOT
108         else
109                 echo -e "\nNot so good, some directories are not included in package\n"
110                 exit 1
111         fi
112         rm -f $TMPFILE
113 }
114 check_filesystem_dirs
115
116 # XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
117 %post -p <lua>
118 posix.chown("/var/mail", 0, %{gid_mail})
119 posix.chown("/var/lock", 0, %{gid_uucp})
120
121 %files
122 %defattr(644,root,root,755)
123 %dir /
124 %dir /bin
125 %dir /boot
126 %dir /dev
127 %dir /etc
128 %dir /etc/X11
129 %dir /etc/opt
130 %dir /home
131 %dir /lib
132 %dir /lib/modules
133 %dir %attr(775,root,root) /media
134 %dir %attr(775,root,root) %verify(not group) /media/floppy
135 %dir %attr(775,root,root) %verify(not group) /media/cdrom
136 %dir /mnt
137 %dir /opt
138 %dir %attr(555,root,root) %verify(not group) /proc
139 %dir %attr(700,root,root) /root
140 %dir %attr(700,root,root) /root/tmp
141 %dir /sbin
142 %dir %attr(755,root,root) /srv
143 %dir %attr(1777,root,root) /tmp
144 %dir /usr
145 %dir /usr/bin
146 %dir /usr/games
147 %dir /usr/include
148 %dir /usr/lib
149 %dir /usr/lib/games
150 %dir /usr/sbin
151 %dir /usr/share
152 %dir /usr/share/dict
153 %dir /usr/share/doc
154 %dir /usr/share/games
155 %dir /usr/share/info
156 %dir /usr/share/man
157 %dir /usr/share/man/man[1-8]
158 %lang(bg) /usr/share/man/bg
159 %lang(ca) /usr/share/man/ca
160 %lang(cs) /usr/share/man/cs
161 %lang(da) /usr/share/man/da
162 %lang(de) /usr/share/man/de
163 %lang(el) /usr/share/man/el
164 %lang(eo) /usr/share/man/eo
165 %lang(es) /usr/share/man/es
166 %lang(fi) /usr/share/man/fi
167 %lang(fr) /usr/share/man/fr
168 %lang(gl) /usr/share/man/gl
169 %lang(hr) /usr/share/man/hr
170 %lang(hu) /usr/share/man/hu
171 %lang(id) /usr/share/man/id
172 %lang(it) /usr/share/man/it
173 %lang(ja) /usr/share/man/ja
174 %lang(ko) /usr/share/man/ko
175 %lang(lt) /usr/share/man/lt
176 %lang(nl) /usr/share/man/nl
177 %lang(pl) /usr/share/man/pl
178 %lang(pt) /usr/share/man/pt
179 %lang(pt_BR) /usr/share/man/pt_BR
180 %lang(ro) /usr/share/man/ro
181 %lang(ru) /usr/share/man/ru
182 %lang(sl) /usr/share/man/sl
183 %lang(sk) /usr/share/man/sk
184 %lang(sr) /usr/share/man/sr
185 %lang(sv) /usr/share/man/sv
186 %lang(tr) /usr/share/man/tr
187 %lang(uk) /usr/share/man/uk
188 %lang(zh_CN) /usr/share/man/zh_CN
189 %lang(zh_TW) /usr/share/man/zh_TW
190 %dir /usr/share/misc
191 %dir /usr/share/tmac
192 %dir /usr/share/xml
193 %dir /usr/src
194 %dir /usr/local
195 %dir /usr/local/bin
196 %dir /usr/local/etc
197 %dir /usr/local/games
198 %dir /usr/local/include
199 %dir /usr/local/lib
200 %dir /usr/local/sbin
201 %dir /usr/local/share
202 %dir /usr/local/share/doc
203 %dir /usr/local/share/info
204 /usr/local/share/man
205 %{_locmandir}
206 %dir /usr/local/src
207 %dir /var
208 %dir /var/cache
209 %dir /var/crash
210 %dir /var/db
211 %dir /var/games
212 %dir /var/lib
213 %dir /var/lib/misc
214 %dir /var/local
215 %dir %attr(1771,root,root) /var/lock
216 %dir %attr(751,root,root) /var/log
217 %dir %attr(2775,root,root) /var/mail
218 %dir /var/opt
219 %dir /var/run
220 %dir /var/spool
221 %dir /var/yp
222 %dir %attr(1777,root,root) /var/tmp
223 %if "%{_lib}" == "lib64"
224 %dir /lib64
225 %dir /usr/lib64
226 %dir /usr/lib64/games
227 %dir /usr/local/lib64
228 %endif
This page took 0.052445 seconds and 2 git commands to generate.