]> git.pld-linux.org Git - packages/FHS.git/blame - FHS.spec
- rel 21
[packages/FHS.git] / FHS.spec
CommitLineData
d8cf4cdf 1# NOTE: don't use %{_*dir} macros for paths defined by FHS
7807a3bf 2Summary: Basic FHS 2.3 filesystem layout
d280bbd7
ER
3Summary(de.UTF-8): Grundlegende Dateisystemstruktur
4Summary(fr.UTF-8): Arborescence de base du système de fichiers
5Summary(pl.UTF-8): Podstawowy układ katalogów systemu Linux zgodny z FHS 2.3
6Summary(tr.UTF-8): Temel dosya sistemi yapısı
b3b300be 7Name: FHS
7807a3bf 8Version: 2.3
1baea29c 9Release: 21
15c9b486 10License: GPL
11Group: Base
8eaadcf0 12URL: http://www.pathname.com/fhs/
73559f52 13BuildRequires: rpmbuild(macros) >= 1.213
e4b30691 14Requires: setup >= 2.4.6-4
8ad4c704 15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15c9b486 16
1a35d806 17%define _locmandir /usr/local/man
99177468 18%define no_install_post_strip 1
0fa811e0 19
15c9b486 20%description
aac153be 21This package contains the basic directory layout for a Linux system,
22including the proper permissions for the directories. This layout
7807a3bf 23conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
15c9b486 24
fdedb1f3
JR
25%description -l de.UTF-8
26Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
27Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
7807a3bf 28Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
15c9b486 29
fdedb1f3
JR
30%description -l fr.UTF-8
31Ce package contient l'arborescence type pour système Linux y compris
32les permissions adéquates pour les répertoires. Cette arborescence est
69503c43 33conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
15c9b486 34
fdedb1f3
JR
35%description -l pl.UTF-8
36Pakiet ten zawiera informacje o podstawowej strukturze katalogów
37systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
7807a3bf 382.3.
aac153be 39
fdedb1f3
JR
40%description -l tr.UTF-8
41Bu paket GNU makro işleme dilini içerir. Mantıksal olarak
42ayrıştırılabilen metin dosyaları yazımı için yararlıdır.
15c9b486 43
44%prep
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
d8cf4cdf
JB
49install -d \
50 $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,srv} \
51 $RPM_BUILD_ROOT/etc/{X11,opt} \
52 $RPM_BUILD_ROOT/lib/modules \
7807a3bf 53 $RPM_BUILD_ROOT/{mnt,media/{cdrom,floppy},proc,root,sbin,tmp} \
d8cf4cdf 54 $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
017dd5c9 55 $RPM_BUILD_ROOT/usr/share/{dict,doc,games,info,misc,tmac,xml} \
d8cf4cdf
JB
56 $RPM_BUILD_ROOT/usr/lib/games \
57 $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
48784dc4 58 $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,lock,log,mail,opt,run,spool,tmp,yp}
d8cf4cdf
JB
59
60%if "%{_lib}" == "lib64"
61install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
76796e14
JB
62%endif
63
45af740b 64for manp in man{1,2,3,4,5,6,7,8} ; do
d8cf4cdf 65 install -d $RPM_BUILD_ROOT/usr/share/man/${manp}
0fa811e0 66 install -d $RPM_BUILD_ROOT%{_locmandir}/${manp}
80d1ef5a
PG
67 for mloc in bg ca cs da de el eo es fi fr gl hr hu id it ja ko nl pl \
68 pt pt_BR ro ru sk sl sr sv tr uk zh_CN zh_TW ; do
d8cf4cdf 69 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
0fa811e0 70 done
0fa811e0 71done
0fa811e0 72
d8cf4cdf 73# "/usr/local/share/man and /usr/local/man must be synonomous" per FHS 2.3
9d1c44e3
JB
74ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
75
15c9b486 76%clean
fa9aa6bf 77cd $RPM_BUILD_ROOT
0a75495b 78
fa9aa6bf 79# %{_rpmfilename} is not expanded, so use
0a75495b 80# %{name}-%{version}-%{release}.%{buildarch}.rpm
76796e14 81RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
0a75495b 82TMPFILE=%{name}-%{version}.tmp$$
83find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE > $TMPFILE
84
85# find finds also '.', so use option -B for diff
52e00ac5 86if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | sort | diff -uB $TMPFILE - ; then
fa9aa6bf
TP
87 rm -rf $RPM_BUILD_ROOT
88else
8c87a904 89 echo -e "\nNot so good, some directories are not included in package\n"
7cdc817f 90 exit 1;
0a75495b 91fi
15c9b486 92
93%files
bfef5768 94%defattr(644,root,root,755)
52e00ac5 95%dir /
d8cf4cdf
JB
96%dir /bin
97%dir /boot
98%dir /dev
2d4f80d5 99%dir /etc
d8cf4cdf
JB
100%dir /etc/X11
101%dir /etc/opt
b9fc8087 102%dir /home
d8cf4cdf
JB
103%dir /lib
104%dir /lib/modules
7807a3bf 105%attr(775,root,disk) %dir /media
106%attr(775,root,disk) /media/floppy
107%attr(775,root,disk) /media/cdrom
d8cf4cdf
JB
108%dir /mnt
109%dir /opt
adf03d52 110%attr(555,root,proc) %verify(not group) /proc
15c9b486 111%attr(700,root,root) /root
112%dir /sbin
7807a3bf 113%attr(751,root,root) /srv
15c9b486 114%attr(1777,root,root) /tmp
d8cf4cdf
JB
115%dir /usr
116%dir /usr/bin
117%dir /usr/games
118%dir /usr/include
119%dir /usr/lib
120%dir /usr/lib/games
121%dir /usr/sbin
122%dir /usr/share
123%dir /usr/share/dict
124%dir /usr/share/doc
125%dir /usr/share/games
126%dir /usr/share/info
d8cf4cdf
JB
127%dir /usr/share/man
128%dir /usr/share/man/man[1-8]
129%lang(bg) /usr/share/man/bg
fb84e090 130%lang(ca) /usr/share/man/ca
d8cf4cdf
JB
131%lang(cs) /usr/share/man/cs
132%lang(da) /usr/share/man/da
133%lang(de) /usr/share/man/de
134%lang(el) /usr/share/man/el
80d1ef5a 135%lang(eo) /usr/share/man/eo
d8cf4cdf
JB
136%lang(es) /usr/share/man/es
137%lang(fi) /usr/share/man/fi
138%lang(fr) /usr/share/man/fr
139%lang(gl) /usr/share/man/gl
140%lang(hr) /usr/share/man/hr
141%lang(hu) /usr/share/man/hu
142%lang(id) /usr/share/man/id
143%lang(it) /usr/share/man/it
144%lang(ja) /usr/share/man/ja
145%lang(ko) /usr/share/man/ko
146%lang(nl) /usr/share/man/nl
147%lang(pl) /usr/share/man/pl
148%lang(pt) /usr/share/man/pt
149%lang(pt_BR) /usr/share/man/pt_BR
150%lang(ro) /usr/share/man/ro
151%lang(ru) /usr/share/man/ru
152%lang(sl) /usr/share/man/sl
153%lang(sk) /usr/share/man/sk
154%lang(sr) /usr/share/man/sr
155%lang(sv) /usr/share/man/sv
156%lang(tr) /usr/share/man/tr
157%lang(uk) /usr/share/man/uk
158%lang(zh_CN) /usr/share/man/zh_CN
159%lang(zh_TW) /usr/share/man/zh_TW
160%dir /usr/share/misc
161%dir /usr/share/tmac
017dd5c9 162%dir /usr/share/xml
d8cf4cdf
JB
163%dir /usr/src
164%dir /usr/local
165%dir /usr/local/bin
166%dir /usr/local/etc
167%dir /usr/local/games
168%dir /usr/local/include
169%dir /usr/local/lib
170%dir /usr/local/sbin
171%dir /usr/local/share
172%dir /usr/local/share/doc
173%dir /usr/local/share/info
174/usr/local/share/man
0fa811e0 175%{_locmandir}
d8cf4cdf 176%dir /usr/local/src
15c9b486 177%dir /var
d8cf4cdf 178%dir /var/cache
0a75495b 179%dir /var/crash
15c9b486 180%dir /var/db
15c9b486 181%dir /var/games
dff2ec9d 182%dir /var/lib
0a75495b 183%dir /var/lib/misc
e7f27a78 184%dir /var/local
9a1c7481 185%attr(1771,root,uucp) %dir /var/lock
bd82a0d2 186%attr(751,root,root) /var/log
98c64a3c 187%attr(2775,root,mail) /var/mail
15c9b486 188%dir /var/opt
0a75495b 189%dir /var/run
2d4f80d5 190%dir /var/spool
48784dc4 191%dir /var/yp
15c9b486 192%attr(1777,root,root) %dir /var/tmp
d8cf4cdf
JB
193%if "%{_lib}" == "lib64"
194%dir /lib64
195%dir /usr/lib64
196%dir /usr/lib64/games
197%dir /usr/local/lib64
76796e14 198%endif
This page took 0.061648 seconds and 4 git commands to generate.