]> git.pld-linux.org Git - packages/FHS.git/blame - FHS.spec
- tabs in preamle
[packages/FHS.git] / FHS.spec
CommitLineData
d8cf4cdf 1# NOTE: don't use %{_*dir} macros for paths defined by FHS
7807a3bf 2Summary: Basic FHS 2.3 filesystem layout
d280bbd7
ER
3Summary(de.UTF-8): Grundlegende Dateisystemstruktur
4Summary(fr.UTF-8): Arborescence de base du système de fichiers
5Summary(pl.UTF-8): Podstawowy układ katalogów systemu Linux zgodny z FHS 2.3
6Summary(tr.UTF-8): Temel dosya sistemi yapısı
b3b300be 7Name: FHS
7807a3bf 8Version: 2.3
fb84e090 9Release: 17
15c9b486 10License: GPL
11Group: Base
8eaadcf0 12URL: http://www.pathname.com/fhs/
73559f52 13BuildRequires: rpmbuild(macros) >= 1.213
e4b30691 14Requires: setup >= 2.4.6-4
8ad4c704 15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15c9b486 16
1a35d806 17%define _locmandir /usr/local/man
0fa811e0 18
15c9b486 19%description
aac153be 20This package contains the basic directory layout for a Linux system,
21including the proper permissions for the directories. This layout
7807a3bf 22conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
15c9b486 23
fdedb1f3
JR
24%description -l de.UTF-8
25Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
26Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
7807a3bf 27Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
15c9b486 28
fdedb1f3
JR
29%description -l fr.UTF-8
30Ce package contient l'arborescence type pour système Linux y compris
31les permissions adéquates pour les répertoires. Cette arborescence est
69503c43 32conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
15c9b486 33
fdedb1f3
JR
34%description -l pl.UTF-8
35Pakiet ten zawiera informacje o podstawowej strukturze katalogów
36systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
7807a3bf 372.3.
aac153be 38
fdedb1f3
JR
39%description -l tr.UTF-8
40Bu paket GNU makro işleme dilini içerir. Mantıksal olarak
41ayrıştırılabilen metin dosyaları yazımı için yararlıdır.
15c9b486 42
43%prep
44
45%install
46rm -rf $RPM_BUILD_ROOT
47
d8cf4cdf
JB
48install -d \
49 $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,srv} \
50 $RPM_BUILD_ROOT/etc/{X11,opt} \
51 $RPM_BUILD_ROOT/lib/modules \
7807a3bf 52 $RPM_BUILD_ROOT/{mnt,media/{cdrom,floppy},proc,root,sbin,tmp} \
d8cf4cdf 53 $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
017dd5c9 54 $RPM_BUILD_ROOT/usr/share/{dict,doc,games,info,misc,tmac,xml} \
d8cf4cdf
JB
55 $RPM_BUILD_ROOT/usr/lib/games \
56 $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
57 $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,lock,log,mail,opt,run,spool,tmp}
58
59%if "%{_lib}" == "lib64"
60install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
76796e14
JB
61%endif
62
45af740b 63for manp in man{1,2,3,4,5,6,7,8} ; do
d8cf4cdf 64 install -d $RPM_BUILD_ROOT/usr/share/man/${manp}
0fa811e0 65 install -d $RPM_BUILD_ROOT%{_locmandir}/${manp}
fb84e090 66 for mloc in bg ca cs da de el es fi fr gl hr hu id it ja ko nl pl pt \
abfb5a6c 67 pt_BR ro ru sk sl sr sv tr uk zh_CN zh_TW ; do
d8cf4cdf 68 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
0fa811e0 69 done
0fa811e0 70done
0fa811e0 71
d8cf4cdf 72# "/usr/local/share/man and /usr/local/man must be synonomous" per FHS 2.3
9d1c44e3
JB
73ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
74
15c9b486 75%clean
fa9aa6bf 76cd $RPM_BUILD_ROOT
0a75495b 77
fa9aa6bf 78# %{_rpmfilename} is not expanded, so use
0a75495b 79# %{name}-%{version}-%{release}.%{buildarch}.rpm
76796e14 80RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
0a75495b 81TMPFILE=%{name}-%{version}.tmp$$
82find . | sed -e 's|^\.||g' -e 's|^$||g' | sort | grep -v $TMPFILE > $TMPFILE
83
84# find finds also '.', so use option -B for diff
52e00ac5 85if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | sort | diff -uB $TMPFILE - ; then
fa9aa6bf
TP
86 rm -rf $RPM_BUILD_ROOT
87else
8c87a904 88 echo -e "\nNot so good, some directories are not included in package\n"
7cdc817f 89 exit 1;
0a75495b 90fi
15c9b486 91
92%files
bfef5768 93%defattr(644,root,root,755)
52e00ac5 94%dir /
d8cf4cdf
JB
95%dir /bin
96%dir /boot
97%dir /dev
2d4f80d5 98%dir /etc
d8cf4cdf
JB
99%dir /etc/X11
100%dir /etc/opt
b9fc8087 101%dir /home
d8cf4cdf
JB
102%dir /lib
103%dir /lib/modules
7807a3bf 104%attr(775,root,disk) %dir /media
105%attr(775,root,disk) /media/floppy
106%attr(775,root,disk) /media/cdrom
d8cf4cdf
JB
107%dir /mnt
108%dir /opt
adf03d52 109%attr(555,root,proc) %verify(not group) /proc
15c9b486 110%attr(700,root,root) /root
111%dir /sbin
7807a3bf 112%attr(751,root,root) /srv
15c9b486 113%attr(1777,root,root) /tmp
d8cf4cdf
JB
114%dir /usr
115%dir /usr/bin
116%dir /usr/games
117%dir /usr/include
118%dir /usr/lib
119%dir /usr/lib/games
120%dir /usr/sbin
121%dir /usr/share
122%dir /usr/share/dict
123%dir /usr/share/doc
124%dir /usr/share/games
125%dir /usr/share/info
d8cf4cdf
JB
126%dir /usr/share/man
127%dir /usr/share/man/man[1-8]
128%lang(bg) /usr/share/man/bg
fb84e090 129%lang(ca) /usr/share/man/ca
d8cf4cdf
JB
130%lang(cs) /usr/share/man/cs
131%lang(da) /usr/share/man/da
132%lang(de) /usr/share/man/de
133%lang(el) /usr/share/man/el
134%lang(es) /usr/share/man/es
135%lang(fi) /usr/share/man/fi
136%lang(fr) /usr/share/man/fr
137%lang(gl) /usr/share/man/gl
138%lang(hr) /usr/share/man/hr
139%lang(hu) /usr/share/man/hu
140%lang(id) /usr/share/man/id
141%lang(it) /usr/share/man/it
142%lang(ja) /usr/share/man/ja
143%lang(ko) /usr/share/man/ko
144%lang(nl) /usr/share/man/nl
145%lang(pl) /usr/share/man/pl
146%lang(pt) /usr/share/man/pt
147%lang(pt_BR) /usr/share/man/pt_BR
148%lang(ro) /usr/share/man/ro
149%lang(ru) /usr/share/man/ru
150%lang(sl) /usr/share/man/sl
151%lang(sk) /usr/share/man/sk
152%lang(sr) /usr/share/man/sr
153%lang(sv) /usr/share/man/sv
154%lang(tr) /usr/share/man/tr
155%lang(uk) /usr/share/man/uk
156%lang(zh_CN) /usr/share/man/zh_CN
157%lang(zh_TW) /usr/share/man/zh_TW
158%dir /usr/share/misc
159%dir /usr/share/tmac
017dd5c9 160%dir /usr/share/xml
d8cf4cdf
JB
161%dir /usr/src
162%dir /usr/local
163%dir /usr/local/bin
164%dir /usr/local/etc
165%dir /usr/local/games
166%dir /usr/local/include
167%dir /usr/local/lib
168%dir /usr/local/sbin
169%dir /usr/local/share
170%dir /usr/local/share/doc
171%dir /usr/local/share/info
172/usr/local/share/man
0fa811e0 173%{_locmandir}
d8cf4cdf 174%dir /usr/local/src
15c9b486 175%dir /var
d8cf4cdf 176%dir /var/cache
0a75495b 177%dir /var/crash
15c9b486 178%dir /var/db
15c9b486 179%dir /var/games
dff2ec9d 180%dir /var/lib
0a75495b 181%dir /var/lib/misc
e7f27a78 182%dir /var/local
9a1c7481 183%attr(1771,root,uucp) %dir /var/lock
bd82a0d2 184%attr(751,root,root) /var/log
98c64a3c 185%attr(2775,root,mail) /var/mail
15c9b486 186%dir /var/opt
0a75495b 187%dir /var/run
2d4f80d5 188%dir /var/spool
15c9b486 189%attr(1777,root,root) %dir /var/tmp
d8cf4cdf
JB
190%if "%{_lib}" == "lib64"
191%dir /lib64
192%dir /usr/lib64
193%dir /usr/lib64/games
194%dir /usr/local/lib64
76796e14 195%endif
This page took 0.053331 seconds and 4 git commands to generate.