]> git.pld-linux.org Git - packages/FHS.git/blame - FHS.spec
add todo for 3.0, released on 3 June 2015
[packages/FHS.git] / FHS.spec
CommitLineData
fa94c830
ER
1# TODO
2# - revise and update to 3.0:
3# - https://en.wikipedia.org/wiki/Filesystem_Hierarchy_Standard
4# - http://www.linuxfoundation.org/collaborate/workgroups/lsb/fhs
2fccd05c
ER
5# NOTE
6# - don't use %{_*dir} macros for paths defined by FHS
05fbeea7
ER
7# - do not add any dependencies to this pkg, FHS should be the first package being installed
8# - do not use any other user/group than "root", as then we have to depend on "setup" package.
7807a3bf 9Summary: Basic FHS 2.3 filesystem layout
d280bbd7
ER
10Summary(de.UTF-8): Grundlegende Dateisystemstruktur
11Summary(fr.UTF-8): Arborescence de base du système de fichiers
12Summary(pl.UTF-8): Podstawowy układ katalogów systemu Linux zgodny z FHS 2.3
13Summary(tr.UTF-8): Temel dosya sistemi yapısı
b3b300be 14Name: FHS
7807a3bf 15Version: 2.3
57d439f5 16Release: 39
15c9b486 17License: GPL
18Group: Base
8eaadcf0 19URL: http://www.pathname.com/fhs/
38ec8b96 20Source0: locale-dirs
2fccd05c 21BuildRequires: mktemp
73559f52 22BuildRequires: rpmbuild(macros) >= 1.213
05fbeea7 23Conflicts: setup < 2.7
8ad4c704 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15c9b486 25
5a4e441c
ER
26# nothing to put there
27%define _enable_debug_packages 0
28
335736da
JB
29%if "%{_lib}" == "lib64"
30%define with_lib64 1
335736da
JB
31%endif
32%if "%{_lib}" == "libx32"
33%define with_libx32 1
57d439f5 34%define with_lib64 1
335736da
JB
35%else
36%ifarch %{x8664}
37# x32 as additional ABI
38%define with_libx32 1
39%endif
40%endif
41
5a4e441c
ER
42# avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
43%define __spec_clean_body %{nil}
44
1a35d806 45%define _locmandir /usr/local/man
2fccd05c 46
6c95f275 47# doesn't contain any files, but we're not noarch package
99177468 48%define no_install_post_strip 1
6c95f275
ER
49%define no_install_post_chrpath 1
50%define no_install_post_compress_modules 1
0fa811e0 51
05fbeea7
ER
52# we have to use numeric uids/groups. see comment above
53
54%define gid_uucp 14
55%define gid_mail 12
56
15c9b486 57%description
aac153be 58This package contains the basic directory layout for a Linux system,
59including the proper permissions for the directories. This layout
7807a3bf 60conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
15c9b486 61
fdedb1f3
JR
62%description -l de.UTF-8
63Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
64Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
7807a3bf 65Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
15c9b486 66
fdedb1f3
JR
67%description -l fr.UTF-8
68Ce package contient l'arborescence type pour système Linux y compris
69les permissions adéquates pour les répertoires. Cette arborescence est
69503c43 70conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
15c9b486 71
fdedb1f3
JR
72%description -l pl.UTF-8
73Pakiet ten zawiera informacje o podstawowej strukturze katalogów
74systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
7807a3bf 752.3.
aac153be 76
15c9b486 77%prep
40188a0f 78%setup -qcT
38ec8b96 79cp -a %{SOURCE0} .
15c9b486 80
81%install
82rm -rf $RPM_BUILD_ROOT
83
d8cf4cdf
JB
84install -d \
85 $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,srv} \
86 $RPM_BUILD_ROOT/etc/{X11,opt} \
87 $RPM_BUILD_ROOT/lib/modules \
d13739ad 88 $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
d8cf4cdf 89 $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
017dd5c9 90 $RPM_BUILD_ROOT/usr/share/{dict,doc,games,info,misc,tmac,xml} \
d8cf4cdf
JB
91 $RPM_BUILD_ROOT/usr/lib/games \
92 $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
48784dc4 93 $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,lock,log,mail,opt,run,spool,tmp,yp}
d8cf4cdf 94
335736da 95%if %{with lib64}
d8cf4cdf 96install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
9d2de01c 97%endif
335736da 98%if %{with libx32}
9d2de01c 99install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
76796e14
JB
100%endif
101
42b7266a
ER
102install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
103install -d $RPM_BUILD_ROOT%{_locmandir}/man{1,2,3,4,5,6,7,8}
0fa811e0 104
d8cf4cdf 105# "/usr/local/share/man and /usr/local/man must be synonomous" per FHS 2.3
9d1c44e3
JB
106ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
107
42b7266a
ER
108> %{name}.lang
109for mloc in $(cat locale-dirs); do
110 echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
111 for manp in man{1,2,3,4,5,6,7,8}; do
112 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
113 echo "%%lang($mloc) %dir /usr/share/man/${mloc}/${manp}" >> %{name}.lang
114 done
115done
116
15c9b486 117%clean
fa9aa6bf 118cd $RPM_BUILD_ROOT
0a75495b 119
2fccd05c 120check_filesystem_dirs() {
2fccd05c
ER
121 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
122 TMPFILE=$(mktemp)
48e57f98 123 find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
2fccd05c
ER
124
125 # find finds also '.', so use option -B for diff
126 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
127 rm -rf $RPM_BUILD_ROOT
128 else
129 echo -e "\nNot so good, some directories are not included in package\n"
130 exit 1
131 fi
132 rm -f $TMPFILE
133}
134check_filesystem_dirs
15c9b486 135
05fbeea7
ER
136# XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
137%post -p <lua>
138posix.chown("/var/mail", 0, %{gid_mail})
139posix.chown("/var/lock", 0, %{gid_uucp})
140
42b7266a 141%files -f %{name}.lang
bfef5768 142%defattr(644,root,root,755)
52e00ac5 143%dir /
d8cf4cdf
JB
144%dir /bin
145%dir /boot
146%dir /dev
2d4f80d5 147%dir /etc
d8cf4cdf
JB
148%dir /etc/X11
149%dir /etc/opt
b9fc8087 150%dir /home
d8cf4cdf
JB
151%dir /lib
152%dir /lib/modules
d13739ad 153%dir /media
d8cf4cdf
JB
154%dir /mnt
155%dir /opt
6c511447
ER
156%dir %attr(555,root,root) %verify(not group) /proc
157%dir %attr(700,root,root) /root
ef2d028b 158%dir %attr(700,root,root) /root/tmp
15c9b486 159%dir /sbin
6c511447
ER
160%dir %attr(755,root,root) /srv
161%dir %attr(1777,root,root) /tmp
d8cf4cdf
JB
162%dir /usr
163%dir /usr/bin
164%dir /usr/games
165%dir /usr/include
166%dir /usr/lib
167%dir /usr/lib/games
168%dir /usr/sbin
169%dir /usr/share
170%dir /usr/share/dict
171%dir /usr/share/doc
172%dir /usr/share/games
173%dir /usr/share/info
d8cf4cdf
JB
174%dir /usr/share/man
175%dir /usr/share/man/man[1-8]
d8cf4cdf
JB
176%dir /usr/share/misc
177%dir /usr/share/tmac
017dd5c9 178%dir /usr/share/xml
d8cf4cdf
JB
179%dir /usr/src
180%dir /usr/local
181%dir /usr/local/bin
182%dir /usr/local/etc
183%dir /usr/local/games
184%dir /usr/local/include
185%dir /usr/local/lib
186%dir /usr/local/sbin
187%dir /usr/local/share
188%dir /usr/local/share/doc
189%dir /usr/local/share/info
190/usr/local/share/man
0fa811e0 191%{_locmandir}
d8cf4cdf 192%dir /usr/local/src
15c9b486 193%dir /var
d8cf4cdf 194%dir /var/cache
0a75495b 195%dir /var/crash
15c9b486 196%dir /var/db
15c9b486 197%dir /var/games
dff2ec9d 198%dir /var/lib
0a75495b 199%dir /var/lib/misc
e7f27a78 200%dir /var/local
6c511447
ER
201%dir %attr(1771,root,root) /var/lock
202%dir %attr(751,root,root) /var/log
203%dir %attr(2775,root,root) /var/mail
15c9b486 204%dir /var/opt
0a75495b 205%dir /var/run
2d4f80d5 206%dir /var/spool
48784dc4 207%dir /var/yp
6c511447 208%dir %attr(1777,root,root) /var/tmp
335736da 209%if %{with lib64}
d8cf4cdf
JB
210%dir /lib64
211%dir /usr/lib64
212%dir /usr/lib64/games
213%dir /usr/local/lib64
9d2de01c 214%endif
335736da 215%if %{with libx32}
9d2de01c
JR
216%dir /libx32
217%dir /usr/libx32
218%dir /usr/libx32/games
219%dir /usr/local/libx32
76796e14 220%endif
This page took 0.060101 seconds and 4 git commands to generate.